Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
NVidia Grafik Treiber funktioniert nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
NVidia-Problem
Gast





BeitragVerfasst am: 17. Feb 2007 17:32   Titel: NVidia Grafik Treiber funktioniert nicht

Der X-Server startet nicht mehr und gibt folgendes Protokoll aus:

X Window System Version 7.1.1
Release Date 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Built Operating System: Linux 2.6.15.7 1686
Current operating System: Linux Computer 2.6.17-11-generic #2 SMP Thu
Feb 1 19:52:28 UTC 2007 1686
Build date: 07 July 2006
Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) Informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 17 17:24:04 2007
(==) Using config file: "/etc/X11/xorg.conf"
Error: API mismatch: the NVIDIA kernel module has the version
1.0-7184, but
this X module has the version 1.0-9746. Please make sure that the kernel
medule and all NVIDIA driver components have the same version
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details
(EE) NVIDIA(0): *** Aborting ***
(EE) NVIDIA(0): Screen(s) found, but none have a usuable configuration

Fatal server error:
no screens found.

Ich benutze Ubuntu Edgy Eft (6.10), folgenden Treiber:
http://www.nvidia.com/object/linux_display_ia32_1.0-9746.html
Und ein Mainboard mit einer NVIDIA GeForce 6 Graphics Processing Unit.

Kann mir jemand helfen? Ich bin noch ein ziemlicher Neuling Sad
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 17. Feb 2007 17:54   Titel:

Zitat:
Code:
Error: API mismatch: the NVIDIA kernel module has the version
 1.0-7184, but
 this X module has the version 1.0-9746. Please make sure that the kernel
 medule and all NVIDIA driver components have the same version


Sagt eigentlich schon alles. Das Nvidia-Kernelmodul stammt aus einer anderen Installation des Treibers als der Treiber für X. Am besten, du führst die Installation nochmal mit dem neuesten nVidia-Treiberpaket durch. Sollte das falsche Kernelmodul ebenfalls weghauen und durch das passende ersetzen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

NVIDIA-Problem
Gast





BeitragVerfasst am: 17. Feb 2007 17:58   Titel:

Das Problem ist nur, laut NVIDIA-Seite IST das bereits der neueste Treiber, den ich oben verlinkt habe
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 17. Feb 2007 19:13   Titel:

Bitte lies dir meine Antwort oben genau durch! Der Treiber besteht aus zwei Teilen, dem Kernelmodul, und dem Treiber für X. Beide müssen von der selben Treiberversion stammen. Der Fehler besagt, dass das Kernelmodul aus einer alten Treiberversion stammt.

Evtl. hat bei der Installation der neuen Treiberversion etwas nicht geklappt. Also nochmal drüberinstallieren, wie von nVidia beschrieben.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Ubuntu-Pupil
Gast





BeitragVerfasst am: 17. Feb 2007 20:23   Titel:

Ich beschreibe mal meinen Installationsvorgang:
Root-Rechte, telinit 3, sh NVIDIA...................run

Lizenzvereinbahrung -> Ich wähle "Accept"

"There appears to already be a driver installed on your system (version:1.0-9746). As part of installing this driver (version: 1.0-9746), the existing driver will be uninstalled. Are you sure you want to continue

"YES"

"No precompiled kernel interface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from the NVIDIA ftp site (ftp://download.nvidia.com)?

"YES" (meine Auswahl)

"No matching precompiled kernel interface was found on the NVIDIA ftp site; this means that the installer will need to compile a kernel interface for your kernel.

"OK" (meine Auswahl)

"WARNING: nvidia-installer was forced to guess the X library path '/usr/lib' and X module path '/use/lib/xorg/modules'; these paths were not queryable from the system. If X fails to find the NVIDIA X driver module, please install the 'pkg-config' utility and the X.Org SDK/Development package for your distribution and reinstall the driver."

"OK" (meine Auswahl)

"Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that the NVIDIA X driver will be used when you restart X? Any pre-existing X configuration file will be backed up.

"YES" (meine Auswahl)

"Your X configuration file has been successfully updated. Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86 (version: 1.0-9746) is now complete"

"OK" (meine Auswahl)

reboot

-> X Server startet nicht.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 18. Feb 2007 0:18   Titel:

Du kannst ja mal versuchen, Debug-Output aus dem Installer zu bekommen:

Code:

# nvidia-installer --sanity


Mehr Optionen gibt es mit "-A" (all help)

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 18. Feb 2007 13:44   Titel:

Stelle sicher, dass das Kernelmodul entladen ist
Code:
init 3
modprobe -r nvidia
lsmod | less
(sollte kein nvidia mehr da sein)
Lösche nvidia.ko aus /lib/modules/....../video,
führe dann
Code:
depmod -ae
durch,
das entfernt das Kernelmodul und die Referenzen darauf.
Lösche in /lib und /usr/lib und /X11/lib alles was *nvidia* heisst, dann
Code:
ldconfig -v


Eigentlich macht der Installer dasselbe, aber wenn er nicht funktioniert?
_________________
mfg komsomolze
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy