Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit video1394

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
soxx
Gast





BeitragVerfasst am: 10. März 2007 17:41   Titel: Probleme mit video1394

Hallo !

Ich habe Probleme mit den Firewire Treibern.
Machmal funktioniert Coriander - ein Tool, das den Firewirekamera - Stream anzeigen kann.
Wie gesagt funktioniert dieses Tool nur ab und zu.
Ich verwende Ubuntu und bei modprobe werden mir alle module angezeigt:

root@pc:/dev# lsmod | grep 1394
video1394 20300 0
raw1394 30956 0
dv1394 21196 0
ohci1394 35124 2 video1394,dv1394
ieee1394 299832 4 video1394,raw1394,dv1394,ohci1394
scsi_mod 139496 5 sg,sr_mod,sd_mod,ahci,libata



Bei einer anderen Software bekomme ich jedoch immer folgende Warnung:

(dc1394_capture.c) unable to open video1394 device /dev/video1394-0
dc1394_capture.c: No such file or directory


bei der installation habe ich folgendes gemacht.
mknod /dev/raw1394 c 171 0
chmod 666 /dev/raw1394
mknod /dev/video1394 c 171 16




In einem bash skript habe ich folgendes stehen.

rm -r /dev/video1394
rm /dev/video1394-0
rm /dev/raw1394
mkdir -p /dev/video1394

ln -s /dev/video1394-0 /dev/video1394/0
ln -s /dev/raw/raw1394 /dev/raw1394
chmod -R a+rwx /dev/video1394
chmod -R a+rwx /dev/raw1394
echo Unloading modules
/sbin/rmmod video1394
/sbin/rmmod dv1394
/sbin/rmmod ohci1394
/sbin/rmmod raw1394
/sbin/rmmod ieee1394
#
# Attempt to reload the four firewire related kernel modules.
# The argument to ohci1394 tries to force the host adapter to be
# the bus controller. Without this, the kernel sometimes asks one of
# the cameras to be bus master, which isn't really very sensible.
#
echo Reloading modules
modprobe dv1394
modprobe ieee1394
modprobe raw1394
modprobe ohci1394 attemp_root=1
modprobe video1394



Ausgabe des Skripts:
rm: Entfernen von „/dev/video1394-0“ nicht möglich: No such file or directory
Unloading modules
Reloading modules



vor ein paar monaten hat es dieses problem nicht gegeben - konnte die software ohne probleme verwenden, möglicherweise wurde dies durch updates verursacht.


vielleicht kann mir jemand helfen - danke für jede hilfe !!!!

mfg
soxx
 

hastifranki



Anmeldungsdatum: 06.05.2006
Beiträge: 252

BeitragVerfasst am: 10. März 2007 20:42   Titel:

Hallo,

bezüglich Fehleranalyse könnte noch folgendes Vorgehen nützlich sein:

Bitte als erstes den folgenden Befehl eingeben:

tail -f /var/log/messages

Anschließend sollte man die Konsole beobachten, wenn man Geräte an den Rechner anschließt oder andere Aktionen durchführt.

Es werden dann Meldungen zeitnah zu den Aktionen angezeigt. Vielleicht ist eine Meldung dabei, die etwas mehr weiterhilft.

Viele Grüße
Frank
 
Benutzer-Profile anzeigen Private Nachricht senden

soxx
Gast





BeitragVerfasst am: 11. März 2007 11:59   Titel:

Hallo !

Also wenn ich die Firewire pci karte anstecke:

Mar 11 11:48:18 localhost kernel: [17179831.752000] pccard: CardBus card inserted into slot 0
Mar 11 11:48:18 localhost kernel: [17179831.752000] PCI: Enabling device 0000:0c:00.0 (0080 -> 0083)
Mar 11 11:48:18 localhost kernel: [17179831.752000] ACPI: PCI Interrup 0000:0c:00.0[A] -> GSI 16 (level, low) -> IRQ 169
Mar 11 11:48:18 localhost kernel: [17179831.752000] PCI: Via IRQ fixup for 0000:0c:00.0, from 169 to 9
Mar 11 11:48:18 localhost kernel: [17179831.752000] ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ[169] MMIO=[b6000000-b60007ff] Max Packet=[1024]

wenn ich nun die firewire kamera anstecke passiert nichts!



nun starte lasse ich mal mein script laufen.
rm: Entfernen von „/dev/video1394-0“ nicht möglich: No such file or directory
Unloading modules
ERROR: Module dv1394 does not exist in /proc/modules
Reloading modules

root@vi-nb04:/home/# tail -f /var/log/messages
Mar 11 11:48:18 localhost kernel: [17179831.752000] PCI: Enabling device 0000:0c:00.0 (0080 -> 0083)
Mar 11 11:48:18 localhost kernel: [17179831.752000] ACPI: PCI Interrupt 0000:0c:00.0[A] -> GSI 16 (level, low) -> IRQ 169
Mar 11 11:48:18 localhost kernel: [17179831.752000] PCI: Via IRQ fixup for 0000:0c:00.0, from 169 to 9
Mar 11 11:48:18 localhost kernel: [17179831.804000] ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[169] MMIO=[b6000000-b60007ff] Max Packet=[1024]
Mar 11 11:53:36 localhost kernel: [17180149.816000] video1394: Removed video1394 module
Mar 11 11:53:36 localhost kernel: [17180149.916000] ohci1394: $Rev: 1313 $ Ben Collins <bcollins@debian.org>
Mar 11 11:53:36 localhost kernel: [17180149.916000] ACPI: PCI Interrupt 0000:0c:00.0[A] -> GSI 16 (level, low) -> IRQ 169
Mar 11 11:53:36 localhost kernel: [17180149.972000] ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[169] MMIO=[b6000000-b60007ff] Max Packet=[1024]
Mar 11 11:53:36 localhost kernel: [17180150.048000] ieee1394: raw1394: /dev/raw1394 device initialized
Mar 11 11:53:36 localhost kernel: [17180150.104000] video1394: Installed video1394 module

wenn ich nun wieder die kamera anschliesse passiert wieder nichts...


ich hoffe jemand kann damit was anfangen.

mfg
soxx
 

soxx
Gast





BeitragVerfasst am: 12. März 2007 11:17   Titel:

habe das Problem gelöst...

mfg
soxx
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy