Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Linux als Router einrichten

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Ausgeraul



Anmeldungsdatum: 24.03.2007
Beiträge: 6

BeitragVerfasst am: 24. März 2007 14:17   Titel: Linux als Router einrichten

Hallo allerseits,
ich versuche mein Suse 10.0 als Router im LAN einzurichten, in dem WindowsXP als Client ist. Da ich Linux-Einsteiger bin, kann ich noch nicht alle IPTABLES Möglichkeiten selbst überblicken. Kann mir jemand eine Unterstützung-Hand anbieten?
Gruß Ausgeraul
 
Benutzer-Profile anzeigen Private Nachricht senden

rbtux



Anmeldungsdatum: 23.06.2004
Beiträge: 69

BeitragVerfasst am: 28. März 2007 16:39   Titel:

nur um einen Router (mit NAT) zu betreiben reichen zwei befehle (sofern nicht sonstige Firewallregeln konfiguriert wurden):

Code:

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o [externes Interface] -j MASQUERADE


Ich kenn SuSE selber nicht, vielleicht musst du noch das iptables_nat modul nachladen

Jetzt gibts du einfach dem WinXP Client als Standard Gateway den Linux Rechner an.

EDIT: Natürlich muss die Routingtabelle auf dem Linuxrechner richtig sein: also zumindest ein default gateway eintrag
_________________
Computer führen dazu, dass man die alten Fehler jetzt 100 mal schneller macht Wink
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 28. März 2007 23:12   Titel:

Bei SuSE wird das mittels YaST->Sicherheit und Benutzer->Firewall eingerichtet.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Ausgeraul



Anmeldungsdatum: 24.03.2007
Beiträge: 6

BeitragVerfasst am: 29. März 2007 0:47   Titel:

Ich glaube ich muss jetzt alles von vorne anfangen. Sowohl Linux als auch Windows reagieren sogar nicht einmal auf ping Sad . Ich vermute mein Firewall ist nicht richtig eingestellt(Zusammenfassung aus Firewall Einstellungen):
Firewall-Start
Firewall beim Systemstart starten
Interne Zone
Schnittstellen
Silicon Integrated SiS900 10/100 Ethernet Adapter / eth-id-xxxx
Offene Dienste, Ports und Protokolle
Interne Zone ist ungeschützt. Alle Ports sind offen.
Entmilitarisierte Zone
Dieser Zone wurden keine Schnittstellen zugewiesen.
Externe Zone
Schnittstellen
DSL-Verbindung / dsl0
Offene Dienste, Ports und Protokolle
DNS-Server
HTTP-Server
HTTPS-Server
TCP-Ports: 1214, 4080, 4661, 4662, 6346, 6347, 6882
UDP-Ports: 1214, 4080, 4661, 4662, 6346, 6347, 6882

Gruß Ausgeraul
 
Benutzer-Profile anzeigen Private Nachricht senden

Ausgeraul



Anmeldungsdatum: 24.03.2007
Beiträge: 6

BeitragVerfasst am: 29. März 2007 1:46   Titel:

linux-natali:/etc # smbclient -L localhost
Unknown parameter encountered: "quest account"
Ignoring unknown parameter "quest account"
Error connecting to 127.0.0.1 (Connection refused)
Connection to localhost failed

Stimmt irgend-was mit der smb.config oder deren Einstellungen nicht?
linux-natali:/etc/init.d # smb status
Checking for Samba SMB daemon dead
 
Benutzer-Profile anzeigen Private Nachricht senden

Polizei Niedersachsen
Gast





BeitragVerfasst am: 29. März 2007 11:29   Titel:

Hier wird das Thema mit Erfolg durchgegangen:
http://www.unixboard.de/vb3/archive/index.php/t-23861.html
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 30. März 2007 11:48   Titel:

"Masquerading für Netzwerke" ist vermutlich nicht eingeschaltet.

Der Ping geht vermutlich nicht mehr, weil dein Switch bei der ganzen Konfiguriererei abgeschmiert ist. Strom aus, Strom an, dann sollte er wieder laufen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Ausgeraul



Anmeldungsdatum: 24.03.2007
Beiträge: 6

BeitragVerfasst am: 30. März 2007 21:42   Titel:

Na endlich, ich habe es geschafft. Nun ist Verbindung zwischen beiden Rechnern wieder in Ordnung. Ich habe nur folgender Befehl abgesetzt:
ifconfig et0 <client IP>
Gruß Ausgeraul
 
Benutzer-Profile anzeigen Private Nachricht senden

Ausgeraul



Anmeldungsdatum: 24.03.2007
Beiträge: 6

BeitragVerfasst am: 31. März 2007 15:57   Titel:

Danke dir, Polizei Niedersachsen!
Das ist ja aber klasse! Router innerhalb von 5 Minuten einzurichten! Funktioniert tadellos. Nun muss ich mich ja aber mit den im Script zusammengestellten Regeln vertraut machen.
Gruß Ausgeraul.
 
Benutzer-Profile anzeigen Private Nachricht senden

Ausgeraul



Anmeldungsdatum: 24.03.2007
Beiträge: 6

BeitragVerfasst am: 31. März 2007 16:04   Titel:

Danke an alle, die zu unserem Dialog irgend-was beigetragen haben. Ihr habt mir sehr geholfen!
Gruß Ausgeraul
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy