Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Passenden Treiber für Linksys LNE100TX

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
LuiG
Gast





BeitragVerfasst am: 06. Mai 2007 16:49   Titel: Passenden Treiber für Linksys LNE100TX

Hallo!

Bin auch eher ein Linux-Neuling. Ich will mir zuhause eine Maschine einrichten, die fernstartbar ist. Jetzt habe ich Debian 4.0R1 installiert und habe die gleichen Probleme wie mit 3.1.
Im BIOS ist WOL eingerichtet, ethtool ist installiert, sagt mir aber: "no data available". Habe jetzt bereits herausgefunden, dass es am Treiber der Karte liegen könnte. Soweit funktioniert sie zwar, aber die WOL-Fähigkeit scheint nicht unterstützt zu werden vom Standardtreiber.
Meine Frage ist jetzt, erstens, welchen Treiber ich nehmen muss (Ich glaube bei Linksys gibt es sogar Linuxtreiber) und vorallem, wie ich diesen dann installiere!

vielen Dank schonmal!
LuiG
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 06. Mai 2007 17:45   Titel:

Ich verstehe das Problem nicht so ganz. Wake on LAN heißt doch, daß Dein PC per LAN eingeschaltet wird. Somit ist zum Einschaltzeitpunkt doch noch garkein Treiber geladen. Alles nötige sollten BIOS und Karte erledigen. Hast Du evtl vergessen, das WOL-Kabel zwischen Mainboard und Karte anzuschließen ?
 
Benutzer-Profile anzeigen Private Nachricht senden

LuiG
Gast





BeitragVerfasst am: 07. Mai 2007 12:51   Titel:

Hallo

Auf Seiten der Hardware ist alles passend eingestellt, Das Mainboard unterstützt WOL genauso wie die Karte an sich. Ein Kabel ist nicht nötig, da diese Generation der Hardware WOL direkt unterstützt.
Allerdings muss das Betriebssystem der Karte beim Herunterfahren mitteilen, dass sie in den WOL empfänglichen Zustand gehen soll. Das wird durch das Tool ethtool gemacht. Dieses erkennt jedoch die Karte nicht als WOL fähig. Ich denke, dass das am Treiber liegt, der scheinbar nicht als Standard WOL unterstützt.
Daher muss ich für die Karte einen Treiber installieren, der sie richtig erkennt. Erst dann kann die Maschine entsprechend heruntergefahren werden.

Gruß,
LuiG
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 08. Mai 2007 10:44   Titel:

Um welche abstruse Ethernethardware handelt es sich? Für alle gebräuchlichen und sogar inzwischen weniger gebräuchlichen Ethernetadapter ist ein passender Treiber im Kernel enthalten.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

LuiG
Gast





BeitragVerfasst am: 08. Mai 2007 12:29   Titel:

Wie der Titel des Threads schon vermuten lässt:
Linksys LNE100TX

Gruß,
LuiG
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 08. Mai 2007 14:47   Titel:

Oh, übersehen. Die Karte verwendet den tulip-Treiber, der beim Kernel schon dabei ist. Das Treiberpaket, das von Linksys vertrieben wird, enthält ebenfalls diesen tulip-Treiber, allerdings in eine veralteten Version von 2001.

WOL funktioniert überhaupt nur bei den folgenden Treibern:
Code:

[jan@janskiste /usr/src/linux/drivers/net]$ grep -ilR get_wol *
8139cp.c
8139too.c
amd8111e.c
b44.c
bnx2.c
e1000/e1000_ethtool.c
e100.c
forcedeth.c
natsemi.c
r8169.c
sis900.c
skge.c
spider_net_ethtool.c
sungem.c
tg3.c
tulip/uli526x.c
typhoon.c
via-rhine.c
via-velocity.c


D.h. beim Tulip-Treiber geht es nur mit dem uli526x-Chipset. Einen anderen Treiber gibt es nicht, auch nicht von Dlink. Nimm eine billige Realtek-Karte, damit geht es.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

LuiG
Gast





BeitragVerfasst am: 08. Mai 2007 15:43   Titel:

Hallo!

Na klasse, hatte mir diese Karte schon extra gekauft, damit es funktioniert... Die vorher eingebaute unterstützte das auch nicht.
Gibt es keinen Treiber, der die Funktionen dieser Karte unterstützt? Und wenn ich wirklich den veralteten Tulip Treiber von Linksys installiere?

LuiG
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. Mai 2007 9:56   Titel:

Der Uralt-Treiber von Linksys ist *derselbe* Treiber wie der tulip-Treiber im Kernel, nur halt in einer Uralt-Version. Wenn die überhaupt funktioniert (scheint nur für Kernel 2.0 und 2.2 zu sein), gibt es natürlich damit auch kein WOL. Da ist noch nicht einmal die Schnittstelle für ethtool mit drin.

Wie immer bei Linux: Zuerst fragen, dann kaufen. Da eine der funktionierenden Netzwerkkarten jedoch höchstens 15Euro kostet, dürfte sich der Ärger in Grenzen halten.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

LuiG
Gast





BeitragVerfasst am: 09. Mai 2007 13:55   Titel:

Hallo!

Habe übrigens gerade mit lspci ausgelesen, dass der Chipsatz ein "ADMtek NC100" ist.
Vielleicht hilft das jemandem weiter?

Gruß,
LuiG
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. Mai 2007 20:25   Titel:

Stopf "ADMtec NC100 linux" in den Google und du erhälst Links auf den tulip-Treiber. Noch Fragen?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

LuiG
Gast





BeitragVerfasst am: 10. Mai 2007 6:57   Titel:

Hi!

Ja schon klar. Aber wie du ja schon ausgeführt hast, kann ich mit dem tulip Treiber nichts anfangen, weil der ja das WOL nicht unterstützt.

Habe den tulip auch schon in die aktuellste Version gebracht.

Gruß,
LuiG
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 10. Mai 2007 8:09   Titel:

Ich weiß nicht, was du dir noch erhoffst. Es gibt für jede Hardware üblicherweise *genau einen* Treiber. Eine Ausnahme ist nur dann gegeben, wenn der Hersteller einen Treiber anbietet, und die Linux-Entwickler einen anderen. Dies ist hier nicht der Fall, also musst du damit leben, dass vorerst kein WOL mit dieser Karte funktioniert.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

LuiG
Gast





BeitragVerfasst am: 10. Mai 2007 16:34   Titel:

Hi,

ja, bin jetzt auch schon auf der Suche nach einer geeigneten Karte. Kann sie hoffentlich mit einem bekannten entsprechend austauschen!

Trotzdem dankeschön!

LuiG
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy