Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit Amanda

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
schnecke



Anmeldungsdatum: 23.04.2003
Beiträge: 47

BeitragVerfasst am: 27. Mai 2007 19:00   Titel: Probleme mit Amanda

Hallo ich versuche gerade Amanda auf meinem Server zum laufen zu bringen.
Leider habe ich so die ein oder andere Schwierigkeit. Die kleineren konnte ich bisher lösen aber jetzt weiss ich nicht wo ich nach dem Fehler suchen soll.

Mittels amdump wurde ein Backup erstellt welches nun probeweise zurückgeschrieben werden soll.

Die Syslog zeigt beim Booten schon den verdächtigen Eintrag:
xinetd[2239]: service/protocol combination not in /etc/services: amidxtaped/tcp

Beim Versuch mit amrecover das Backup mittels extract wiederherzustellen gibt folgenden Fehler aus:
cannot connect to localhost: Connection refused
amrecover - can't talk to tape server

Welche Schraube habe ich vergessen zu drehen?
Habe gestern Abend überall versucht zu drehen und zu ändern leider komme ich auf keinen grünen Zweig.
Hat hier vielleicht jemand eine Vorstellung?
Vielen Dank im Voraus!
Gruß,
Alexander
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 27. Mai 2007 19:27   Titel:

Scheint ein Schreibfehler zu sein. Es gibt in /etc/services einen Service "amidxtape" (ohne "d"). Guck mal dein /etc/xinetd.conf nochmal durch.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

schnecke



Anmeldungsdatum: 23.04.2003
Beiträge: 47

BeitragVerfasst am: 27. Mai 2007 19:43   Titel:

Vielen Dank!
Bin gerade auf die Lösung zu diesem Problem über Webmin gestossen.

Hier finde ich unter "Netzwerk" -> "Extendet Internet Services" folgenden Eintrag zu Amanda:

Code:

amanda       Internet    10080    UDP    amanda    /usr/lib/amanda/amandad     Yes
amandaidx    Internet    10082    TCP    amanda    /usr/lib/amanda/amindexd    Yes
amidxtaped   Internet             TCP    amanda    /usr/lib/amanda/amidxtaped  Yes


Wenn ich hier den Port 10083 bei amidxtaped festlege funktioniert es.

Aber warum fehlt hier der Eintrag? In welche Datei, ausser in /etc/xinet.d/amidxtaped, sollte der Port dafür eigentlich festgelegt werden? Denn für amanda und amandaidx sind in den jeweiligen Dateien unter /etc/xinet.d/ auch keine Ports angegeben aber er weiss sie trotzdem. Weiss das jemand?
Vielen Dank!
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 28. Mai 2007 8:49   Titel:

Das ist ein Schreibfehler. Wenn nicht bei dir, dann in /etc/services oder in dem amanda-Paket, dass du benutzt.
Ändere es beispielsweise in /etc/services.

Portnummern werden über /etc/services festgelegt. Es gibt eine Reihe von Funktionen getservby...(), die unter anderem /etc/services durchsuchen.

$ man getservbyname

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

schnecke



Anmeldungsdatum: 23.04.2003
Beiträge: 47

BeitragVerfasst am: 29. Mai 2007 15:59   Titel:

Vielen Dank!
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy