Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 13. Nov 2018 1:12

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 1 Beitrag ] 
Autor Nachricht
BeitragVerfasst: 06. Jun 2007 16:38 
Offline

Registriert: 21. Aug 2006 11:45
Beiträge: 23
Hi,

ich habe nen Problem mein svn/apache an die AD anzubinden. ich will die User die sich an dem svn anmelden dürfen halt über die ad auslesen.

Hier mein System:
SLES10 + Apache 2.2 + SVN 1.4.3

SVN funktioniert super nur jedes mal wenn man sich einloggen will kommt dieser Fehler in die apache error.log
Code:
Wed Jun 06 15:28:42 2007] [warn] [client 192.168.0.10] [1219] auth_ldap authenticate: user fbj authentication failed; URI /svn/ [LDAP: ldap_simple_bind_s()
failed][Invalid credentials]
[Wed Jun 06 15:28:42 2007] [error] [client 192.168.0.10] user fbj: authentication failure for "/svn/": Password Mismatch

Hier mal meine Configs:

httpd.conf:
Code:
<Directory />
    Options ExecCGI Indexes FollowSymLinks
    AllowOverride all
    AuthType Basic
    Order deny,allow
    Deny from all
</Directory>

Loadmodule dav_svn_module /usr/lib/apache2/mod_dav_svn.so
LoadModule ldap_module /usr/lib/apache2-prefork/mod_ldap.so
Loadmodule authnz_ldap_module /usr/lib/apache2-prefork/mod_authnz_ldap.so
LoadModule authz_svn_module /usr/lib/apache2/mod_authz_svn.so

LDAPSharedCacheSize 200000
LDAPCacheEntries 1024
LDAPCacheTTL 600
LDAPOpCacheEntries 1024
LDAPOpCacheTTL 600

<Location /svn>
    DAV svn
    SVNParentPath /opt/svn
    AuthzSVNAccessFile /etc/.svnaccess
 
    AuthBasicAuthoritative On
    AuthBasicProvider ldap
    Require valid-user
    AuthType Basic
    AuthName "Subversion Repository"
   
    AuthLDAPBindDN CN=fbj,CN=Admins,CN=IT,DC=domain,DC=extension
    AuthLDAPBindPassword password

    AuthLDAPURL ldap&#58;//server.domain.extension&#58;389/CN=Admins,CN=IT,DC=domain,DC=extension?sAMAccountName?sub?&#40;objectClass=*&#41;

</Location>
svnaccess:
Code:
&#91;groups&#93;
Users= domain\fbj, fbj, DOMAIN\FBJ

&#91;/&#93;
@Users=rw


Hat da einer ne Idee? Hab jetzt 2 Tage gegoogelt und alle Beispiele und Konfigurationen ausprobiert. Ich kriegs aber nichts ans laufen. Muss ich da noch was am ldap client konfigurieren oder habe ich irgendwas vergessen??

Hoffe es kann mir wer helfen :(


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 1 Beitrag ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de