Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Notebook WLAN unter Knoppix 5.2

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
tellofix



Anmeldungsdatum: 31.12.2005
Beiträge: 9

BeitragVerfasst am: 15. Jun 2007 16:28   Titel: Notebook WLAN unter Knoppix 5.2

Hallo Experten,

wie bekomme ich mein WLAN-Modul am Laptop unter Knoppix 5.2 (die DVD von der ct) zum Laufen?
So wie im Artikel aus der ct 7/2007 beschrieben, funktioniert es bei mir nicht.
Verbaut ist ein Intel(R) PRO/Wireless 2200-Chip, der beim Start von Knoppix auch als eth2 erkannt und angesprochen wird.

Anbei ein paar Zeilen des Startprotokolls...


    ieee80211_crypt: registered algorithm 'NULL'
    ieee80211: 802.11 data/management/control stack, git-1.1.13
    ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
    ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.4kmpr
    ipw2200: Copyright(c) 2003-2006 Intel Corporation
    ....
    ....
    ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    ipw2200: Radio Frequency Kill Switch is On:
    Kill switch must be turned off for wireless networking to work.
    ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
    ....
    ....
    ADDRCONF(NETDEV_UP): eth2: link is not ready
    ADDRCONF(NETDEV_UP): eth2: link is not ready


Habe die Einrichtung wie beschrieben über das Tool aus dem Knoppix-Menu "wlcardconfig" durchgeführt. Allerdings werden keinerlei verfügbare Drahtlosnetzwerke gefunden, obwohl der Router neben dem Laptop steht. Überflüssig zu erwähnen, dass WLAN natürlich unter W...dows funktioniert.

Beim Starten der Verbindung mit "IP Aktivieren/Verbinden" erfolgt noch die DHCP-Abfrage, die ich mangels Netzwerk-Kenntnissen auf "automatisch" lasse. Danach kommt in der Konsole das folgende: "Sende DHCP-Broadcast von Netzwerkkarte eth2." Nach etwa 10 - 20 Sekunden erschein dann "Operation failed - Fehlgeschlagen" und das wars.

Mein Eindruck ist, dass das WLAN Modul gar nicht eingeschaltet ist, obwohl im Kontrollzentrum der Status "aktiviert" angezeigt wird. Das Notebook hat ein paar LEDs für Anzeigen wie "Festplatte aktiv", "Akku-Laden" etc. und unter anderem auch "WLAN aktiv". Da diese LED nicht leuchtet,vermute ich fast, dass es nicht eingeschaltet wird. Die ganze Konfiguration wird schon i.O. sein, aber dazu muss es auch funken....

Anbei noch die Ausgabe von iwconfig (WLAN-Router war aber dabei nicht eingeschaltet):

    knoppix@Knoppix:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 no wireless extensions.

    eth2 radio off ESSID:off/any
    Mode:Managed Channel:0 Access Point: Not-Associated
    Bit Rate:0 kb/s Tx-Power=off Sensitivity=8/0
    Retry limit:7 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    ppp0 no wireless extensions.


Und nochwas - die Ausgabe von lspci - scheint das WLAN auch zu kennen....

    knoppix@Knoppix:~$ lspci
    ......
    02:05.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
    02:06.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
    ........


Wer hat das schon zum Laufen bekommen und kann einen Tipp geben?
 
Benutzer-Profile anzeigen Private Nachricht senden

sith
Gast





BeitragVerfasst am: 15. Jun 2007 18:33   Titel:

hallo,
erstmal ein paar fragen:
dein knoppix läuft von cd oder hast du es auf festplatte installiert?
kannst du mal den inhalt der '/etc/network/interfaces' posten.
dann wäre schonmal gut, wenn du mal im kde menu schaust, ob du unter internet den knetworkmanager findest.
ansonsten wäre gut zu wissen wie dein wlan verschlüsselt ist. also wpa, wpa2 oder etwa wep?
bis dann
 

tellofix



Anmeldungsdatum: 31.12.2005
Beiträge: 9

BeitragVerfasst am: 15. Jun 2007 21:50   Titel:

Das Knoppix ist mit der "tohd-Option" als DVD-Image auf der Festplatte abgelegt. Es startet also immer wie von DVD, nur wesentlich schneller. Konfiguration und Home-Verzeichnis sind auf USB-Stick.

Anbei die etc/network/interfaces:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

    # The loopback interface
    # automatically added when upgrading
    auto lo
    iface lo inet loopback

    allow-hotplug eth0
    iface eth0 inet dhcp
    pre-up ifconfig eth0 up

    allow-hotplug eth1
    iface eth1 inet dhcp
    pre-up ifconfig eth1 up

    allow-hotplug eth2
    iface eth2 inet dhcp
    pre-up ifconfig eth2 up


Einen Knetworkmanager gibt es in der "Internet-Sektion" nicht dafür aber ein WLAN-Tool ("KWiFi") Wenn ich das starte, kommt sofort die Meldung "Antenne ausgeschaltet". Mein WLAN ist im Normalfall WPA-verschlüsselt und MAC-codiert.

Habe aber zu Probezwecken mal alle Verschlüsselungen ausgechaltet - bringt nichts. Ich denke, das WLAN muss zum Senden gebracht werden, irgenwie ist es vorhanden, wird auch erkannt ist aber nicht aktiv. Unter Wi...s benutze ich zum Einschalten einfach die Hardware-Tasten am Notebook. Vermutlich sind es aber eben keine Hardware- sondern Software-Tasten, denn unter Linux erzeugen die keine Aktion, d. h. die LED für das WLAN geht nicht an.
 
Benutzer-Profile anzeigen Private Nachricht senden

sith
Gast





BeitragVerfasst am: 16. Jun 2007 10:17   Titel:

ich habe die von dir benutzte knoppix version zwar auch und wollte das soweit hier mit meiner karte möglich mal nachvollziehen - leider ist das teil aber kaputt. ich kann dir also nur 2 versionen anbieten, mit denen das bei mir auf einem debian system läuft.

zumal iwconfig eth2 anzeigt, gehe ich davon aus, dass die entspprechenden module geladen sind. ich denke das dazu auch die firmware nötig ist, ganz sicher bin ich mir dabei aber nicht. du kannst das aber mal überprüfen indem du guckstob sie unter '/lib/firmware' zu finden ist. dazu auch hier:
http://www.thinkwiki.org/wiki/Ipw2200#Installation_on_Debian_Etch

mit dem kwifimanager konnte ich mich nicht anfreunden. am einfachsten und flexibelsten geht das ganze imho mit dem knetworkmanager den du mit dem packet 'network-manager-kde' installierst. zusätzliche software kannst du auf einem von dvd laufenden knoppix installieren und konfigurieren, wie das nach einem neustart funktioniert musst du probieren. also:
{code]
aptitude install network-manager-kde
[/code]
danach editierst du die '/etc/network/interfaces' so, dass nur das loopback aktiv bleibt:
Code:

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

alle weiteren einträge kommentierst du mit '#' am zeilenanfang.
nun muss noch dein user in '/etc/group' der gruppe 'netdev' zugeordnet werden.
Code:

adduser deinuser netdev

nach einem
Code:

/etc/init.d/networking restart

sollte dein wlan funktionieren, wenn die anderen genannten vorraussetzungen stimmen. ich hab allerdings auch schon erlebt, das aus irgendeinem grund ein neustart nötig war, was die angelegenheit auf deinem knoppix system halt etwas spannender machen würde Wink . jedenfalls das war's, wenn du den network-manager nutzt.

ansonsten gibts den weg über den wpasupplicant. den zu konfigurieren, ist etwas lästiger und schreibe das in einen 2. post, wenn dir obige lösung nicht gefällt, zumal ich meine wpa_supplicant.conf datei nicht auf dem rechner habe, mit dem ich gerade schreibe.

melde dich vielleicht erst nochmal
bis dann
 

tellofix



Anmeldungsdatum: 31.12.2005
Beiträge: 9

BeitragVerfasst am: 16. Jun 2007 11:21   Titel:

sith hat folgendes geschrieben::
denke das dazu auch die firmware nötig ist, ganz sicher bin ich mir dabei aber nicht. du kannst das aber mal überprüfen indem du guckstob sie unter '/lib/firmware' zu finden ist.


So sieht es in /lib/firmware aus. Glaube nicht, dass dabei die richtige für den 2200er Chip ist.





sith hat folgendes geschrieben::
das ganze imho mit dem knetworkmanager den du mit dem packet 'network-manager-kde' installierst. zusätzliche software kannst du auf einem von dvd laufenden knoppix installieren und konfigurieren


Oh, für mich ein Riesenproblem. Durch updaten/nachinstallieren habe ich mir mein Vorgänger-Knoppix, was zwei Jahre stabil lief, total unrettbar zerschossen. Das Inferno kam mit apt-get install.... Sad

Ich scheue daher etwas davor zurück, zusätzliche Software, Module etc. zu installieren. Es gibt allerdings noch ein anderes Problem.

Zum Nachinstallieren von Software ist auch mein Home-Verzeichnis auf dem USB-Stick zu klein und ich weiß nicht, wie ich es vergrößern kann, ohne all meine Daten, Mails etc. zu verlieren. Neu anlegen auf einem anderen USB-Stick funktioniert nicht, da dieser beim Neustart nicht richtig gelesen wird. Ich gehe doch richtig in der Annahme, das neue Software immer zu knoppix.img oder in configs.tbz abgelegt wird. Auf dem Read-Only System gehts jedenfalls nicht anders.

Vielen Dank für die Tipps. Werde mal das Wiki lesen.
Ciao
 
Benutzer-Profile anzeigen Private Nachricht senden

sith
Gast





BeitragVerfasst am: 16. Jun 2007 12:17   Titel:

Code:

Ich scheue daher etwas davor zurück, zusätzliche Software, Module etc. zu installieren.

um das installieren der firmware wirst du nicht herumkommen. fehlen tut sie sehr wahrscheinlich wegen lizenz problemen (in debian fehlt sie ja auch aus diesem grund).

wirklich zu etwas raten kann ich dir da nicht, aus zu einer festpatten installation. wobei dann wohl eher kanotix oder vielleicht sidux in frage kommen würde (eben wegen eventueller abhängikeits und damit apt-get problemen). aber du wirst wissen warum du das bisher über cd/dvd machst.

machs gut
 

tellofix



Anmeldungsdatum: 31.12.2005
Beiträge: 9

BeitragVerfasst am: 16. Jun 2007 17:18   Titel:

sith hat folgendes geschrieben::
Code:

um das installieren der firmware wirst du nicht herumkommen. fehlen tut sie sehr wahrscheinlich wegen lizenz problemen (in debian fehlt sie ja auch aus diesem grund).


Da hast Du recht. Ohne Installation geht es offenbar nicht. Habe die Firmware wie im Wiki beschrieben, mittels Root-Konsole installiert. Ging auch ohne Fehlermeldung ab. Allerdings ist der nunmehr unter /lib/firmware stehende Ordner ipw2200-fw-3.0 leer und die Dateien

ipw2200-bss.fw
ipw2200-ibss.fw
ipw2200-sniffer.fw
LICENSE.ipw2200-fw

stehen direkt im Stammverzeichnis /lib/firmware. Der Eigentümer ist knoppix, obwohl als root installiert.. Question

Das "aptitude install network-manager-kde" funktioniert nicht. Fehlermeldung ist "...Kein Kandidat für network-manager-kde gefunden..."

Wie weiter?
 
Benutzer-Profile anzeigen Private Nachricht senden

tellofix



Anmeldungsdatum: 31.12.2005
Beiträge: 9

BeitragVerfasst am: 16. Jun 2007 17:27   Titel:

... und wie vermutet: Nach einem Neustart ist /lib/firmware wieder im Original-Zustand.
Ohne ipw2200-fw-3.0......
 
Benutzer-Profile anzeigen Private Nachricht senden

sith
Gast





BeitragVerfasst am: 16. Jun 2007 18:04   Titel:

sowie das in dem wiki steht soll die firmware auch ohne den ordner in /lib/firmware stehen.
Code:

mv /lib/firmware/ipw2200-fw-3.0/* /lib/firmware

macht ja genau das. ist natürlich blöd, wenn nach dem neustart wieder alles beim alten ist. dazu weiss ich leider keinen rat.

was das packet network-manager-kde betrifft, so arbeitet knoppix ja zumindest auch mit debian sid quellen. in debian sid ist das packet enthalten
Code:

apt-cache search network-manager-kde
network-manager-kde - KDE systray applet for controlling NetworkManager

eventuell müsstest du erst die datenbank für die quellen neu laden:
Code:

apt-get update

und dann installieren? ansonsten kannst du das ganze auch mit dem wpasupplicant machen, wobei auch der installiert sein muss. das kannst du erstmal überprüfen mit
Code:

apt-cache policy wpasupplicant

wie knoppix da eventuell vorbereitetist weiss ich dann nicht aber hier sieht die konfiguration so aus:
/etc/wpa_supplicant.conf (musst du eventuell neu erstellen)
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=2
fast_reauth=1
network={
        ssid="essid-vom-router"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        psk=mit-wpa_passphrase-erstellter-schlüssel
}

den schlüssel erstellst du dann mit
Code:

wpa_passphrase essid total-geheimes-passwort

die /etc/network/interfaces muss jetzt auch wieder angepasst werden
Code:

...
auto eth2
iface eth2 inet dhcp
        wpa-driver wext
        wpa-conf /etc/wpa_supplicant.conf
...

wobei ich davon ausgehe, das die datei bisher noch im ursprünglichen zustand ist und keine änderungen für den network-manager vorgenommen wurden. du änderst also nur diesen bereich.
diese einstellungen sind für wpa, für wpa2 musst du das noch ein wenig anpassen - eventuell auch so noch ein wenig (hier läuft es so).
so, vielleicht kommst du damit zurecht.
viel erfolg noch
 

tellofix



Anmeldungsdatum: 31.12.2005
Beiträge: 9

BeitragVerfasst am: 17. Jun 2007 14:41   Titel:

wpasupplicant ist bei Knoppix offenbar installliert, denn apt-cache sagt folgendes:

Code:
apt-cache policy wpasupplicant
wpasupplicant:
  Installiert:0.5.7-0
  Mögliche Pakete:0.5.7-0
  Versions-Tabelle:
 *** 0.5.7-0 0
        100 /var/lib/dpkg/status


Soweit so gut. Das Verzeichnis etc ist im Verzeichnisbaum kursiv dargestellt. Ich vermute daher, es ist kein richtiges Verzeichnis (sondern ein Link o.ä.)?

Wenn ich dort eine "wpasupplicant.conf" anlege, bleibt sie sicher nur für die aktuelle Sitzung bestehen. Offiziell kann man zwar bei Knoppix im DVD-Betrieb Software nachinstallieren, aber in praxi funktioniert es nicht so einfach.

Aber was sagt dmesg bei Dir? Mich machen immer wieder die Zeilen stutzig:

Code:

ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.4kmpr
ipw2200: Copyright(c) 2003-2006 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
ipw2200: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.


Für mich klingt das so, als wenn der WLAN-Treiber vollständig installiert und lauffähig wäre, nur die WLAN-Hardware durch einen Befehl eingeschaltet werden müsste.

Schade, dass Du das nicht mit der Knoppix-DVD nachvollziehen kannst. Trotzdem Vielen Dank für die Hilfe!
 
Benutzer-Profile anzeigen Private Nachricht senden

sith
Gast





BeitragVerfasst am: 17. Jun 2007 20:13   Titel:

Code:

Kill switch must be turned off for wireless networking to work.

ich hab hier ne ipw3945 karte. das prob kenne ich nicht. aber guck dir mal diese links an:
http://www.hollstegge.de/md42200/wlan.php
http://forum.ubuntuusers.de/topic/94762/
speziell im oberen wird direkt darauf eingegangen.vielleicht kommst du damit schon weiter.
 

sith
Gast





BeitragVerfasst am: 17. Jun 2007 22:20   Titel:

wahrscheinlich passt die ubuntu anleitung denn doch besser zu deinem amilo, hast du doch oder Wink und die firmware liegt jetzt aber da wo sie hingehört oder?
 

tellofix



Anmeldungsdatum: 31.12.2005
Beiträge: 9

BeitragVerfasst am: 19. Jun 2007 20:18   Titel:

sith hat folgendes geschrieben::
wahrscheinlich passt die ubuntu anleitung denn doch besser zu deinem amilo, hast du doch oder Wink und die firmware liegt jetzt aber da wo sie hingehört oder?


Irgendwie komme ich so nicht weiter. Habe gestern mehrere Stunden damit zugebracht.

Alle Tipps beziehen sich auf installierte Linux-Systeme. Knoppix ist aber auch als DVD-Image auf der Platte ein Readonly-System.

Da kann man keine Dateien an bestimmte Stellen speichern - da alles beim nächsten Systemstart neu erstellt wird.

Trotzdem nochmals vielen Dank für die Hilfe. Vielleicht geht es später mal bei Knoppix 6.x oder 7.x. Sad
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy