Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Crash: free(): invalid pointer in libc.so.6

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Huan Sen
Gast





BeitragVerfasst am: 19. Jul 2007 12:26   Titel: Crash: free(): invalid pointer in libc.so.6

Hallo!

Ich bitte euch um eure Hilfe. Wir starten auf unserem Public-Server das Game Day of Defeat: Source und erhalten den nachfolgenden Crash, etwa eine Minute, nachdem jemand gejoint hat.

System ist ein AMD Athlon 64 3700+ mit SuSE (wobei ich offen gestanden nicht mehr weiß, ob es ein 32-Bit oder 64-Bit SuSE ist, die SuSE-Version ist 10.0 glaube ich, wo kann ich das alles ggf. checken?).

Woanders las ich, dass ich glibc aktualisieren solle. Ich muß aber sagen, dass ich nicht weiß, wie ich das machen soll (Yast?).

Kann jemand etwas dazu sagen oder hat noch andere Hinweise wegen dem Crash? Smile

Zitat:

*** glibc detected *** ./srcds_amd: free(): invalid pointer: 0xf7d2cfe0 ***
======= Backtrace: =========
/lib/libc.so.6[0xf7dfa911]
/lib/libc.so.6(__libc_free+0x84)[0xf7dfbf84]
bin/dedicated_amd.so(_ZN15CBaseFileSystem12FastFindFileEPKNS_11CSearchPathEPKc+0x1a2)[0xf7cc82e2]
bin/engine_amd.so(_Z9Sys_mkdirPKc+0xa0)[0xf71d7030]
======= Memory map: ========
08048000-08054000 r-xp 00000000 08:02 125911 /home/game_dods/srcds_amd
08054000-08056000 rwxp 0000c000 08:02 125911 /home/game_dods/srcds_amd
08056000-09961000 rwxp 08056000 00:00 0 [heap]
efb00000-efb21000 rwxp efb00000 00:00 0
efb21000-efc00000 ---p efb21000 00:00 0
efc79000-efc83000 r-xp 00000000 08:02 2019 /lib/libgcc_s.so.1
efc83000-efc84000 rwxp 00009000 08:02 2019 /lib/libgcc_s.so.1
efc8f000-efc90000 ---p efc8f000 00:00 0
efc90000-efe52000 rwxp efc90000 00:00 0
efe52000-efead000 r-xp 00000000 08:02 125869 /home/game_dods/bin/vstdlib_s_i486.so
efead000-efeb3000 rwxp 0005a000 08:02 125869 /home/game_dods/bin/vstdlib_s_i486.so
efeb3000-efec4000 rwxp efeb3000 00:00 0
efec4000-f05ba000 r-xp 00000000 08:02 125862 /home/game_dods/bin/steamclient_i486.so
f05ba000-f063b000 rwxp 006f5000 08:02 125862 /home/game_dods/bin/steamclient_i486.so
f063b000-f0733000 rwxp f063b000 00:00 0
f0739000-f0aac000 rwxp f0739000 00:00 0
f0adc000-f0d6c000 rwxp f0adc000 00:00 0
f0d95000-f0e24000 rwxp f0d95000 00:00 0
f0e25000-f0e49000 rwxp f0e25000 00:00 0
f0e6d000-f0eab000 rwxp f0e6d000 00:00 0
f0eb2000-f0edf000 r-xp 00000000 08:02 125864 /home/game_dods/bin/tier0_s_i486.so
f0edf000-f0ee2000 rwxp 0002d000 08:02 125864 /home/game_dods/bin/tier0_s_i486.so
f0ee2000-f1049000 rwxp f0ee2000 00:00 0
f106f000-f1093000 rwxp f106f000 00:00 0
f10b7000-f164e000 rwxp f10b7000 00:00 0
f1659000-f170a000 rwxp f1659000 00:00 0
f1731000-f1a06000 rwxp f1731000 00:00 0
f1a18000-f1b94000 rwxp f1a18000 00:00 0
f1b9d000-f1c00000 rwxp f1b9d000 00:00 0
f1c1c000-f1c8b000 rwxp f1c1c000 00:00 0
f1c8e000-f1d2d000 rwxp f1c8e000 00:00 0
f1d2e000-f1e23000 rwxp f1d2e000 00:00 0
f1e3b000-f1e68000 rwxp f1e3b000 00:00 0
f1e6a000-f1e9f000 r-xs 00000000 08:02 98521 /var/run/nscd/dbmLDnG7 (deleted)
f1e9f000-f1ea0000 ---p f1e9f000 00:00 0
f1ea0000-f5fa1000 rwxp f1ea0000 00:00 0
f5fa1000-f6a82000 r-xp 00000000 08:02 120506 /home/game_dods/dod/bin/server_i486.so
f6a82000-f6b56000 rwxp 00ae1000 08:02 120506 /home/game_dods/dod/bin/server_i486.so
f6b56000-f6d4a000 rwxp f6b56000 00:00 0
f6d73000-f6d82000 r-xp 00000000 08:02 125858 /home/game_dods/bin/shaderapiempty_i486.so
f6d82000-f6d83000 rwxp 0000f000 08:02 125858 /home/game_dods/bin/shaderapiempty_i486.so
f6d83000-f6dac000 rwxp f6d83000 00:00 0
f6dac000-f6dbe000 r-xp 00000000 08:02 125861 /home/game_dods/bin/steam_api_i486.so
f6dbe000-f6dc0000 rwxp 00011000 08:02 125861 /home/game_dods/bin/steam_api_i486.so
f6dc0000-f6dc4000 rwxp f6dc0000 00:00 0
f6dc4000-f6f46000 r-xp 00000000 08:02 125855 /home/game_dods/bin/libsteamvalidateuseridtickets_i486.so
f6f46000-f6f6d000 rwxp 00182000 08:02 125855 /home/game_dods/bin/libsteamvalidateuseridtickets_i486.so
f6f6d000-f6f72000 rwxp f6f6d000 00:00 0
f6f72000-f731c000 r-xp 00000000 08:02 120507 /home/game_dods/bin/engine_amd.so
f731c000-f73d4000 rwxp 003aa000 08:02 120507 /home/game_dods/bin/engine_amd.so
f73d4000-f744c000 rwxp f73d4000 00:00 0
f744c000-f74a5000 r-xp 00000000 08:02 125848 /home/game_dods/bin/datacache_i./srcds_run: line 344: 20306 Abgebrochen
 

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 20. Jul 2007 0:59   Titel:

Mario H. hat folgendes geschrieben::
die SuSE-Version ist 10.0 glaube ich, wo kann ich das alles ggf. checken?
einerseits die Datei /etc/SuSE-release,
oder in yast die Namen der Software-Quellen,
oder die Versionen von Kernel und libc mit den Paketen auf den Mirrors vergleichen.
Code:
uname -r
rpm -qa | grep libc6


Zitat:
dass ich glibc aktualisieren solle. Ich muß aber sagen, dass ich nicht weiß, wie ich das machen soll (Yast?).
Ja, entweder in yast oder direkt das Modul yast-online-update aufrufen:
Code:
you
Ob in SuSE-10.0 das ZEN-Framework schon dazugehört weiß ich nicht, falls doch sollte es jedoch (IMHO) entfernt werden!
(da die mit diesem verwalteten Updates mit denen von you kollidieren können)


Im DoD-Server-Forum schon nach linux oder libc|glibc|libc6 gesucht?
Wenn ich nach "srcds_run: line 344" google bemühe, dann scheinen auch CounterStrike-Foren richtig zu sein.



EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT
Code:
rpm -qa | grep libc6
Sorry, wie Janka sagt, 'libc6' ist hier falsch,
ich bin von debian ausgegangen.
Code:
Also
rpm -qa | grep libc
oder
ldconfig -V

Die libc kann auch direkt gefragt werden:
Code:
user@machine:~$ ls -l /lib/libc*
-rwxr-xr-x 1 root root 1147548 2007-02-21 16:13 /lib/libc-2.3.6.so
lrwxrwxrwx 1 root root      14 2007-04-15 23:25 /lib/libcap.so.1 -> libcap.so.1.10
-rw-r--r-- 1 root root   11024 2004-04-14 00:10 /lib/libcap.so.1.10
lrwxrwxrwx 1 root root      17 2007-04-15 23:25 /lib/libcfont.so.0 -> libcfont.so.0.0.0
-rw-r--r-- 1 root root   10644 2006-09-05 18:26 /lib/libcfont.so.0.0.0
-rw-r--r-- 1 root root  181684 2007-02-21 16:13 /lib/libcidn-2.3.6.so
lrwxrwxrwx 1 root root      16 2007-04-15 23:25 /lib/libcidn.so.1 -> libcidn-2.3.6.so
lrwxrwxrwx 1 root root      17 2007-04-15 23:25 /lib/libcom_err.so.2 -> libcom_err.so.2.1
-rw-r--r-- 1 root root    5820 2007-03-07 03:17 /lib/libcom_err.so.2.1
lrwxrwxrwx 1 root root      19 2007-04-15 23:25 /lib/libconsole.so.0 -> libconsole.so.0.0.0
-rw-r--r-- 1 root root   73540 2006-09-05 18:26 /lib/libconsole.so.0.0.0
-rw-r--r-- 1 root root   21868 2007-02-21 16:13 /lib/libcrypt-2.3.6.so
lrwxrwxrwx 1 root root      17 2007-04-15 23:25 /lib/libcrypt.so.1 -> libcrypt-2.3.6.so
lrwxrwxrwx 1 root root      14 2007-04-15 23:25 /lib/libc.so.5 -> libc.so.5.4.46
-rw-r--r-- 1 root root  565940 2003-09-22 17:45 /lib/libc.so.5.4.46
lrwxrwxrwx 1 root root      13 2007-04-15 23:25 /lib/libc.so.6 -> libc-2.3.6.so
lrwxrwxrwx 1 root root      19 2007-04-15 23:25 /lib/libctutils.so.0 -> libctutils.so.0.0.0
-rw-r--r-- 1 root root   18380 2006-09-05 18:26 /lib/libctutils.so.0.0.0

/lib/libc5-compat:
total 0
user@machine:~$
user@machine:~$
user@machine:~$
user@machine:~$ /lib/libc.so.6
GNU C Library stable release version 2.3.6, by Roland McGrath et al.
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
Compiled by GNU CC version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21).
Compiled on a Linux 2.6.18 system on 2007-02-21.
Available extensions:
        GNU libio by Per Bothner
        crypt add-on version 2.1 by Michael Glad and others
        GNU Libidn by Simon Josefsson
        linuxthreads-0.10 by Xavier Leroy
        BIND-8.2.3-T5B
        libthread_db work sponsored by Alpha Processor Inc
        NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk
Thread-local storage support included.
For bug reporting instructions, please see:
<http://www.gnu.org/software/libc/bugs.html>.

_________________
mfg komsomolze


Zuletzt bearbeitet von komsomolze am 21. Jul 2007 17:48, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

Huan Sen
Gast





BeitragVerfasst am: 21. Jul 2007 10:07   Titel:

Mh... das passiert, wenn ich die Schritte bei mir mache.

Zitat:

suse10164lamp:~ # uname -r
2.6.16.13-4-smp
suse10164lamp:~ # rpm -qa | grep libc6
suse10164lamp:~ #


Also nichts (?).

Bei you bekomme ich zwar jede Menge Patches in einer ellenlangen Listen angezeigt. Was ich aber davon installieren soll, um libc6 zu aktualisieren, weiß ich nicht.

Vielen Dank bis hierhin, aber das hat nicht wirklich weitergeholfen. Welchen Weg sollte ich denn nun gehen, um libc6 zu aktualisieren?
 

Huan Sen
Gast





BeitragVerfasst am: 21. Jul 2007 10:08   Titel:

Mh... das passiert, wenn ich die Schritte bei mir mache.

Zitat:

suse10164lamp:~ # uname -r
2.6.16.13-4-smp
suse10164lamp:~ # rpm -qa | grep libc6
suse10164lamp:~ #


Also nichts (?).

Bei you bekomme ich zwar jede Menge Patches in einer ellenlangen Listen angezeigt. Was ich aber davon installieren soll, um libc6 zu aktualisieren, weiß ich nicht.

Vielen Dank bis hierhin, aber das hat nicht wirklich weitergeholfen. Welchen Weg sollte ich denn nun gehen, um libc6 zu aktualisieren?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 21. Jul 2007 11:14   Titel:

Das Paket heißt ja auch nicht libc6, sondern glibc. Kannst das ja mal über den YaST-Onlineupdater auf den neusten Stand bringen. Ich glaube aber nicht, das hier das Problem liegt.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Huan Sen
Gast





BeitragVerfasst am: 23. Jul 2007 17:19   Titel:

Ist denn das schon der neueste Schrei?

Zitat:

suse10164lamp:~ # ls -l /lib/libc*
-rwxr-xr-x 1 root root 1404242 Apr 12 01:14 /lib/libc-2.4.so
lrwxrwxrwx 1 root root 11 Apr 12 01:14 /lib/libc.so.6 -> libc-2.4.so
lrwxrwxrwx 1 root root 14 Apr 12 01:14 /lib/libcap.so.1 -> libcap.so.1.92
-rwxr-xr-x 1 root root 10456 Apr 12 01:14 /lib/libcap.so.1.92
-rwxr-xr-x 1 root root 187186 Apr 12 01:14 /lib/libcidn-2.4.so
lrwxrwxrwx 1 root root 14 Apr 12 01:14 /lib/libcidn.so.1 -> libcidn-2.4.so
lrwxrwxrwx 1 root root 17 Apr 12 01:14 /lib/libcom_err.so.2 -> libcom_err.so.2.1
-rwxr-xr-x 1 root root 6272 Apr 12 01:14 /lib/libcom_err.so.2.1
-rwxr-xr-x 1 root root 47259 Apr 12 01:14 /lib/libcrypt-2.4.so
lrwxrwxrwx 1 root root 15 Apr 12 01:14 /lib/libcrypt.so.1 -> libcrypt-2.4.so
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 23. Jul 2007 18:44   Titel:

Das ist die stable-Version für SuSE10.2:
Code:
$ rpm -q glibc
glibc-2.5-25
$

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Huan Sen
Gast





BeitragVerfasst am: 20. Sep 2007 8:01   Titel:

Wo kann ich denn dieses Paket bekommen? Smile
 

Huan Sen
Gast





BeitragVerfasst am: 20. Sep 2007 8:05   Titel:

Ah, ich habe hier was gefunden: http://rpmseek.com/rpm-pl/glibc.html?hl=de&cs=glibc:PN:0:0:0:0

Doch welches Paket nehme ich für einen AMD Athlon 64?

glibc-2.5-25.i586.rpm oder glibc-2.5-25.i686.rpm?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 20. Sep 2007 8:41   Titel:

Beides geht. Das i686-Paket ist für Pentium-II und folgende optimiert, läuft also einfach nur nicht auf Pentium/PentiumMMX-Rechnern.

Aber wie schon geschrieben: Das ist bereits die neueste Version, die es für SuSE10.2 gibt. Wenn du was noch neueres brauchst, musst du glibc selbst kompilieren (das würde selbst ich nur als wirklich allerletzte Maßnahme anwenden), oder SuSE10.3 benutzen -- auch noch nicht wirklich empfehlenswert.

Evtl. gibt es auch eine etwas ältere Version eures "Game of Defeat", das mit der aktuellen Version der glibc funzt?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Huan Sen
Gast





BeitragVerfasst am: 20. Sep 2007 9:18   Titel:

Ich habe es nun mit rpm -U glibc-2.5-25.i586.rpm installiert. Doch rpm -q glibc ergibt weiterhin "glibc-2.4-25".

Was muss ich noch tun? Cool
 

Huan Sen
Gast





BeitragVerfasst am: 20. Sep 2007 9:34   Titel:

Da kamen auch allerdings einige Meldungen wie

Zitat:

[...]
libutil.so.1()(64bit) is needed by (installed) openssh-4.2p1-18.x86_64
libutil.so.1()(64bit) is needed by (installed) libzypp-1.3.2-0.9.x86_64
[...]
 

Huan Sen
Gast





BeitragVerfasst am: 20. Sep 2007 10:21   Titel:

Oups, da kommen doch einige Meldungen mehr:

Zitat:

file /etc/default/nss from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /etc/ld.so.cache from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /etc/ld.so.conf from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /sbin/ldconfig from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/bin/gencat from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/bin/getconf from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/bin/getent from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/bin/iconv from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/bin/ldd from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/bin/locale from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/bin/localedef from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/sbin/glibc_post_upgrade from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/sbin/iconvconfig from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /usr/sbin/rpcinfo from install of glibc-2.5-25 conflicts with file from package glibc-2.4-25
file /lib/ld-linux.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libBrokenLocale.so.1 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libSegFault.so from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libanl.so.1 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libc.so.6 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libcidn.so.1 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libcrypt.so.1 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libdl.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libm.so.6 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libmemusage.so from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libnsl.so.1 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libnss_compat.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libnss_dns.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libnss_files.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libnss_hesiod.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libnss_nis.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libnss_nisplus.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libpcprofile.so from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libpthread.so.0 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libresolv.so.2 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/librt.so.1 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libthread_db-1.0.so from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30
file /lib/libutil.so.1 from install of glibc-2.5-25 conflicts with file from package glibc-32bit-2.4-30


Muß ich also das glibc-32bit-2.4-30 erst de-installieren? Kann ich das gefahrlos machen?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 20. Sep 2007 20:11   Titel:

Nein, das geht nicht gefahrlos.Wenn du glibc deinstallierst, funktioniert kein einziges Binary mehr, das darauf zugreift, nicht einmal mehr die bash und das rpm-Werkzeug!

Bevor du dich da ranmachst, upgrade lieber die ganze Distribution zu SuSE10.2, das ist sicher schmerzloser.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy