Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Shell: Schwarzer Bildschirm

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
lipox



Anmeldungsdatum: 09.08.2007
Beiträge: 3

BeitragVerfasst am: 09. Aug 2007 11:14   Titel: Shell: Schwarzer Bildschirm

Hallo Leute.
Da mir meine alta Riva128 nun doch etwas alt erschien, habe ich mir vor kurzem eine preiswerte nvidia 6200 zugelegt.
Bin soweit auch sehr zufrieden, beryl u.ä. läuft.

Mein Problem ist aber folgendes. Starte ich den X-Server, dann ist es nicht mehr möglich (mittels ALT+STRG+F1,..) in die Shell zu wechseln. Der Bildschirm bleibt dann schwarz. Das Problem tritt nicht auf, wenn ich den PC ohne X hochfahre. Ich denke es funktioniert nicht mehr, sobald der NVIDIA Treiber geladen wird.
Fehlermeldungen gibt es keine und andere Treiberversionen machen auch keinen Unterschied.

Wenn jemand ne Ahnung hat, was es sein könnte, wäre ich sehr dankbar.

Gruß lipox
 
Benutzer-Profile anzeigen Private Nachricht senden

Asa



Anmeldungsdatum: 11.07.2007
Beiträge: 30

BeitragVerfasst am: 09. Aug 2007 13:36   Titel:

hi,

läuft die konsole im framebuffer? ( erkennbar an höherer auflösung und meist mit netter grafik drumherum - z.B. bei (open)suse so weit ich weiß noch immer standard)
framebuffer und nvidia-treiber vertragen sich nicht wirklich. sollte deine distri einen verwenden, erstmal versuchen, ob es nicht reicht den abzuschalten...

gruß, asa
_________________
mihi enim liber esse non videtur, qui non aliquando nihil agit.
M. Tullius Cicero
 
Benutzer-Profile anzeigen Private Nachricht senden

ano max
Gast





BeitragVerfasst am: 09. Aug 2007 16:13   Titel: oder

oder sicher dass das kein alpha-compitz ist was da läuft ??
 

lipox



Anmeldungsdatum: 09.08.2007
Beiträge: 3

BeitragVerfasst am: 10. Aug 2007 7:15   Titel: Re: oder

Asa hat folgendes geschrieben::
hi,

läuft die konsole im framebuffer? ( erkennbar an höherer auflösung und meist mit netter grafik drumherum - z.B. bei (open)suse so weit ich weiß noch immer standard)
framebuffer und nvidia-treiber vertragen sich nicht wirklich. sollte deine distri einen verwenden, erstmal versuchen, ob es nicht reicht den abzuschalten...

gruß, asa


Ne,also die Konsole läuft nicht im Framebuffer. Distri ist im Übrigen Fedora 7 ... ganz vergessen Wink

ano max hat folgendes geschrieben::
oder sicher dass das kein alpha-compitz ist was da läuft ??

Bin jetzt nich sicher was alpha-compiz sein soll. Aber falls sich das auf den Windowmanager bezieht, kann ich nur sagen, dass es keinen Unterschied macht, ob metacity, kwin, xfwm4, ...

Kann es vielleicht irgendwas an der xorg.conf sein?



Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu May  3 16:02:56 PDT 2007

# Xorg configuration created by livna-config-display

Section "ServerLayout"
    Identifier     "single head configuration"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath      "/usr/lib/xorg/modules"
EndSection

Section "Module"
   Load "dbe"
   Load "v4l"
   Load "extmod"
   Load "type1"
   Load "freetype"
   Load "glx"
EndSection

Section "ServerFlags"
    Option         "AIGLX" "on"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "de"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    ModelName      "LCD Panel 1280x1024"
    HorizSync       31.5 - 67.0
    VertRefresh     70.0 - 75.0
    Option         "dpms"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
   Option "RenderAccel" "true"
   Option "AllowGLXWithComposite" "true"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

 
Benutzer-Profile anzeigen Private Nachricht senden

ano max
Gast





BeitragVerfasst am: 10. Aug 2007 8:20   Titel: cpompitz

Hallo,

mir hatte mal jemand von Version 7 von Fedora abgeraten, warum habe ich vergessen - weil das benutze ich eh' nicht...

Mit dem Compiz (das Gegenstück zu Beryl, die Projekte hatten sich damals getrennt und sind seit kurzem wiedervereint) hatte ich damals Probleme bei manchen Dingen (u.a. Rahmen-Darstellung).

Du hast noch den Org-NVidia-Treiber, damit Funktioniert 3D flüssig? *wunder*
Ich würde mal den richtigen Treiber von NVidia einspielen...

Bye
any max
 

Asa



Anmeldungsdatum: 11.07.2007
Beiträge: 30

BeitragVerfasst am: 10. Aug 2007 14:18   Titel:

hi,

also ... deine xorg.conf sieht so auf den ersten blick ok aus.

compiz und ähnliche sind zur zeit aber tatsächlich noch nicht besonders stabil.
wenn du compiz benutzt, dann ist compiz dein windowmanager. (z.B. bei gnome ersetzt er dann metacity -- meist aufgerufen mit compiz --replace). versuche es doch mal (wenn du das nicht schon gemacht hast) ohne composite manager. der einzige, mit dem ich noch keine probleme hatte, ist der in xfce eingebaute (einstellungen -> fentermanager-tweaks -> compositor, glaub ich). muß aber gestehen, wenn man - wie ich - nicht gerade neuere hardware hat, dann kann man sich schon fragen, ob man auf den compositor-eye-candy nicht auch verzichten kann.

als radikale methode zu testen, ob's am composite-manager liegt, bliebe natürlich, in der xorg.conf mal alle composite einstellungen auszukommentieren....

Zitat:
Du hast noch den Org-NVidia-Treiber, damit Funktioniert 3D flüssig? *wunder*


@ ano max: wieso den org-nvidia-treiber? das wäre der "nv" -treiber. wenn die treiber installation ansonsten geklappt hat (und danach sieht es aus, denn:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig

-- die xorg.conf ist vom install-script angepasst ),

dann ist "nvidia" der richtige treiber.
_________________
mihi enim liber esse non videtur, qui non aliquando nihil agit.
M. Tullius Cicero
 
Benutzer-Profile anzeigen Private Nachricht senden

ano max
Gast





BeitragVerfasst am: 10. Aug 2007 16:25   Titel: sorry

@wieso den org-nvidia-treiber? das wäre der "nv" -treiber.

Ok - habe ich verwechselt
 

ano max
Gast





BeitragVerfasst am: 10. Aug 2007 16:45   Titel: beser mit 2 monitoren

Hallo,

passt zwar nicht zum Thema, aber zur Karte:
Nachdem ich eine Weile mit beryl & co. rumgespielt hatte:
Das brauche ich eigentlich nicht wirklich.

Besser finde ich:
Ich habe mir zum meinem alten 15" LCD noche einen 17"er zugelegt incl. dieser preiswerten Grafikkarte.

Nun gibts die Optionen

- beide bilden das gleiche ab -> nur für Demonstartionszwecke sinnvoll

- 2 Monitore als ein Bildschirm -> bei Monitoren verschiedener Auflösung nicht das goldene vom Ei, geht zwar, aber klickt man auf ein Icon geht dann die Anwendung oft über beide Monitore auf und diese muss man erst zurechtschieben.

- 2 Monitore getrennt betrieben, jeder mit einen Startleiste, Hintergrundbild usw.
Dabei kann man den Mauszeiger und die Icons von einem zum anderen Monitor verschieben, aber nicht die Anwendungen. Diese starten in dem Display indem auch die Icons angeklickt wurden. (Ausser man kann den Anwendungen die Displaynummer mitgeben, wie bei camorama).

Zur konfiguration gibts von nvidia "NVIDIA-Settings".
Hier meine xorg:
Code:

# /etc/xorg.conf fuer nvidia-Karte 6200 Dual-Ausgang
# DFP (digital) und CRT (analog TFT)
#
# ****************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# ****************************************************************
#

# ****************************************************************
# Module section - dynamisch ladbare Module
# ****************************************************************

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
EndSection

Section "Extensions"
    Option "Composite"
EndSection

Section "Files"
    # font server independent of the X server to render fonts.
    # minimal fonts to allow X to run without xfs
    ModulePath "/usr/lib/xorg/modules/extensions/nvidia97xx"
    ModulePath "/usr/lib/xorg/modules"
    FontPath "unix/:-1"
    FontPath "/usr/share/fonts/misc:unscaled"
EndSection
# ****************************************************************
# Server flage section
# ****************************************************************

Section "ServerFlags"
    Option "Xinerama" "0"

    # Option "DontZap" # disable <Crtl><Alt><BS> (server abort)
    # Option "Dont VTSwitch"
    # Option "DontZoom" # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    # allows the server to start up even if the mouse does not work:
    Option "allowmouseopenfail"
EndSection
# ****************************************************************
# Input device section
# ****************************************************************

Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "de(nodeadkeys)"
    Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
EndSection
# ****************************************************************
# Graphics device section
# ****************************************************************

Section "Device"
    Identifier "Videocard0"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 6200"
    Driver "nvidia"
    Screen 0
    BusID "PCI:1:0:0"
EndSection

Section "Device"
    Identifier "Videocard1"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 6200"
    Driver "nvidia"
    Screen 1
    BusID "PCI:1:0:0"
EndSection
# ****************************************************************
# Monitor section
# ****************************************************************

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Philips 170C"
    HorizSync 30.0 - 83.0
    VertRefresh 56.0 - 76.0
EndSection

Section "Monitor"
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    Identifier "Monitor1"
    VendorName "Unknown"
    ModelName "GERICOM 520A"
    HorizSync 31.0 - 60.0
    VertRefresh 56.0 - 85.0
    ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
    ModeLine "768x576" 63.0 768 800 960 1024 576 578 590 616
EndSection
# ****************************************************************
# Screen section
# ****************************************************************

Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24

    Subsection "Display"
        Depth 24
        Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Option "metamodes" "DFP: nvidia-auto-select +0+0"
    Option "TwinView" "0"
EndSection

Section "Screen"
    Identifier "Screen1"
    Device "Videocard1"
    Monitor "Monitor1"
    DefaultDepth 24

    Subsection "Display"
        Depth 24
        Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Option "DPMS"

    # Option         "AddARGBGLXVisuals"
    Option "TwinView" "0"
    Option "metamodes" "CRT: nvidia-auto-select +0+0"
EndSection
# ****************************************************************
# Server Layout section
# ****************************************************************

Section "ServerLayout"
    Identifier "ServerLayout0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen 0  "Screen0" 0 0
    Screen 1  "Screen1" RightOf "Screen0"
EndSection


gefällt mir jedenfalls Wink

bye
ano max
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy