Tastaturproblem bei XDMCP Server - lokale Anmeldung

Antworten
Nachricht
Autor
MSA2000
Beiträge: 3
Registriert: 15. Aug 2007 15:18

Tastaturproblem bei XDMCP Server - lokale Anmeldung

#1 Beitrag von MSA2000 » 15. Aug 2007 16:29

Hallo Leute,

nun habe ich ne ganze Weile gegooglet und mich auch hier im Forum umgesehen, wurde aber leider nicht fündig. Ich hoffe, Ihr könnt mir helfen.

Es geht um folgendes: ich habe einen stärkeren PC als XDMCP Server einrichten können. Ich kann mich auch schon mit ca. 12 schwachen Terminal PCs anmelden. Das alles läuft super.
Das lokale Anmelden beim Server-PC hat anfangs auch gut geklappt. Ich weiß nicht, ob ich da was bei den Einstellungen, oder bei den Config-Files verpfuscht habe, aber seit ner Weile will die Tastatur nicht mehr bei der lokalen Anmeldung am Server (nicht an einem Terminal).
Wenn ich über [Strg] + [Esc] zur Shell wechsle funktioniert sie wieder. Nur bei der grafischen Anmeldung will es nicht. Die Maus funktioniert, aber Eingaben mit der Tastatur kann ich nicht machen.

Habe ich da irgendwelche Sicherheitsmechanismen aktiviert, oder ähnliches?
Hat jemand ne Idee, wie ich das Problem lösen kann?

Als BS habe ich Suse Linux 10.1 benutzt.
Die Tastatur ist ne Standard-Tastatur an PS2.

Es wäre toll, wenn mir jemand weiter helfen könnte.

Viele Grüße,

MSA2000

Benutzeravatar
Janka
Beiträge: 3585
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 15. Aug 2007 19:23

Ich habe in einer Installation bei einem Bekannten ein ähnliches Problem. Es tritt aber nur direkt nach dem Booten auf. Wenn ich in der Konsole "rcxdm restart" mache, habe ich danach im X wieder eine Tastatur.

Kannst ja mal ausprobieren, ob das bei dir derselbe Fehler ist.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

MSA2000
Beiträge: 3
Registriert: 15. Aug 2007 15:18

Problem gelöst

#3 Beitrag von MSA2000 » 16. Aug 2007 17:06

Hi Janka,

danke für den Tipp.
Es war bei mir der selbe Fall. Also direkt nach dem Booten ging die Tastatur nicht mehr.
Die Tastenkombination, um in die Konsole zu gelangen funktionierte trotzdem. Und dort hat dann auch die Tastatur wieder getan.

Ich habe das mit "rcxdm restart" getestet, hat mir aber leider nicht geholfen. Es hat mich aber auf die richtige Fährte gebracht und ich habe es doch tatsächlich geschaft, das Problem zu lösen.

Also mein Problem lag an der "/etc/X11/xorg.conf"

In dieser Datei werden ja, soweit ich das verstanden habe, z.B. die Konfigurationen von InputDevices festgelegt.
In meinem Fall wurden als InputDevices auch VNC - Geräte (Tastatur und Maus) eingerichtet.
Somit hatte ich eine 2. Tastatur mit dem Identifier "Keyboard[2]"

Code: Alles auswählen

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "pc105"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
  Driver       "rfbkeyb"
  Identifier   "Keyboard[2]"
  Option       "InputFashion" "VNC"
EndSection
Komischerweise stand bei mir in der Section "ServerLayout"

Code: Alles auswählen

InputDevice  "Keyboard[2]" "CoreKeyboard"
An dieser Stelle habe ich den Identifier Keyboard[2] durch Keyboard[0] ersetzt und die Tastatur ging wieder nach einem "rcxdm restart" in der Konsole, bzw. einem Neustart.

Nun habe ich auf meinem Laptop gesehen, dass an der selben Stelle statt

Code: Alles auswählen

InputDevice  "Keyboard[0]" "CoreKeyboard"
folgende Zeile steht:

Code: Alles auswählen

InputDevice  "Keyboard[2]" "ExtraKeyboard"
Sieht also danach aus, dass man beide Varianten verwenden kann.

Problem endlich gelöst :D

Grüße!!!

Antworten