Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
via K8N890CE Chrome9 integrated graphics "amd64"
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Celuldor
Gast





BeitragVerfasst am: 30. Aug 2007 13:36   Titel: via K8N890CE Chrome9 integrated graphics "amd64"

hi
ich ich versuche seit längerem den "K8N890CE Chrome9™ integrated graphics" in einem amd64 system zum laufen zu bringen

diese erwies sich als *bis-jetzt* unmöglich

[COLOR="Red"]beim ersten versuch mit anleitung von viaarena.com :[/COLOR]

Code:
OffLine:/home/celuldor/Desktop/VT3336-3364XORG40079-kernel-src_20070611/src# ./vinstall
 -------- install start --------
Fatal error, not support this distribution!
OffLine:/home/celuldor/Desktop/VT3336-3364XORG40079-kernel-src_20070611/src#


man bemerke ich habe das genommen was laut viaarena.com der debiantreiber iss

[COLOR="Red"]der nächste versuch:[/COLOR]

hab mal von der selben seite nen älteren treiber versucht
Code:
OffLine:/home/celuldor/Desktop/K8M890XF40069-kernel-src_20060620/src# ./vinstall336
 -------- install start --------
Install VIA/S3G UniChrome familly graphic driver!
Which CPU do you use ?
1. VIA C3-2(C5N/C5P), C7, Intel Pentium 2/3/4
2. VIA C3
3. AMD K7
4. AMD K8 with 32 bits OS(x86)
5. AMD K8 with 64 bits OS(x86_64)
5
Please wait...
cp: Aufruf von stat für „XServer/via_drv.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
Now start to install VIA/S3G display utility...

Warning, system cannot find the /usr/X11R6/lib/libXv.so.1.0 file.
Please install XFree86-libs RPM package first.
You can find the package in the installation CD.

Abort, the utility is not installed.
OffLine:/home/celuldor/Desktop/K8M890XF40069-kernel-src_20060620/src# 


[COLOR="Red"]und wieder mutig bei:[/COLOR]

hab nu auf anraten eines kolegen einen symlink von der vorhandenen /usr/X11R6/lib/libXv.so.1.0.0 auf die angeforderte /usr/X11R6/lib/libXv.so.1.0 gelegt
Code:
OffLine:/home/celuldor/Desktop/K8M890XF40069-kernel-src_20060620/src# ./vinstall336
 -------- install start --------
Install VIA/S3G UniChrome familly graphic driver!
Which CPU do you use ?
1. VIA C3-2(C5N/C5P), C7, Intel Pentium 2/3/4
2. VIA C3
3. AMD K7
4. AMD K8 with 32 bits OS(x86)
5. AMD K8 with 64 bits OS(x86_64)
5
Please wait...
cp: Aufruf von stat für „XServer/via_drv.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
Now start to install VIA/S3G display utility...
Put the main program(s3utility) into the bin directory: /usr/local/bin
Utility installation is finished!
Now start to modify X config...
X config file '/etc/X11/XF86Config-4' or '/etc/X11/XF86Config' not fond. Exit!
OffLine:/home/celuldor/Desktop/K8M890XF40069-kernel-src_20060620/src#


[COLOR="Red"]da ich nochimmer ohne grafik bin:[/COLOR]

nach einigem hin-und-her probieren hab ich nu diese ausgabe inner konsole ich weiss nicht ob ich mich dem ziehl nähere oder mich entferne *schwitz*

http://nopaste.debianforum.de/6540


[COLOR="Red"]und auch der versuch auf das 64bit sys zu verzichten war nicht gut^^[/COLOR]
hab jetzt mal testweise n 32-bit sys installiert und versucht die treiber zu compilieren

aber mit mässigem bis garkeinem erfolg Sad

http://nopaste.debianforum.de/6547

[COLOR="Red"]wie sich am nächsten tag herausstellte[/COLOR]
ok die idee mit dem 32'er system und dem amd64-kernel scheint doof gewesen zu sein

nu kann ich keine pci-karten mehr nutzen
---

das meine bisherige leidensgeschichte
also wenn hier einer rat weiss Smile bin für jede hilfe dankbar
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 30. Aug 2007 16:14   Titel:

Der UniChrome-Treiber ist doch sowieso seit einigen Releases im Vanilla-Kernel und Xorg mit dabei. Wieso machst du dir den Stress mit Treiberpaketen von VIA?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 31. Aug 2007 9:07   Titel:

Dieser unterstützt aber neuere Chips nicht. Die Treiber, die man von Via bekommt sind ziemlicher Müll. Am besten sind noch die von openchrome.org, aber noch weit entfernt von perfekt (z. B. Probleme bei xv oder OpenGL).
 
Benutzer-Profile anzeigen Private Nachricht senden

Celuldor
Gast





BeitragVerfasst am: 01. Sep 2007 9:11   Titel:

jo aber beim opencrome iss mit K8M800 schluss
ich hab aber den K8N890CE und der wird da leider auch nicht supportet Sad
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 01. Sep 2007 14:37   Titel:

Wenn Du kannst benutze eine andere Grafikkarte, mit dem Ding wirst Du wenig Spaß haben. Wenn's natürlich nen Laptop ist hast Du Pech gehabt. Und das, obwohl Via Treibersupport verspricht - nur ist der noch weitaus mieser als der von Ati.
 
Benutzer-Profile anzeigen Private Nachricht senden

Celuldor



Anmeldungsdatum: 01.09.2007
Beiträge: 10

BeitragVerfasst am: 01. Sep 2007 21:12   Titel:

ich währ auch schon mit nem funsenden 2d treiber zufrieden

weil immo läuft hier nur der standart vesa treiber
und bei dem schaff ich es einfach nicht die bildwiederhohlrate meines monitors auf meine heissgeliebte 100 Hz zu stellen

stattdessen muss ich mich hier mit 51 - 60 Hz (entscheidet x beim start selber^^) begnügen
und das geht enorm auf die augen Sad
 
Benutzer-Profile anzeigen Private Nachricht senden MSN Messenger

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 01. Sep 2007 21:41   Titel:

Das funktioniert mit etwas Glück mit dem Openchrome Treiber. Eine Anleitung gibt es beispielsweise hier, das ist aber Bastelarbeit. Die PCI-ID in der Anleitung (0x1106 0x3344) mußt Du mit lspci ermitteln und entsprechend anpassen (falls sie noch nicht drinsteht).
 
Benutzer-Profile anzeigen Private Nachricht senden

Celuldor



Anmeldungsdatum: 01.09.2007
Beiträge: 10

BeitragVerfasst am: 01. Sep 2007 22:33   Titel:

PCI-ID ???
wo bekomm ich die her (es ist onboard) >>Titel: via K8N890CE Chrome9 integrated graphics "amd64"

Code:
celuldor@OffLine:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.5 PIC: VIA Technologies, Inc. K8M890CE I/O APIC Interrupt Controller
00:00.7 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:02.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:03.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 Host bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: VIA Technologies, Inc. Unknown device 3230 (rev 11)
04:05.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
04:05.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
80:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
celuldor@OffLine:~$


scheint wichtig zu sein^^ denn ohne
Code:
celuldor@OffLine:~/drm/linux-core$ sudo make LINUXDIR=/lib/modules/`uname -r`/build DRM_MODULES=via
make -C /lib/modules/2.6.21-2-amd64/build  SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.21-2-amd64'
  CC [M]  /home/celuldor/drm/linux-core/drm_auth.o
In file included from /home/celuldor/drm/linux-core/drm_auth.c:36:
/home/celuldor/drm/linux-core/drmP.h:44:26: error: linux/config.h: Datei oder Verzeichnis nicht gefunden
make[2]: *** [/home/celuldor/drm/linux-core/drm_auth.o] Fehler 1
make[1]: *** [_module_/home/celuldor/drm/linux-core] Fehler 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.21-2-amd64'
make: *** [modules] Fehler 2
celuldor@OffLine:~/drm/linux-core$
 
Benutzer-Profile anzeigen Private Nachricht senden MSN Messenger

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 02. Sep 2007 8:03   Titel:

Das hat nichts mit der PCI-ID zu tun. Das list lediglich die Kennung, damit der Treiber die Grafikkarte erkennt. Deine Grafikkarte hat die Nummer "01:00.0". Gib nochmal "lspci -n" ein und gucke, und gucke was dort bei "01:00.0" steht. Das sollte die PCI-ID sein. Bei mir steht dort beispielsweise "10de:005d"

Du mußt die Kernel Header oder Quellen installieren. Zudem alle Header von x.org. Je nach Distribution heißen die Pakete dazu unterschiedlich. Bei Debian enden alle Development Pakte mit "-dev", dort reicht ein "apt-get install xorg-dev". Sag uns doch einfach, welche Distribution Du hast.

Nochmals: Wenn das Board einen passenden Steckplatz für eine Grafikkarte hat, nimm lieber das billigste von NVidia. Das ist 3D-mäßig sicher schneller als Via und Du sparst Dir ne Menge Zeit und Nerven.
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 02. Sep 2007 8:31   Titel:

Und nach dem installieren der Kernelquellen
Code:

zcat /proc/config.gz >/usr/src/linux/.config

nicht vergessen! Damit übernimmst du die Konfiguration des laufenden Kernels als Vorgabe. Könnte für das Kompilieren des Openchrome-Treibers wichtig sein.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Celuldor



Anmeldungsdatum: 01.09.2007
Beiträge: 10

BeitragVerfasst am: 02. Sep 2007 8:39   Titel:

hab debian-lenny-amd64
hab alle dev's bereits

und
Code:
OffLine:/home/celuldor# lspci -n | grep 01:00.0
01:00.0 0300: 1106:3230 (rev 11)
OffLine:/home/celuldor#


also geh ich mal von aus das die magischen zahlen die ich brauch 1106:3230 sind
oder wird das (rev 11) dahinter auch gebraucht ?

hab mal gesucht wegen "error: linux/config.h: Datei oder Verzeichnis nicht gefunden" und kein wunder das er die nicht findet
die iss ja auch nicht da


Zuletzt bearbeitet von Celuldor am 02. Sep 2007 8:55, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden MSN Messenger

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 02. Sep 2007 8:43   Titel:

Ja genau die. Danach durchsuchst Du die Datei drm_pciids.txt. Wenn's nicht drin steht mußt Du einen Eintrag hinzufügen. Wichtig sind die Zahlen, der Text rechts davon ist egal.
 
Benutzer-Profile anzeigen Private Nachricht senden

Celuldor



Anmeldungsdatum: 01.09.2007
Beiträge: 10

BeitragVerfasst am: 02. Sep 2007 9:05   Titel:

der eintrag dieser daten ändert nix am resultat von oben Sad
 
Benutzer-Profile anzeigen Private Nachricht senden MSN Messenger

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 02. Sep 2007 9:18   Titel:

Lies Dir den ersten Absatz meines Postings von oben nochmal durch !

Das Problem liegt hier:

Code:
/home/celuldor/drm/linux-core/drmP.h:44:26: error: linux/config.h: Datei oder Verzeichnis nicht gefunden


Wenn Du die Kernel-Header bzw. Sourcen installierst, wird diese Datei installiert.
 
Benutzer-Profile anzeigen Private Nachricht senden

Celuldor



Anmeldungsdatum: 01.09.2007
Beiträge: 10

BeitragVerfasst am: 02. Sep 2007 10:58   Titel:

ich habe den header und die source installiert

Code:
celuldor@OffLine:~$ such linux-image-2.6.21-2-amd64
i A linux-image-2.6.21-2-amd64      - Linux 2.6.21 image on AMD64
celuldor@OffLine:~$ such linux-headers-2.6.21-2-amd64
i   linux-headers-2.6.21-2-amd64    - Header files for Linux 2.6.21 on AMD64
celuldor@OffLine:~$ such linux-source-2.6.21
i   linux-source-2.6.21             - Linux kernel source for version 2.6.21 wit
celuldor@OffLine:~$ 


genau deshalb wundere ich mich ja das die datei nicht da ist Sad
 
Benutzer-Profile anzeigen Private Nachricht senden MSN Messenger

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy