Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Nov 2018 4:04

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 12. Nov 2007 20:54 
Offline

Registriert: 08. Nov 2007 22:42
Beiträge: 2
Hallo,

ich habe mir von der Homepage meines Druckerherstellers (Brother HL-1270N) den Original Debian Linuxtreiber (hl1270nlpr-1.1.2-1.i386.deb) heruntergeladen und zunächst versucht diesen mit Hilfe von GDebi Package Installer zu installieren. Dies wurde ohne eine Fehlermeldung abgebrochen. Danach versuchte ich diesen Treiber / Paket mit Synaptic zu installieren. Auch hier wurde ohne eine Fehlermeldung die Installation abgebrochen. Wenn ich jetzt versuche, ein Paket / Paketupdates einzuspielen, bricht der update-notifier ab, bzw. es lassen sich unter Synaptic keine Pakete mehr einspielen.

Ich erhalte unter kpackage folgende Fehlermeldung:

Desktop/hl1270nlpr-1.1.2-1.i386.deb' ;echo RESULT=$?
(Lese Datenbank ... 146027 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereiten zum Ersetzen von hl1270nlpr 1.1.2-1 (durch .../hl1270nlpr-1.1.2-1.i386.deb) ...
Entpacke Ersatz für hl1270nlpr ...
/var/lib/dpkg/info/hl1270nlpr.postrm: line 3: /etc/init.d/lpd: Datei oder Verzeichnis nicht gefunden
dpkg: Warnung - altes post-removal-Skript wurde mit Fehler-Status 127 beendet
dpkg - probiere stattdessen Skript aus dem neuen Paket ...
/var/lib/dpkg/tmp.ci/postrm: line 3: /etc/init.d/lpd: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Bearbeiten von ///home/markus/Desktop/hl1270nlpr-1.1.2-1.i386.deb (--install):
Unterprozess neues post-removal-Skript gab den Fehlerwert 127 zurück
/var/lib/dpkg/tmp.ci/postrm: line 3: /etc/init.d/lpd: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Aufräumen:
Unterprozess post-removal script gab den Fehlerwert 127 zurück
Fehler traten auf beim Bearbeiten von:
///home/markus/Desktop/hl1270nlpr-1.1.2-1.i386.deb
RESULT=1

Beim Starten von Synaptic erhalte ich folgende Fehlermeldung:

E: Das Paket hl1270nlpr muss reinstalliert werden, ich kann aber kein Archiv dafür finden.
E: Interner Fehler beim Öffnen des Zwischenspeichers (1). Bitte melden Sie diesen Fehler.

Unter der Konsole (Runlevel 5) bring dpkg -C folgende Meldung:
Die folgenden Pakete befinden sich durch schwere Probleme bei der Installation
in einem Schlamassel. Sie müssen neu installiert werden, damit sie
(und alle von ihnen abhängende Pakete) ordnungsgemäß funktionieren:
hl1270nlpr Brother lpr Printer Definitions

dpkg -i hl1270nplr bringt folgende Fehlermeldung:

dpkg: Fehler beim Bearbeiten von hl1270nplr (--install):
Kann auf das Archiv nicht zugreifen: Datei oder Verzeichnis nicht gefunden
Fehler traten auf beim Bearbeiten von:
hl1270nplr


Hat jemand eine Idee, wie ich dieses Problem lösen kann?


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Nov 2007 11:24 
Offline
Pro-Linux
Benutzeravatar

Registriert: 15. Aug 1999 16:59
Beiträge: 3237
Wohnort: Bruchsal
Hi!

Das ist das wohl größte Problem von APT, dass es mit versauten Paketen keinen Ausweg anbietet. Das Paket wurde vom Hersteller verpfuscht, da es nicht voraussieht, dass /etc/init.d/lpd nicht existiert. Ich würde folgendes machen (als Root):
Code:
cp -a /bin/true /etc/init.d/lpd
Dann das Paket deinstallieren oder versuchen, korrekt zu installieren. Danach /etc/init.d/lpd wieder löschen.

Grüße,
hjb

_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Nov 2007 23:17 
Offline

Registriert: 08. Nov 2007 22:42
Beiträge: 2
Vielen Dank für die Nachricht,

Bis jetzt habe ich folgende Befehle ausprobiert (als root auf Konsole):

cp -a /bin/true /etc/init.d/lpd
dpkg -r hl1270nlpr

dpkg: Fehler beim Bearbeiten von hl1270nlpr (--remove):
Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie sollten
es erneut installieren, bevor Sie es zu entfernen versuchen.
Fehler traten auf beim Bearbeiten von:
hl1270nlpr

apt-get --force-yes remove hl1270nlpr
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
E: Das Paket hl1270nlpr muss reinstalliert werden, ich kann aber kein Archiv dafür finden.

:cry:

Was nun?


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14. Nov 2007 11:34 
Offline
Pro-Linux
Benutzeravatar

Registriert: 15. Aug 1999 16:59
Beiträge: 3237
Wohnort: Bruchsal
Hi!

Wie wär's damit:
Zitat:
Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie sollten
es erneut installieren, bevor Sie es zu entfernen versuchen.
Wenn dpkg -i auch nichts nützt, würde ich mal 'apt-get install -f' probieren, und wenn das auch das nicht klappt, dem Hersteller aufs Dach steigen.

Grüße,
hjb

_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de