Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Nov 2018 17:21

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 7 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: xfs startet nicht
BeitragVerfasst: 19. Nov 2007 7:59 
Ich habe hier ein Problem mit einem Linux-System, das auf einem Flash-Speicher liegt. Das funktioniert an sich ganz ordentlich. Jetzt habe ich /tmp allerdings auf die RAM-Disk gemountet um hier unnütze Zugriffe auf den Flash zu ersparen die diesen nur schneller kaputt gehen lassen.

Allerdings startet jetzt mein X nicht mehr, da der xfs nicht läuft. Woran könnte das liegen? Mein erster Gedanke war, das auf /tmp jetzt nicht mehr genug Platz ist, aber selbst wenn ich die Größe der RAM-Disk auf 10M erhöhe geht es immer noch nicht...


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Nov 2007 9:56 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Den XFS brauchst du auch nicht unbedingt. Unbedingt notwendig ist allerdings der Font-Cache, und der braucht, je nachdem, wieviele Fonts dein System hat, etwas Platz. Normalerweise liegt er bei /var/cache/fontconfig. Wo ist er bei dir?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Nov 2007 10:19 
/var/cache/fontconfig gibts bei mir auch, hier scheint /tmp also nicht beteiligt zu sein.

Der Einzige Unterschied, den ich bei verwendung der RAM-disk erkennen kann ist eben, dass der xfs nicht startet. Wenn ich ihn dann von Hand ausführe kommt X spannenderweise aber...


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Nov 2007 14:38 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Hast du nicht doch noch weitere Dinge verstellt? Ich habe hier bei einer SuSE10.2 beispielsweise auch /tmp (und /var/tmp) in einem tmpfs, das funktioniert ebenfalls und ist genau wie eine Ramdisk beim Systemstart leer.

Wo mountest du denn die Ramdisk? Per "mount -a" aus der fstab oder anderweitig?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Nov 2007 15:03 
Die RAM-Disk wird vom ersten Initscript erzeugt und eingebundent:

mke2fs /dev/ram0 # da das dingens ja formatiert werden muss
mount /dev/ram0 /tmp

Mehr is da eigentlich nicht...


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Nov 2007 22:01 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Kein chmod? In dem Fall darf nur root in deinem /tmp schreiben. Könnte ein Problem sein.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 20. Nov 2007 12:40 
Das Directory /tmp selber, in das gemountet wird hat schreibrechte für alle - reicht das nicht?


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 7 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de