Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
FSC Amilo XA-1526 unter opensuse 10.3

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Tips, Tricks, Helferlein
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Desert



Anmeldungsdatum: 13.06.2007
Beiträge: 8

BeitragVerfasst am: 20. Nov 2007 22:35   Titel: FSC Amilo XA-1526 unter opensuse 10.3

Hallo zusammen,

auf Wunsch stelle ich die Anleitung nochmals hier bei Tips und Tricks ein, wie WLan unter Linux automatisch bei einem XA-1526 gestartet und verbunden wird.

Nach langer Forensuche, vielen Problemen und endlosen Probieren habe ich es hinbekommen, dass mein Fujitsu-Siemens Amilo XA1526 unter Suse 10.3 läuft. Der ist per WLAN an eine FritzBox 7050 angeschlossen. Ob das auch mit dem Xi-1526 funktioniert, vermag ich allerdings nicht zu sagen (ich bin kein Experte). Wahrscheinlich funktioniert es aber auch für ähnliche Notebooks mit einem sis163u Chip.
So bin ich nach der Installation von Suse 10.3 (32 bit) vorgegangen:
1. ndiswrapper und ndiswrapper-kmp-default über yast installieren
2. sis163u Treiber von FSC Homepage oder direkt von sis besorgen (XP bzw. NT-Treiber) und lokal abspeichern und entpacken
3. auf konsole mit Alt-F2 kdesu konsole und nach su - in das Verzeichnis mit dem Treiber wechseln.
4. Befehl ndiswrapper -i sis163u.inf eingeben und danach mit ndiswrapper -l überprüfen
5. Danach noch auf der Konsole modprobe ndiswrapper eingeben
6. Nun das Netzwerk nicht über Yast einrichten, sondern auf dem Desktop unten rechts mit rechter Maustaste knetworkmanager -> Verbindung zu anderem drahtlosen Netzwerk herstellen anwählen
7. Dort Essid vom Router angeben
8. Verschlüsselung verwenden WPA Personal, Passwort eingeben und WPA2 wählen
9. daraufhin startet automatisch kwallet, dort Basiseinrichtung wählen
10. Brieftasche für pers. Information verwenden (ja anwählen)
11. kein Passwort eingeben für automatischen WLAN-Start (Sicherheitsrisiko), dann Abschließen anwählen
12. Das Programm knetworknanager verlangt Zugriff auf digitale Brieftasche stets zulassen wählen
13. über Yast -> System Editor für /etc/sysconfig Dateien in System -> Kernel -> Modules_loaded_on Boot ndiswrapper eintragen und mit Beenden abschließen. Geänderte Variablen mit OK bestätigen.
14. wieder über rechte Maustaste beim knetworkmanager -> Optionen -> Einrichten wählen und dann Drahtlose Netzwerke auswählen. Dort müsste eine Essid angegeben sein. Die bitte mit der Maus von NoFallback zu Fallback verschieben.

Das wars Very Happy Very Happy So hat es bei mir nachweislich funktioniert. Ich hoffe, dass dies evtl. auch anderen hilft. Nach Neustart verbindet sich mein Notebook automatisch per WLAN mit dem Router ohne zusätzliche Abfragen!
Vielleicht hat ja noch jemand Ergänzungen bzw. hat noch eine Idee bezüglich der dauernd laufenden Lüfter im XA1526. Wenn jemand noch zum gleichen Notebook Fragen zum Sound hat, bitte hier posten. Der läuft bei mir auch ohne Probleme (wenn mans weiß, kein Problem). Außerdem habe ich noch eine Farblaser von Samsung CLP-650N über Linux ins Netz eingebunden. Kann ich bei Bedarf auch noch eine Info zu geben!
Falls es diese Info dem einen oder anderen geholfen hat, würde ich mich über ein Feedback hier freuen. Ich hoffe es hilft, Linux weiter zu verbreiten.

Freundliche Grüße
Desert
 
Benutzer-Profile anzeigen Private Nachricht senden

terra44
Gast





BeitragVerfasst am: 04. Dez 2007 20:01   Titel: Lüfter

Hallo,

hatte gleiches Problem mit dem Lüfter.
Hier meine Lösung:

Trage am Ende der Datei /etc/init.d/boot.local
diese Zeilen ein.

echo -n 0 > /proc/acpi/fan/FN1/state
echo -n 0 > /proc/acpi/fan/FN2/state
sleep 1
echo -n 3 > /proc/acpi/fan/FN1/state
echo -n 3 > /proc/acpi/fan/FN2/state


Nach einem Neustart laufen die Lüfter nur noch bei Bedarf an.

Unter http://www.iaccarino.de/silvio/linuxnb.htm#Fan findest du noch andere Lösungen zum Thema Lüfter.

Gruß Rainer
 

terra44
Gast





BeitragVerfasst am: 04. Dez 2007 20:03   Titel: Lüfter

Hallo,

hatte gleiches Problem mit dem Lüfter.
Hier meine Lösung:

Trage am Ende der Datei /etc/init.d/boot.local
diese Zeilen ein.

echo -n 0 > /proc/acpi/fan/FN1/state
echo -n 0 > /proc/acpi/fan/FN2/state
sleep 1
echo -n 3 > /proc/acpi/fan/FN1/state
echo -n 3 > /proc/acpi/fan/FN2/state


Nach einem Neustart laufen die Lüfter nur noch bei Bedarf an.

Unter http://www.iaccarino.de/silvio/linuxnb.htm#Fan findest du noch andere Lösungen zum Thema Lüfter.

Gruß Rainer
 

terra44
Gast





BeitragVerfasst am: 04. Dez 2007 20:04   Titel: Lüfter

Hallo,

hatte gleiches Problem mit dem Lüfter.
Hier meine Lösung:

Trage am Ende der Datei /etc/init.d/boot.local
diese Zeilen ein.

echo -n 0 > /proc/acpi/fan/FN1/state
echo -n 0 > /proc/acpi/fan/FN2/state
sleep 1
echo -n 3 > /proc/acpi/fan/FN1/state
echo -n 3 > /proc/acpi/fan/FN2/state


Nach einem Neustart laufen die Lüfter nur noch bei Bedarf an.

Unter http://www.iaccarino.de/silvio/linuxnb.htm#Fan findest du noch andere Lösungen zum Thema Lüfter.

Gruß Rainer
 

Desert



Anmeldungsdatum: 13.06.2007
Beiträge: 8

BeitragVerfasst am: 05. Dez 2007 21:49   Titel: super, besten Dank für die Info

Endlich ist Ruhe. Very Happy Very Happy
Der Lüfter nervte schon sehr!

Hat jetzt noch jemand eine Idee, wie man das Touch-Pad ausschalten kann?

Freundliche Grüße
Desert
 
Benutzer-Profile anzeigen Private Nachricht senden

terra44
Gast





BeitragVerfasst am: 09. Dez 2007 16:29   Titel: Touchpad

Hallo,

wieso willst du das Touchpad ausschalten. Macht das Sinn?

Die einzige Möglichkeit die ich auf die Schnelle gefunden hab ist die.
Einfach über Yast ausschalten.

Yast aufrufen - Hardware - Mausmodelle wählen - unter Maus2 "Diesen Zeiger aktivieren" abklicken. Fertig

Gruß Rainer
 

Desert



Anmeldungsdatum: 13.06.2007
Beiträge: 8

BeitragVerfasst am: 12. Dez 2007 21:11   Titel: Touchpad ein- /ausschalten über Hotkey

Hallo,

ich habe das Notebook oft zu Hause auf dem Tisch stehen und nutze dann über USB eine Maus. Wenn ich nun aus Versehen beim Schreiben mit der Tastatur mit einem Finger auf das Touchpad komme, springt der Cursor in der Zeile. Das ist echt nervig. Aus diesem Grund möchte ich gerne das Touchpad über einen Hotkey an- bzw. ausschalten können. Immer über Yast hin und herschalten ist mir dann doch zu aufwendig. Gibt es nicht noch eine andere Möglichkeit? Confused

Gruß Desert
 
Benutzer-Profile anzeigen Private Nachricht senden

jochen
prolinux-forum-admin


Anmeldungsdatum: 14.01.2000
Beiträge: 699
Wohnort: Jülich

BeitragVerfasst am: 13. Dez 2007 10:25   Titel:

Ja, gibt's.

  • Wenn Dein Touchpad die entsprechende Hardware-Unterstützung hat, kannst Du in der /etc/X11/xorg.conf über
    Code:
    Option "PalmDetect" "On"
    und die weiteren Optionen "PalmMinWidth" und "PalmMinZ" eine Unterdrückung der zufälligen Berührungen einschalten.
  • Schneller und einfacher wäre es aber, wenn Du in der /etc/X11/xorg.conf in der Section zum Synaptics-Touchpad die Zeile
    Code:
    Option "SHMConfig" "On"
    hinzufügst und dann das Programm ksynaptics (KDE) oder gsynaptic (? GNOME - verwende ich selbst nicht, müsste aber das korrekte Programm sein) verwendest. Abgesehen von der einfachen grafischen Konfigurierbarkeit von Speed, Empfindlichkeit usw. des Touchpads kannst Du es auch auf Mausklick hin ein- oder ausschalten. Die Software legt sich als kleines Icon ins Tray und ist damit jederzeit leicht aufzufinden.

Ich hoffe, das hilft weiter.

Jochen
_________________
Die grösste Lüge der EDV? "Mal eben..."
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Desert



Anmeldungsdatum: 13.06.2007
Beiträge: 8

BeitragVerfasst am: 13. Dez 2007 20:31   Titel: Genau das hab ich gesucht

Very Happy Very Happy Besten Dank,
genau das hab ich gesucht. Ich habe die Lösung mit ksynaptic gewählt. Über den Hotkey Strg-Alt-Q kann ich nun das Touchpad an- oder abschalten. Ein Spitzentipp! Vielen Dank Laughing
Desert
 
Benutzer-Profile anzeigen Private Nachricht senden

ulros



Anmeldungsdatum: 14.12.2007
Beiträge: 1

BeitragVerfasst am: 14. Dez 2007 22:56   Titel: Probleme mit dem Sound Amilo La 1703

Hallo!

Erst einmal vielen Dank fuer die tolle Anleitung! Genauso habe ich auch meinen Amilo La 1703 ans Wlan gebracht.

Das Problem ist jetzt noch der Sound. Offensichtlich wird der Treiber installiert, ich kann den Lautstaerkeschieber veraendern wie ich will. Dem Amilo ist jedoch leider kein Ton zu entlocken.

Was kann ich versuchen, um Sound zu haben? Ich habe open Suse 10.3 mit allen Updates installiert.

Eine Sache noch: Der automatische Updater sagt mir staendig das Amarok aktualisiert werden muesse. Nur selbst nach der 5. Aktualisierung ist er nicht zufrieden und will weiter aktualisieren. Gibt es da Abhilfe?

Viele Gruesse an alle
Ulros
 
Benutzer-Profile anzeigen Private Nachricht senden

Stevie
Gast





BeitragVerfasst am: 15. Dez 2007 11:41   Titel:

Hallo Desert!

Also wenn Du das mit dem Sound noch erläutern könntest, das wäre abolut genial Smile
Gibts eigentlich auch eine möglichkeit die Fernbedienung zu nutzen?

Viele Grüße,

Stevie
 

Desert



Anmeldungsdatum: 13.06.2007
Beiträge: 8

BeitragVerfasst am: 30. Dez 2007 11:02   Titel: sound mit XA 1526

Hallo Leute,

habe ich gerade erst gesehen, dass noch Fragen zum Sound sind.
Also folgendermaßen vorgehen:
Mit Alt-F2 und Befehl kdesu kate den Editor öffnen (root-Passwort eingeben).
Dann die Datei /etc/modprobe.h/audio öffnen
Das in der Datei vorhandene löschen.
Dort dann die folgenden drei Zeilen eingeben:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=6stack-dig

Das dann speichern!

Nach Neustart (oder alternativ Alt-F2 -> kdesu konsole -> rcalsasound restart ) müsste der Sound laufen. Evtl. müssten die Regler in KMix noch eingestellt werden (PCM und Front auf ganz hoch stellen). Mit PCM als Hauptregler kann dann die Lautstärke geregelt werden.

Das wars. So müsste es funktionieren. Very Happy Falls nicht, kurze Info

Zur Fernbedienung und auch zu amarok kann ich leider nichts sagen. Confused Tut mir leid.
Für Infos zum Notebook XA-1526 bin ich aber auch immer dankbar!

Viele Grüße
Desert

PS: Ich wünsche allen einen guten Rutsch ins neue Jahr
 
Benutzer-Profile anzeigen Private Nachricht senden

Stevie
Gast





BeitragVerfasst am: 07. Jan 2008 6:59   Titel: Touchpad

hallo desert!

danke dir für deine erläuterung!

ich hab hier noch eine kleine howto, wie man das touchpad mit Fn+F5 ein und ausschalten kann. für das cpu-runtertakten bin ich noch am durchlesen.
ich selbst habe ubuntu 7.10 am laufen.


funktionieren bei dir eigentlich die LEDs für touchpad und throttle?

hier die howto, war ursprünglich die antwort an lars aus dem amilo-forum Smile
falls du noch verbesserungen hast, immer her damit.

hallo lars,

also die lösung für die hotkeys ist etwas komplex.
als erstes solltest du die keycodes von den tasten herausfinden,
die nicht funktionieren. dafür startest du unter "xev" und drückst die entsprechende taste, z.b. Fn+F5. wird in der konsole jetzt kein keycode angezeigt, dann ist die taste noch nicht in linux konfiguriert.
du musst dann folgendes in die konsole eingeben:
Code:
cat /var/log/messages | grep keycode


für meine tastenkombination bekam ich folgende ausgabe:

Code:
atkbd.c: Unknown key released (translated set 2, code 0x65 on isa0060/serio0).
atkbd.c: Use 'setkeycodes 65 <keycode>' to make it known.


die synthax zum zuweisen siehst du oben.

Code:
setkeycodes 65 <keycode>


welche keycodes noch frei zum zuweisen sind findest du mit:
Code:
dumpkeys --keys-only

raus.

die untersten einträge à la "keycode 255 = " sind noch nicht zugewiesen.

daraus folgt:

Code:
setkeycodes 65 255


damit du jetzt einer taste eine funktion (programm) zuweisen kannst,
musst du noch das paket "hotkeys" installieren.

gib jetzt nochmal "xev" in die konsole unter X ein und drücke die gleich taste wie vorhin. jetzt sollte ein code geliefert werden.
diesen schreibst du dir auf.

jetzt erzeugst du die folgende datei: fsc-li2727.def mit folgendem
inhalt:

Code:
<?xml version="1.0"?>
 
<definition>
 
  <config model="Fujitsu-Siemens Amilo LI2727">
    <userdef keycode="139" command="/etc/acpi/fsc-touchpad.sh">Touchpad</userdef>
  </config>
 
  <contributor>
    <name>Assaf Paz</name>
    <email>damagedspline@aim.com</email>
  </contributor>
 
</definition>


für den keycode 139 setzt du den in "xev" herausgefundenen
keycode ein. diese datei kopierst du jetzt mit sudo in /usr/share/hotkeys
wie du siehst wird in dieser datei ein sh-script angesprochen.
dieses script musst du in /etc/acpi kopieren.

hier das touchpad-script "fsc-touchpad.sh"
Code:
 
#!/bin/sh
 
# get the current state of the touchpad
TPSTATUS=`synclient -l | grep TouchpadOff | awk '{print $3}'`
 
# if getting the status failed, exit
test -z $TPSTATUS && exit 1
 
if [ $TPSTATUS = 0 ]; then
  synclient TouchpadOff=1
else
  synclient TouchpadOff=0
fi


das script muss jetzt noch ausführbar gemacht werden:

Code:
chmod a+x "datei"


nach einem neustart sind die einstellungen für setkeycodes nicht mehr aktiv, deswegen müssen sie in die init script eingetragen werden.
dazu erstellst du eine neue datei "fsc-setkeys.sh"

Code:
#!/bin/bash
# zusaetzliche Tastencodes fuer Fujtisu-Siemens XA1526
 
## Touchpad (Fn+F5)
setkeycodes 65 120


auch diese datei wieder ausführbar machen mit sudo chmod a+x fsc-setkeys.sh und nach /etc/init.d/ kopieren.

damit du in jedem init mode das script ausgeführt bekommst, musst du noch einen symbolischen link in alle inits setzen. das machst du mit folgenden befehlen:

sudo ln -s /etc/init.d/fsc-setkeys.sh /etc/rc1.d/S10fsc-setkeys.sh
sudo ln -s /etc/init.d/fsc-setkeys.sh /etc/rc2.d/S10fsc-setkeys.sh
sudo ln -s /etc/init.d/fsc-setkeys.sh /etc/rc3.d/S10fsc-setkeys.sh
sudo ln -s /etc/init.d/fsc-setkeys.sh /etc/rc4.d/S10fsc-setkeys.sh
sudo ln -s /etc/init.d/fsc-setkeys.sh /etc/rc5.d/S10fsc-setkeys.sh
sudo ln -s /etc/init.d/fsc-setkeys.sh /etc/rc6.d/S10fsc-setkeys.sh

jetzt musst du das programm hotkeys noch starten, damit die sh scripte auch zugewiesen werden. das machst du mit folgender datei "hotkeys-desktop" :

Code:
[Desktop Entry]
Version=1.0
Encoding=UTF-8
Name=Hotkeys Manager
Comment=Activate special buttons for FSC Amilo XA1526
Icon=
Exec=hotkeys -Z -t fsc-xa1526 -o off
Terminal=false
Type=Application
Categories=
OnlyShowIn=GNOME;
X-GNOME-Autostart-enabled=true
GenericName[de_DE]=


diese datei kopierst du wieder mit sudo nach /usr/share/gnome/autostart.

nach einem neustart sollte dann alles klappen Smile
 

Stevie
Gast





BeitragVerfasst am: 23. Feb 2008 20:50   Titel: lüfter-code erklärt

zur lüftersteuerung gibts vielleicht noch was zu sagen...
linux erkennt nicht, dass die lüfter bereits laufen und deshalb steht bei uns allen immer:

Code:
cat /proc/acpi/fan/FN1/state
status:                  off


durch den oben geposteten code wird der lüfter an und wieder ausgeschaltet.
jetzt stimmt der status, dass der lüfter aus ist, tatsächlich mit dem zustand des lüfters
überein und die acpi-fan steuerung greift wieder (bei 55° lüfter aus bei knapp 60 wieder an).

das nur zum verständnis Smile


viele grüße,

stevie


p.s. könnte der admin meinen 3fach post löschen?
wusste nicht ob die beiträge durchkamen, da immer ein php-fehler auftrat.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Tips, Tricks, Helferlein Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy