Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Sound mit neuem Mainboard funzt nicht.

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
zwietel



Anmeldungsdatum: 05.12.2007
Beiträge: 4

BeitragVerfasst am: 05. Dez 2007 18:09   Titel: Sound mit neuem Mainboard funzt nicht.

Hi,

Ich hab mir gestern das Asus M2V-MX SE eingebaut, und jetzt habe ich keinen Sound, weder Systemtöne noch Mp3(die Codecs sind installiert). Vieleicht kann mir jemand helfen, schon mal im voraus danke.
 
Benutzer-Profile anzeigen Private Nachricht senden

Albert
Gast





BeitragVerfasst am: 05. Dez 2007 20:17   Titel:

Schaue doch mal im www.alsa-project.org nach,ob deine soundkarte unterstützt wird..
Das wird dir sicher helfen,dann musst du evtl. einen treiber installieren,wenn nicht dann über alsaconf. einstellen.

Du solltest aber auch uns sagen was für eine soundkarte genau du hast und welche Distribution du hast...

Albert
 

zwietel



Anmeldungsdatum: 05.12.2007
Beiträge: 4

BeitragVerfasst am: 06. Dez 2007 3:01   Titel: Sound on Board

Und laut Manual ist das Realtek ALC 662-GR Azalia
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 06. Dez 2007 9:46   Titel:

Der richtige Treiber für diese Karte müsste "snd-hda-intel" sein. Wenn dieser Treiber bereits eingestellt ist -- bitte die Ausgabe von "lsmod" posten -- könnte es noch an einer seltsamen Verdrahtung der Ausgänge des Chips mit den Buchsen des Mainboards liegen. Dreh mal im Mixer *alle* Kanäle auf 100%, und dann machst du
Code:

$ speaker-test -c2


Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

zwietel



Anmeldungsdatum: 05.12.2007
Beiträge: 4

BeitragVerfasst am: 06. Dez 2007 13:04   Titel: lsmod

Module Size Used by
nls_iso8859_1 8192 0
nls_cp437 9856 0
vfat 16128 0
fat 52636 1 vfat
usb_storage 80780 0
ide_core 122948 1 usb_storage
udf 80652 1
xt_tcpudp 7168 2
xt_pkttype 5888 3
ipt_LOG 9984 8
xt_limit 6656 8
snd_pcm_oss 50432 0
snd_mixer_oss 20096 2 snd_pcm_oss
snd_seq 54452 0
snd_seq_device 12172 1 snd_seq
ipt_REJECT 8448 3
xt_state 6528 4
iptable_mangle 6784 0
iptable_nat 11140 0
nf_nat 21912 1 iptable_nat
iptable_filter 6912 1
nf_conntrack_ipv4 14856 6 iptable_nat
nf_conntrack 61684 4 xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
nfnetlink 9752 3 nf_nat,nf_conntrack_ipv4,nf_conntrack
ip_tables 16324 3 iptable_mangle,iptable_nat,iptable_filter
ip6_tables 17476 0
x_tables 18308 9 xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ipt_REJECT,xt_state,iptable_nat,ip_tables,ip6_tables
apparmor 40736 0
fuse 45460 2
loop 21636 0
dm_mod 56880 0
amd64_agp 16004 0
nvidia 6242424 0
k8temp 9600 0
via_agp 13952 1
hwmon 7300 1 k8temp
snd_hda_intel 273180 1
snd_pcm 82564 2 snd_pcm_oss,snd_hda_intel
agpgart 35764 3 amd64_agp,nvidia,via_agp
snd_timer 26756 2 snd_seq,snd_pcm
snd 58164 7 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer
joydev 13632 0
rtc_cmos 12064 0
rtc_core 23048 1 rtc_cmos
rtc_lib 7040 1 rtc_core
i2c_core 27520 1 nvidia
soundcore 11460 2 snd
shpchp 35092 0
usbhid 41300 0
hid 29184 1 usbhid
sr_mod 19492 1
cdrom 37020 1 sr_mod
button 12560 0
parport_pc 40764 0
parport 37832 1 parport_pc
serio_raw 10756 0
pci_hotplug 33216 1 shpchp
snd_page_alloc 14472 2 snd_hda_intel,snd_pcm
ff_memless 9352 1 usbhid
via_rhine 27912 0
mii 9344 1 via_rhine
sg 37036 0
ehci_hcd 34956 0
uhci_hcd 27024 0
sd_mod 31104 6
usbcore 123756 5 usb_storage,usbhid,ehci_hcd,uhci_hcd
edd 12996 0
ext3 131976 2
mbcache 12292 1 ext3
jbd 68148 1 ext3
fan 9220 0
pata_via 15620 5
sata_via 15364 0
libata 137032 2 pata_via,sata_via
scsi_mod 140376 5 usb_storage,sr_mod,sg,sd_mod,libata
thermal 20744 0
processor 40876 1 thermal
 
Benutzer-Profile anzeigen Private Nachricht senden

jochen
prolinux-forum-admin


Anmeldungsdatum: 14.01.2000
Beiträge: 699
Wohnort: Jülich

BeitragVerfasst am: 06. Dez 2007 16:24   Titel:

Hi,

wenn snd-hda-intel der richtige Treiber ist (was ist jetzt mal voraussetze), musst Du ggf. noch das korrekte Model mitgeben. Bei meinem Notebook war der Sound auch schräg, bis ich das korrekte Model gefunden habe - scheinbar scheint die Autoerkennung in dem Bereich nur schlecht zu funktionieren.

Schau mal in folgende Datei unter "Module snd-hda-intel": http://wiki.ubuntuusers.de/_attachments/Soundkarten_installieren%282f%29HDA/ALSA-Configuration.txt

Da Du ein ASUS-Board hast, würde ich mit den Models asus, asus-w1v, asus-dig und asus-dig2 anfangen. Das Durchtesten ist eigentlich ganz einfach:
Code:
modprobe -r snd-hda-intel
modprobe snd-hda-intel mode=asus
Danach mittels alsamix prüfen, dass die Kanäle nicht gemutet sind und mittels aplay versuchen, irgendein *.wav auszugeben. Bei Misserfolg von vorne mit einem anderen Model beim Laden des Moduls.

Wenn Du das korrekte Modul herausgefunden hast, musst Du nur noch die Zeile
Code:
options snd-hda-intel mode=mein-eigener-spezieller-mode
in die /etc/modprobe/soundcard.modprobe einfügen. Dies sollte so bei *ubuntu und SuSE passen - existiert die Datei noch nicht, kannst Du sie einfach neu anlegen. Beim nächsten Laden des Treibers (sprich Reboot) wird die Option dann automatisch gesetzt.

Ich hoffe, das hilft weiter!

Jochen
_________________
Die grösste Lüge der EDV? "Mal eben..."
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

zwietel



Anmeldungsdatum: 05.12.2007
Beiträge: 4

BeitragVerfasst am: 13. Dez 2007 17:10   Titel: Hat geklappt

Danke für die Hilfe und nach etlichen Versuchen endlich geklappt, allerdings über die GUI Yast2.

Vielen Dank

Carsten
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy