Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Nov 2018 4:44

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 10 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: WLAN Treiber
BeitragVerfasst: 06. Dez 2007 11:21 
Offline

Registriert: 09. Sep 2004 15:00
Beiträge: 176
Hallo,
ich hab OpenSuse10.2 auf meinem Notebook installiert, bekomme aber leider meine WLAN -PCMCIA -Karte (D-Link DWL-G630) nicht zum laufen. Es gibt offensichtlich kein rpm-Treiber-Paket.
Gibt es eine Liste mit unterstützter Hardware? Ich hab bei OpenSuse nichts gefunden.
Kann mir jemand eine gute Karte nennen, die sich unter OpenSuse 10.2 oder 10.3 problemlos installieren läst?
Danke.
ottto


Nach oben
   
 Betreff des Beitrags: wlan
BeitragVerfasst: 08. Dez 2007 11:07 
Hallo,

die Unterstützung der Hardware richtet sich logischerweise nach dem verbauten Chipsatz.
Es gibt seitens der Industrie keine gewär, dass Geräte einer bestimmten Bezeichnung einen identischen Chip beinhalten.
Firmen, die den Chisatz angeben, gibts es selten (z.B. www.Allnetde).

Prinzipiell gilt als Faustregel: Chipsätze Orinoco, Prism und Atheros werden hackermässig gut unterstützt. Intel läuft gut und viele von Realtek, aironet, usw.

http://en.opensuse.org/HCL/Network_Adap ... ireless%29

Was nicht generisch funktioniert, kann meistes mit der methode vom "NDiswrapper" zum laufen gebracht werden.
Hier kann es aber unter bestimmten konstellationen von Betriebssystem, NDiswrapper-Version und Kartentreiber zu Unstabilitäten kommen - muss es aber nicht.
http://de.opensuse.org/SDB:Ndiswrapper


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08. Dez 2007 15:02 
Offline

Registriert: 09. Sep 2004 15:00
Beiträge: 176
Hallo sumsi,
vielen Dank für die Info.
Ich hab schon mal mit ndiswrapper versucht, meine D-Linkkarte zum laufen zu bekommen. Bischen weiter bin ich schon bekommen. Der WinTreiber lies sich installieren.

moskau:~ # ndiswrapper -l
installed drivers:
netrt61g driver installed, hardware (1814:0302) present (alternate driver: rt61pci)

modprobe ndiswrapper bringt keine Fehler

nach ifconfig wlan0 down/up bekomme ich auf dmesg :
...
sd 1:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete
usb 1-2: USB disconnect, address 3
ADDRCONF(NETDEV_UP): wlan0: link is not ready

mir ist aufgefallen ,dass obwohl ich im yast den entsprechenden Netzwerknamen eingetragen hab, bringt mir iwconfig bei ESSID "default".

moskau:/ # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"default"
Mode:Auto Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:20 dBm Sensitivity=-121 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

moskau:/ #
Warum ist meine Karte "not ready"? War das nicht der richtige Wintreiber?
Vielleicht kann mir nochmal jemand eine Tipp geben, wie ich hier weiterkomme?
Danke.
ottto


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08. Dez 2007 15:08 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Treiber für ralink-Karten gibt es hier. Zugegeben, nicht als rpm-Paket, Du mußt schon selber kompilieren, was aber machbar ist.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08. Dez 2007 21:58 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
In Kernel 2.6.24 sind die Treiber für die ralink-Karten bereits drin. Ist evtl. einfacher als selbst zu patchen.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08. Dez 2007 22:11 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Stimmt die wurden ja aufgenommen. Sehr praktisch, das spart Arbeit.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Dez 2007 21:49 
Offline

Registriert: 09. Sep 2004 15:00
Beiträge: 176
sorry,
ich steh hier leider völlig im Wald, wie muss ich die enthaltenen Treiber patchen?
Könnt Ihr mir sagen, wo ich eine Anleitung/Beispiel finde?
Danke.
ottto


Nach oben
   
 Betreff des Beitrags: treiber
BeitragVerfasst: 10. Dez 2007 10:32 
Moin,

also
1. Du benötigst Deine Kernel-Sourcen
2. Paket auspacken und die README lesen. da steht dann der Befehl zum Patchen drin, wie z.B. Aufruf von make oder einem Install-Script ... (als root)

Viel Erfolg
sumsi


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 10. Dez 2007 16:19 
Offline

Registriert: 09. Sep 2004 15:00
Beiträge: 176
Hallo sumsi,
im yast hab ich gesehen das die Kernel-Sourcen installiert sind. Aber wo finde ich die jetzt und welches ist das richtige Paket.
Sorry, das ich mich so blöd anstelle, ich hab aber mit diesen Geschichten noch nie was gemacht. Irgendwie fehlt mir hier der Faden.
Danke.
ottto


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 16. Dez 2007 9:00 
Offline
Benutzeravatar

Registriert: 06. Mai 2006 19:58
Beiträge: 252
Zitat:
wie muss ich die enthaltenen Treiber patchen?
Unter SuSE10.3 braucht man nur das Paket rt2x00-kmp-default (Kernelmodule für ralink-Karten) zu installieren.

Viele Grüße
Frank


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 10 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de