Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
speedstep bei coppermine

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
exc128user
Gast





BeitragVerfasst am: 08. Dez 2007 11:10   Titel: speedstep bei coppermine

hallo

ich habe ein IBM ThinkPad mit einem Intel PIII Coppermine mit speedstep.
Als Distri habe ich Suse 10.3 installiert.
Die Installation lief reibungslos bis auf die speedstep unterstützung.
Bis jetzt habe ich herrausgefunden, das dies ein problem mit dem modul cpufreq zu sein scheint. Nach den fehlermeldungen zu urteilen, versucht das Modul cpufreq mit Powernow von AMD an die Sache ran zu gehen, was natürlich bei einem IBM mit speedstep nicht funktionieren kann.
Es hat den Anschein, als ob Suse 10.3 hier die Module durcheinander bringt.

Bin für Anregungen und Hilfe in dieser Sache dankbar


mfg


Ralf
 

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 28. Dez 2007 23:02   Titel:

Zitat:
mit dem modul cpufreq
Nachfrage: "modul cpufreq" oder "Paket cpufreqd"?

Welchen chipsatz hat Dein thinkpad? i440*?
Versuche mal das Modul *speedstep-smi.

Zitat:
das Modul cpufreq mit Powernow von AMD
"Paket cpufreqd"(?) hat vielleicht in seiner Konf-Datei diese Standard-Einstellung.
Gehe mal nach 'init 1' (damit eventuelle CPUfreq-Dämonen gestoppt werden), entlade die cpufreq-Module und versuche mit 'modprobe' das passende zu laden. Im Erfolgsfall sollte sich /sys/devices/system/cpu/cpu0/cpufreq/ aufbauen.
(In /lib/modules/$kenelversion/ befinden sich zwei cpufreq-Verzeichnisse, eins für die cpufreq-Module und eins für die Governor (Regler).)
_________________
mfg komsomolze
 
Benutzer-Profile anzeigen Private Nachricht senden

exc128user
Gast





BeitragVerfasst am: 31. Dez 2007 22:17   Titel: speedstep bei coppermine

hallo

ich habe die cpufreq utils per yast instaliert und mit modprobe -r speedstep.lib /speedstep.smi die module entladen und dann mit modprobe sie wieder geladen
jetzt steht speedstep zur verfügung mit 900 und 700 mhz.
allerdings nur zur laufzeit.
wie mache ich es, das die module auch beim systemstart zur verfügung stehen?

ralf

ps: einen guten rutsch und ein frohes neues jahr
 

exc128user
Gast





BeitragVerfasst am: 31. Dez 2007 22:19   Titel: speedstep bei coppermine

hallo

ich habe die cpufreq utils per yast instaliert und mit modprobe -r speedstep.lib /speedstep.smi die module entladen und dann mit modprobe sie wieder geladen
jetzt steht speedstep zur verfügung mit 900 und 700 mhz.
allerdings nur zur laufzeit.
wie mache ich es, das die module auch beim systemstart zur verfügung stehen?

ralf

ps: einen guten rutsch und ein frohes neues jahr
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 01. Jan 2008 19:46   Titel:

Du kannst diesen Befehl beispielsweise in /etc/init.d/boot.local eintragen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

stolli83



Anmeldungsdatum: 11.01.2008
Beiträge: 1

BeitragVerfasst am: 11. Jan 2008 21:08   Titel:

hi ich habe beim wiederladen des speedstep-smi moduls folgede fehlereldung

Code:
ibm:~ # modprobe speedstep-smi
FATAL: Error inserting speedstep_smi (/lib/modules/2.6.22.13-0.3-default/kernel/arch/i386/kernel/cpu/cpufreq/speedstep-smi.ko): No such device


vielleicht weiß daja von euch jemand rat!!!
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 14. Jan 2008 13:40   Titel:

Erst "dmesg -c" um den Puffer zu löschen. Dann nochmal versuchen, das Modul zu laden. Dann nochmal "dmesg -c", und *dieses* Ergebnis posten.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy