Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Mounten von verschlüsselter Partition

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Echter27
Gast





BeitragVerfasst am: 27. Jan 2008 9:57   Titel: Mounten von verschlüsselter Partition

Hallo,
bin nicht ganz sicher ob das die richtige Kategorie ist, aber ich schildere mein Problem mal:
Ich habe eine Partition auf der Platte verschlüsselt angelegt mit cryptoloop und aes.
Das Prblem ist nun, daß ich nicht sicher bin, ob ich nur das Passwort nicht mehr weiß, oder ob die Partition beschädigt ist, bzw ob noch irgendwelche Module fehlen.
Ich lade von hand immer:
modprobe cryptoloop
modprobe aes

Wenn ich dann die Partition mounten will kommt folgender Fehler:
[root@Linuxrechner ~]# mount /mnt/Daten
Passwort:
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Das was dann im log steht ist nicht aussagekräftig:

VFS: Can't find ext3 filesystem on dev loop0.

Ach ja in der fstab steht:
/dev/hda1 /mnt/Daten ext3 loop,user,noauto,encrypted,encryption=AES256 0 0
Das sollte eigentlich so passen da hab ich nichts dran geändert.


Habe auch schon mit fsck versucht zu reparieren, er macht dann auch was, aber ich bin nicht sicher, ob nun vielleicht die Daten unwiederbringlich weg sind.
Was kann ich nun machen, wie kann ich rausfinden, ob ich nur zu doof bin das richtige PW einzugeben, (vergessen wäre möglich da ich das ding 1-2x im Jahr nur brauche) oder ob halt irgendwas sonst nicht stimmt.

Für irgendwelche Hilfe wäre ich sehr dankbar!

Gruß
Michael
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 27. Jan 2008 15:38   Titel:

Also das mit dem fsck halte ich für keine gute Idee. Andererseits sollte es nicht starten, wenn kein Dateisystem drauf ist.

Benutzt Du KDE? Dann kannst Du in der Konsole Dein Passwort eingeben, so daß Du es als Klartext siehst (solltest natürlich alleine dazu sein :). Dann kannst Du es mit der Maus markieren, kopieren und dann wieder einfügen, wenn losetup nach dem Passwort fragt. Du wirst es dabei wie gewohnt nicht angezeigt bekommen, kannst Dir aber trotzdem sicher sein, daß Du richtig getippt hast.

Als Anmerkung, cryptoloop hat einige Schwachstellen und sollte nicht mehr benutzt werden. Nimm lieber dmcrypt zusammen mit cryptsetup und luks.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy