Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme nach openSuse 10.3 Installation

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Umstieg auf Linux
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Goffrey
Gast





BeitragVerfasst am: 30. Jan 2008 10:29   Titel: Probleme nach openSuse 10.3 Installation

Zwecks umstieg von Windows habe ich openSuse Ver. 10.3 installiert.
Die Installation verlief problemlos bis zum ersten Systemstart.
Hier bekomme ich die Anzeige:

"Searching for Boot Record from IDE-0..OK"
"GRUB Loading stage1.5"

"GRUB loading, please wait..."
"Error 18"
_


Jetzt hängt das System und nichts geht mehr...

Wer kann mir helfen ???

Mit der Live CD " Knoppix " startet der PC einwandfrei.

Im voraus besten Dank

Goffrey
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 30. Jan 2008 13:31   Titel:

Wie alt ist der Rechner?
http://wiki.linuxquestions.org/wiki/GRUB#Error_18

Grub benutzt das BIOS, um den Linux-Kernel zu laden. Das BIOS deines (alten?) Rechners kann aber nur maximal 1024 Zylinder ansprechen und der Linux-Kernel liegt wohl hinter dieser Grenze auf der Platte. Evtl. hast du auf derselben Platte vor dem Linux-Bereich noch ein MS-Windows-Dateisystem?

Du kannst dieses Problem umgehen, indem du von Hand partitionierst und eine /boot-Partition anlegst, die komplett unterhalb der 1024-Zylinder-Grenze liegt. Diese Partition muss nur 32MB groß sein, das reicht. Den Bereich dahinter kannst du frei belegen, zumindest eine /-Partition brauchst du aber noch. SuSEs Installationswerkzeug bietet ein Partitionierwerkzeug an.

Du brauchst übrigens nicht tausend verschiedene Linux-Distributionen auszuprobieren, dieses Problem hängt mit deinem Rechner zusammen und wird immer auftreten.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Goffrey II
Gast





BeitragVerfasst am: 30. Jan 2008 16:45   Titel: Umstieg auf Linux

Danke Janka,

dann scheint die Sache ja nicht hoffnungslos zu sein.

Ja stimmt, mein Rechner ist ein ziemlich alter AMD PC 1GHz, 1 HDD 40GB, 1HDD 190GB
Auf der ersten Festplatte C (40GB) ist Win XP installiert.
Die zweite Festplatte hat 2 Partitionen D=Win XP (58GB) / E=Backup (70GB) und
einen unpartitionierten Bereich von ~ (58GB).
Wenn ich das richtig sehe hat sich hier Linux eingerichtet ?

Ich habe die Linux Installation noch einmal gestartet und bin dann bei Festplatte vorbereiten in den Experten-Modus gewechselt.
Hier habe ich dann folgende Info's gesammelt:

dev/sda___38,3GB
dev/sda1__38,3GB____HTFS/NTFS_________/windows/C
dev/sdb__186,3GB
dev/sdb1__58,3GB____HTFS/NTFS_________/windows/D XP
dev/sdb2__69,4GB____HTFS/NTFS_________/windows/E Backup
dev/sdb3__58,3GB____Extended
dev/sdb5_619,0MB____Linux swap_________swap_____16709-16787 =78Zylinder
dev/sdb6__20,0GB____Linux native__________________16788-19398=2610
dev/sdb7__15,0GB_F__Linux native (ext3)___/__________19399-21367=1968
dev/sdb8__22,6GB_F__Linux native (ext3)___/home_____21368-24320=2952

Da ich keine Ahnung habe muß ich leider noch mal nachfragen.
Welche Partition muß ich ändern ?

Danke für Eure Unterstützung
 

sumsi
Gast





BeitragVerfasst am: 30. Jan 2008 17:42   Titel: 1024

Moin,

der Linux-Kernel bfindet sich unter /boot.
Da Du dem /boot-Verzeichnis keine extra Partition gewidmet hast, liegt /boot-Partition auf der Wurzel-Partition /.

Du musst dafür sorgen, dass der Kernel auf der Platte unterhalb der 1024-Zylinder liegt.

Mein Vorschlag wäre, die Windows-D-Pfaden müßten dann aber nachgebessert werden, dem /dev/sdb1 30 MB für die Partition /boot abzuzweigen. Dann würden sich alle Partionen um eine Nummer höher verschieben, was Du dann in der /etc/fstab nachbessern musst.

Ist Dir das zu kompliziert, sorge jedenfalls dafür dass am Anfang einer Festplatte (sda1, sdb1, ..) die /- oder /boot-Partionion zu finden ist und installiere Linux neu ..

Viel Spaß
sumsi
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 30. Jan 2008 20:54   Titel:

Hmm. Sooo alt ist der Rechner dann nicht. Evtl. ist das Problem gar nicht die 1023-Zylinder-Grenze, sondern die 128GB-Grenze, die ein wenig moderne BIOS-Versionen noch haben. In dem Fall kann man *gar nicht* von einer Platte mit >128GB booten.

In dem Fall empfehle ich dir, nach einer neuen BIOS-Version für dein Board zu schauen, oder auf der 40GB-Platte Platz zu schaffen. Hinter der 1024-Zylinder-Grenze sollte bei deinem Rechner auch klappen (Ich hab' hier auch keine neueren, und da geht es überall!), nur eben nicht auf einer Platte >128GB.

Also verkleinere das Dateisystem C: auf /dev/sda1 (vorher Backup machen!) um 32MB und knall dahinter im SuSE-Partitionierwerkzeug eine Partition /dev/sdb2 für /boot
Nicht vergessen, den Kernel und die Bootloader_infos über Installation->Reparatur auch in diese Partition zu Installieren.

/dev/sdb7 und /dev/sdb8 aus deinem Listing scheinen übrigens nur Vorschläge aus dem *zweiten* Partitionierversuch zu sein, deswegen das "F"-Flag (für formatieren). SuSE ist ja bereits auf /dev/sdb5 und /dev/sdb6 installiert. Die können also weg. Du kannst dir aber tatsächlich überlegen, *später* dem /home-Baum auch eine eigene Partition zu spendieren. Das macht einen späteren Distributionswechsel einfacher.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Goffrey III
Gast





BeitragVerfasst am: 30. Jan 2008 22:42   Titel:

Yabbadabaduhh !!!!!

hat gefunzt, ich habe Linux auf die 40GB Platte installiert und sieht gut aus.

Jetzt hab ich ein neues problem(chen). Wink
Nee sorry sind eigentlich zwei

1 Wenn ich im bootmanager Windows starten möchte oder om BIOS die Startreihenfolge IDE1 / IDE0 ändere geht gar nix. Mein XP ist +++ TOT +++

2 Mit diesem PC war ich mit einem WLAN USB Stick online.....ok dafür gobts keinen Treiber
aber for den AVM FRTITZ!WLAN USB Stick gibts einen Treiber für Linux.
Hat den schon jemand im Einsatz ???

Goffrey
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 30. Jan 2008 23:33   Titel:

Goffrey III hat folgendes geschrieben::
Yabbadabaduhh !!!!!
hat gefunzt, ich habe Linux auf die 40GB Platte installiert und sieht gut aus.

Fein!

Zitat:

1 Wenn ich im bootmanager Windows starten möchte oder om BIOS die Startreihenfolge IDE1 / IDE0 ändere geht gar nix. Mein XP ist +++ TOT +++

Hmmm. Was genau hast du gemacht? Wie sieht jetzt die Partionierung aus? Mach mal in einer Konsole
Code:

/sbin/fdisk -l /dev/sda /dev/sdb
mount

um uns einen Überblick über die Partitionierung und die Dateisysteme zu geben.

Zitat:

2 Mit diesem PC war ich mit einem WLAN USB Stick online.....ok dafür gobts keinen Treiber
aber for den AVM FRTITZ!WLAN USB Stick gibts einen Treiber für Linux.

Die Sticks haben teilweise trotz gleichen Namens Unterschiedliche Chipsätze drinnen. Mach mal in einer Konsole
Code:

lsusb

um die Device-ID herauszufinden.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Umstieg auf Linux Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy