Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
gelöst - Nach Monitorwechsel: "failed to inititalize core devices"

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
grille



Anmeldungsdatum: 21.08.1999
Beiträge: 58

BeitragVerfasst am: 21. März 2008 18:36   Titel: gelöst - Nach Monitorwechsel: "failed to inititalize core devices"

Hi
Neuen Monitor erstanden, beim herumprobieren mit YAST in den Einstellungen plötzlich Systemabsturz, mit Console /reboot behoben, aber keine grafische Oberfläche mehr. Aufruf von startx ergibt die Fehlermeldung (abgetippt - Tippfehler)
Zitat:

hans@desktop:~>startx
xauth: creating new authority file /home/han/.serverauth.15952


X Window
...
unnötiges gekürzt
...
(II) Module already built-in
(EE) PreInit returned NULL for "Mouse(1)"
The XKEYBOARD keymap compiler (xkbcomp) reports:
>Warning Type "ONE LEVEL"has 1 levels, but RALT has 2 symbols
> ignoring extra symbols
Errors form xkbcomp are not fatal to the X server
no core pointer

Fatal server error:
failed to inititalize core devices
giving up
xinit: Connection reset by peer (errnno 104): unable to connect to x server
xinit: No such process (errno 3): Server error.
hans@desktop:~>

Wie unschwer zu erkennen und auch im Netz zu finden ist, hat die Maus "einen Patschen". Es handelt sich um eine Logitech Maus, die an der runden Buchse (PS2?) über der Tatstatur angesteckt wurde. Bisher war da eine "Intelli/wheel mouse (Aux-port) ausgewählt und eingestellt und lief Jahrelang perfekt.
Folgende Lösungsansätze bisher:
yast2 als root im Textmodus; Hardware - Mouse modell ist noch immer die Intelli Mouse eingetragen. Versuchsweise auf "Intelli Mouse Explorer (ps2)" umgestellt - Neustart - Spannung - Frust - gleiche Fehlermeldung. Zurückgestellt.
Nachlesen in /etc/X11/xorg.conf
Zitat:
# /.../
#SaX generated X11 config file
...
gekürzt
...
section "Input device"
Driver "kbd"
...
gekürzt
...
EndSection

section "InputDevice"
Driver "evdev"
Identifier "Mouse[1]"
Option "Buttons" "20"
Option "InputFashon" "Mouse"
Option "Name" "Logitech Bluetooth Mouse"
Option "Protocoll" "Event"
Option "SendCoreEvents" "on"
Option "Vendor" " Sysp"
Option "ZAxisMapping" "4 5"
EndSection
...
rest gekürzt

Wie kommt trotz meiner Einstellversuche Xorg.conf zur Behauptung, hier sei eine Bluetooth Mouse angeschlossen?
Andere Mäuse selbstverständlich auch schon probiert, allerdings alle am runden Anschluss. Die "böse" Maus arbeitet gerade problemlos am Ersatz-PC
Hauptfrage: Wie fasse ich das weiter an?
Gruß und *zirp*
GriLLe
--
Vile Menschen sind zu gut erzogen, um mit vollem Mund zu sprechen; aber sie haben keine Bedenken, dies mit leerem Kopf zu tun.


Zuletzt bearbeitet von grille am 23. März 2008 13:52, insgesamt 2-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

grilleh
Gast





BeitragVerfasst am: 22. März 2008 12:04   Titel: am Weg der Beserung:

Hi
In der Nacht fiel es mir wie Schuppen von den Haaren Wink Die Datei /etcX11/xorg.config.install untersuchen. Der offensichtlich große unterschied dürfte die fehlende Zeile
Zitat:
Options "Device" "/dev/input/mice"
sein.
Jedenfalls läuft's jetzt wieder soweit, dass ich SAX benutzen kann.
Danke Jenen, die sich in der Zwischenzeit schon Gedanken gemacht haben.
Gestern Abend habe ich noch rasch meinen Zugang zu pro-linux geschrottet, indem ich meine emailadresse richtig gestellt habe. Nach absenden kam eine Fehlermeldung, sinngemäß wie "Absolut unbekannter Fehler, das Script weiß auch nicht weiter". Seither kann ich mich nicht mehr einloggen. (Fehlermeldung: "Sie haben einen ungültigen Benutzernamen eingegeben"). Jetzt ist mein originlae Benutzernamen "belegt" und ungültug gleichzeitig. Mal eine mail schreiben, damit hjb mich nach Ostern "richtigstellt".
Gruß und *zirp*
GriLLe
--
Sollte hier jemand sein, den ich vergessen habe zu beleidigen, dann entschuldige ich mich zutiefst!
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy