komme mit wget nicht übern proxy

Antworten
Nachricht
Autor
sumsi

komme mit wget nicht übern proxy

#1 Beitrag von sumsi » 10. Apr 2008 20:44

Hallo,

ich versuche verzweifelt mit wget (oder auch anderen Tools) zwecks autom. Download den Proxy zu überwinden.

Manuell mit Firefox gehts, Proxy eintragen, Name u. Passwort abnicken und drüber...

Mache ich

Code: Alles auswählen

wget  --proxy-user="USERNAME" --proxy-password="PASSWORT" HTTP_PROXY="12.34.56.78:8085/"  URL
so kommt

Code: Alles auswählen

--21:33:27--  http://http_proxy=12.34.56.78:8085/
           => `http_proxy=12.34.56.78:8085/index.html'
Verbindungsaufbau zu 12.34.56.78:8085... verbunden.
Proxy Anforderung gesendet, warte auf Antwort... 407 Proxy Authentication Required ( Der ISA Server erfordert Autorisierung, um die Anfrage durchf\374hren zu k\366nnen. Der Zugriff auf den Webproxydienst wird verweigert.  )
21:33:27 FEHLER 407: Proxy Authentication Required ( Der ISA Server erfordert Autorisierung, um die Anfrage durchf\374hren zu k\366nnen. Der Zugriff auf den Webproxydienst wird verweigert.  )BEENDET --21:33:27--
Geholt: 0 Bytes in 0 Dateien

Die /etc/wgetrc habe ich schon auskommentiert oder damit gespielt.

Jemand eine gute Idee?
Oder ein anderes Tool, was auch von https laden kann? (Habe Aria schon probiert)

Gute Nacht
sumsi

Benutzeravatar
hjb
Pro-Linux
Beiträge: 3252
Registriert: 15. Aug 1999 16:59
Wohnort: Bruchsal
Kontaktdaten:

#2 Beitrag von hjb » 11. Apr 2008 12:36

Hi!

wget kann keine NTLM-Authentifizierung (fuck diese MS-Scheiße). Siehe dazu meinen Kurztipp http://www.pro-linux.de/news/2008/12309.html

Grüße,
hjb
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?

susmi

cntim

#3 Beitrag von susmi » 12. Apr 2008 10:25

Hallo hjb,

danke für den Tipp ;-)
Auf sowas muss man erstmal kommen ....

Das werde ich in der kommenden Woche ausprobieren.

LD
sumsi

sumsi

nachtrag

#4 Beitrag von sumsi » 12. Apr 2008 11:45

Laut "Internet" soll cURL auch dieses Protokoll beherrschen.

Es war auch eines der Testkanditaten, da ich aber von "NTLM" noch nichts wusste, hatte ich auch die Option"--proxy-ntlm" nicht probiert.
Die Grundlagen für NTLM liegen übrigens bei OS/2

F*ck M*oft, die sollten mal etwas eigenes und gemeinnütziges produzieren ...

Benutzeravatar
hjb
Pro-Linux
Beiträge: 3252
Registriert: 15. Aug 1999 16:59
Wohnort: Bruchsal
Kontaktdaten:

#5 Beitrag von hjb » 12. Apr 2008 22:51

Hallo,

curl kenne ich nicht gut genug, um dazu was zu sagen. Die meisten Konsolenprogramme (einschl. apt-get, w3m u.a.) können mit NTLM aber nicht umgehen.

Grüße,
hjb
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?

susmi

ergänzung

#6 Beitrag von susmi » 13. Apr 2008 11:11


sumsi

gracias

#7 Beitrag von sumsi » 14. Apr 2008 17:34

Schönen Abend,

vielen dank nochmal für den Tip http://www.pro-linux.de/news/2008/12309.html .

Geht super ;-) RPM (naja, Susi-Firmenserver), runterladen, installieren, Startscript anwerfen, .wgetrc definieren:

Code: Alles auswählen

http_proxy = http://x.x.x.x::8085/
ftp_proxy = http://x.x.x.x:8085/
no_proxy = 127.0.0.1, localhost, 10., 
proxy_user = mein-windoof-account
proxy_passwd = windoof-passwort
user = account beim Empfänger (nu.novell.com)
password = XXXXX

# If you do not want to use proxy at all, set this to off.
use_proxy = on
recursive = on
und dann

Code: Alles auswählen

user@SLES-Verteiler:~> wget 'https://nu.novell.com/repo/$RCE/SLES10-SP1-Updates/sles-10-i586/rpm/i586/clamav-0.91-3.1.i586.rpm'
--18:30:27--  https://nu.novell.com/repo/$RCE/SLES10-SP1-Updates/sles-10-i586/rpm/i586/clamav-0.91-3.1.i586.rpm
           => `nu.novell.com/repo/$RCE/SLES10-SP1-Updates/sles-10-i586/rpm/i586/clamav-0.91-3.1.i586.rpm'
Verbindungsaufbau zu 10.23.25.10:8085... verbunden.
Proxy Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 1.075.759 (1.0M) [application/x-rpm]

100%[=================================================================================================>] 1.075.759      1.97M/s

18:30:28 (1.96 MB/s) - »nu.novell.com/repo/$RCE/SLES10-SP1-Updates/sles-10-i586/rpm/i586/clamav-0.91-3.1.i586.rpm« gespeichert [1075759/1075759]
yiiipie yäh

bye
sumsi

Antworten