Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Frage zu expresskeys ( expresskeys ERROR: Tablet not attached )

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Triple666Blood



Anmeldungsdatum: 02.11.2005
Beiträge: 25

BeitragVerfasst am: 22. Apr 2008 15:45   Titel: Frage zu expresskeys ( expresskeys ERROR: Tablet not attached )

hi,

habe mir ein Grafiktablett "Wacom Bamboo" gekauft. Habe den linuxwacom treiber auch ohne Probleme installieren können. Wollte jetzt mit expressekeys die Sondertasten für zoomen auf dem Tablett ansteuern. Wenn ich nun aber expresskeys start, bekomme ich folgende Meldung :

[robert@Bluehal ~]$ expresskeys -d
expresskeys ERROR: Tablet not attached, OR (in case of Cintiq 21UX, Intuos3
and Graphire4) the 'pad' device has not been specified in xorg.conf, OR is
lacking on the command line when using "named devices".

[robert@Bluehal ~]$ expresskeys pad
expresskeys ERROR: User named device "pad" not found!

Doch habe ich in meiner xorg.conf eigenlich alles richtig eingerichtet:
( Auszug)
Auch die Xorg.log scheint die wacom Treiber richtig zu laden ( xorg.log weiter unten ) Aber wieso erkennt expresskeys das Tablett nicht.

Vielleicht hat ja jemand einen Tip für mich.

Danke

Gruß T6B

-------------------------------------------------------------------------------------------------------------------------


Section "ServerLayout"

# The Identifier line must be present
# Screen "Screen1" rightof "Screen0"
Identifier "Simple Layout"
Screen "Screen0" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "pad"
InputDevice "stylus" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
.
.
.
.
.
EndSection
Section "Module"
.
.
.
Load "wacom"
.
.
.
EndSection

Section "Input Device"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "USB" "on"
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "USB" "on"
EndSection

Section "InputDevice"
Identifier "pad"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "pad"
Option "USB" "on"
EndSection

------------------------------------------------------------------------------------------------------------------------

und laut xorg.log scheint die xorg.conf auch alles zu laden:

-------------------------------------------------------------------------------------------------------------------------


This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.4.0.90
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-ARCH i686
Current Operating System: Linux Bluehal 2.6.24-ARCH #1 SMP PREEMPT Sun Mar 30 11:40:06 CEST 2008 i686
Build Date: 23 March 2008 11:53:09AM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 22 13:27:52 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "nvidia0"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) |-->Input Device "pad"
(**) |-->Input Device "stylus"
(**) |-->Input Device "eraser"
(==) Automatically adding devices
(==) Automatically enabling devices
*
*
*
*
*
(**) pad: always reports core events
(**) pad device is /dev/input/wacom
(**) pad is in relative mode
(**) WACOM: suppress value is 2
(**) Option "USB" "on"
(**) pad: reading USB link
(**) Option "BaudRate" "9600"
(**) Option "SendCoreEvents"
(**) stylus: always reports core events
(**) stylus device is /dev/input/wacom
(**) stylus is in absolute mode
(**) WACOM: suppress value is 2
(**) Option "USB" "on"
(**) stylus: reading USB link
(**) Option "BaudRate" "9600"
(**) Option "SendCoreEvents"
(**) eraser: always reports core events
(**) eraser device is /dev/input/wacom
(**) eraser is in absolute mode
(**) WACOM: suppress value is 2
(**) Option "USB" "on"
(**) eraser: reading USB link
(**) Option "BaudRate" "9600"
(II) evaluating device (eraser)
(II) XINPUT: Adding extended input device "eraser" (type: Wacom Eraser)
(II) evaluating device (stylus)
(II) XINPUT: Adding extended input device "stylus" (type: Wacom Stylus)
(II) evaluating device (pad)
(II) XINPUT: Adding extended input device "pad" (type: Wacom Pad)
(II) evaluating device (Keyboard1)
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) evaluating device (Mouse1)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(**) Option "Device" "/dev/input/wacom"
eraser Wacom X driver grabbed event device
(==) Wacom using pressure threshold of 30 for button 1
(==) Wacom USB Bamboo tablet speed=9600 maxX=14760 maxY=9225 maxZ=511 resX=2540 resY=2540 tilt=enabled
(==) Wacom device "eraser" top X=0 top Y=0 bottom X=14760 bottom Y=9225 resol X=2540 resol Y=2540
(==) Wacom device "stylus" top X=0 top Y=0 bottom X=14760 bottom Y=9225 resol X=2540 resol Y=2540
(==) Wacom device "pad" top X=0 top Y=0 bottom X=14760 bottom Y=9225 resol X=2540 resol Y=2540
(II) Mouse1: ps2EnableDataReporting: succeeded
SetClientVersion: 0 9
Error reading wacom device : Invalid argument
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy