Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
LVM nicht erkannt in initrd

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 07. Mai 2008 14:27   Titel: LVM nicht erkannt in initrd

Hi!

Ich will Kernel 2.6.23.12 durch 2.6.25.1 ersetzen. Die Konfiguration ist geringfügig anders, aber im entscheidenden Bereich - Device Mapper und SATA - dieselbe.

Habe eine initrd angelegt und versuche nun zu booten. Es gibt keine offensichtlichen Unterschiede in den initrds für die beiden Kernelversionen.

Kernel 2.6.25.1 sagt nun: "Volume Group vg0 not found" und bleibt in Busybox stehen. In der Initrd wird vgchange zum Aktivieren der VGs eingesetzt. Die DM-Module sind geladen. Trotzdem sagt vgchange auch bei manuellem Aufruf, dass es keine VGs findet. Die SATA-Platten wurden aber gefunden.

Ich stehe total auf dem Schlauch und meine Gedanken drehen sich im Kreis. Habe ich was vergessen oder hat der Kernel ein Problem? Auf der initrd sind kaum Diagnosetools, die könnte ich aber problemlos hinzufügen.

Danke,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 08. Mai 2008 10:36   Titel:

Hi!

Dann führe ich halt Selbstgespräche. Die Ursache könnte damit zusammenhängen:

http://lkml.org/lkml/2007/6/12/149

Ein Test steht allerdings noch aus, da ich die initrd neu konstruieren muss.

Grüße,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

sumsi
Gast





BeitragVerfasst am: 05. Jun 2008 13:17   Titel: gehts wieder ?

Hallo hjb,

was ist nun graus geworden? hast Du Dir eine separate /boot-Partition gegönnt?

Smile

Grüße
sumsi
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 06. Jun 2008 11:11   Titel:

Hi!

Die Lösung war, die LVM-Tools zu aktualisieren. Die Version in Debian Etch ist zu alt für Kernel 2.6.25.

Etch wurde mit Kernel 2.6.18 ausgeliefert, da ist jedes Update ein gewisses Risiko.

Grüße,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy