Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
auf Treiberjagt für ne Xircom
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 20. Mai 2008 14:12   Titel: auf Treiberjagt für ne Xircom

Hallo Leuts,

nachdem ich nun nach einer Woche Überredungskunst zum errsten mal erfolgreich Linux installiert habe, kommen gleich die nächsten Probs hoch. Und zwar wird meine "XirCom Cardbus Ethernet 10/100+Modem 56" nicht erkannt.
Ich habe Kubuntu 8.04 drauf und suche nun verzweifelt im Netz nach Treibern. Aber so ne richtig gute Quelle habe ich noch nicht gefunden. Nur nen haufen Seiten die damit werben unterm Strich aber bestenfalls nen Link auf nen Win-Treiber haben.

Wenn mir also jemand nen Tip geben kann, wo ich so'n Treiber finde...
immer her damit.

G, der Peter
 
Benutzer-Profile anzeigen Private Nachricht senden

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 21. Mai 2008 3:11   Titel:

http://support.intel.com/support/network/sb/CS-003258.htm

Was die Karte so kann:
http://support.dell.com/support/edocs/comm/xirccbe2/en/trouble.htm
_________________
mfg komsomolze
 
Benutzer-Profile anzeigen Private Nachricht senden

PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 21. Mai 2008 12:18   Titel:

High komsolmolze,

vielen Dank erstmal für den tollen Tip. ich bin der Sache nun mehrere Stunden nachgegangen. Auf der Seite gab's leider keinen Treiber, dafür aber wertvolle Hinweise wo die Schnipseljagd weitergeht. Habe derweil rausgefunden, dass ich ein Pakt installieren soll, in dem sich folgendes Modul befindet: xirc2ps_cs. Habe sogar ne Seite mit vielen Servern gefunden, von denen ich aber irgendwie nichts bekomme. Download ist einfach weg... (ich weiß wie man sachen aus'm Nezt läd und RMT, ZSU etc.....)http://rpmseek.com/rpm-dl/kernel-pcmcia-modules-2.4.27-2-686_2.4.27-12_i386.html?hl=de&cx=858:K:100:2483682:0:0:0

Ja, da stehe ich momentan und bin schonwieder ratlos....

der Peter
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 21. Mai 2008 13:22   Titel:

Nein, die PCMCIA-Module für Kernel 2.4 werden dir nichts nützen, weil Kubuntu 8.04 Kernel 2.6 benutzt.

Zudem handelt es sich um eine *Cardbus*-Karte, also PCI, nicht PCMCIA, das wäre ISA. Es würde mich sehr wundern, wäre der Treiber für diese relativ alte Hardware nicht bereits in Kubuntu 8.04 vorhanden. Externe Treiber braucht fast immer man nur dann einzuspielen, wenn man aktuelle Hardware mit einer alten Distribution einsetzen will.

Poste mal die Ausgaben von "/sbin/lspci -nn" und "/sbin/lsmod".

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 21. Mai 2008 20:55   Titel:

Hallo Janka,

hier die entsprechenden Info's. <hope>ich hoffe das hilft</hope>

g, der Peter

hier die lsmod:
Code:

user@kanister:/sbin$ lsmod
Module                  Size  Used by
ipv6                  267780  8
nls_iso8859_1           4992  1
nls_cp437               6656  1
vfat                   14464  1
fat                    54556  1 vfat
usb_storage            73664  1
libusual               19108  1 usb_storage
xirc2ps_cs             20108  0
serial_cs              23172  1
rfcomm                 41744  2
l2cap                  25728  13 rfcomm
bluetooth              61156  4 rfcomm,l2cap
uinput                 10240  1
nvram                   9992  1
ppdev                  10372  0
apm                    22616  1
cpufreq_userspace       5284  0
cpufreq_stats           7104  0
cpufreq_powersave       2688  0
cpufreq_ondemand        9740  0
freq_table              5536  2 cpufreq_stats,cpufreq_ondemand
cpufreq_conservative     8712  0
iptable_filter          3840  0
ip_tables              14820  1 iptable_filter
x_tables               16132  1 ip_tables
aes_i586               33536  0
dm_crypt               15364  0
dm_mod                 62660  1 dm_crypt
lp                     12324  0
pcmcia                 40876  2 xirc2ps_cs,serial_cs
snd_cs4232             15512  1
snd_opl3_lib           12928  1 snd_cs4232
snd_hwdep              10500  1 snd_opl3_lib
snd_cs4231_lib         26624  1 snd_cs4232
snd_pcm_oss            42144  0
snd_mixer_oss          17920  1 snd_pcm_oss
snd_pcm                78596  2 snd_cs4231_lib,snd_pcm_oss
snd_page_alloc         11400  2 snd_cs4231_lib,snd_pcm
snd_mpu401_uart         9728  1 snd_cs4232
snd_seq_dummy           4868  0
snd_seq_oss            35584  0
snd_seq_midi            9376  0
irtty_sir               9728  0
snd_rawmidi            25760  2 snd_mpu401_uart,snd_seq_midi
sir_dev                17412  1 irtty_sir
evdev                  13056  2
analog                 13600  0
snd_seq_midi_event      8320  2 snd_seq_oss,snd_seq_midi
snd_seq                54224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_m
idi_event
nsc_ircc               24208  0
ns558                   5632  0
snd_timer              24836  4 snd_opl3_lib,snd_cs4231_lib,snd_pcm,snd_seq
snd_seq_device          9612  6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_m
idi,snd_rawmidi,snd_seq
psmouse                40336  0
gameport               16008  3 analog,ns558
irda                  203068  3 irtty_sir,sir_dev,nsc_ircc
crc_ccitt               3072  1 irda
snd                    56996  14 snd_cs4232,snd_opl3_lib,snd_hwdep,snd_cs4231_li
b,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401_uart,snd_seq_dummy,snd_seq_oss,sn
d_rawmidi,snd_seq,snd_timer,snd_seq_device
serio_raw               7940  0
soundcore               8800  1 snd
parport_pc             36260  1
parport                37832  3 ppdev,lp,parport_pc
i2c_piix4               9612  0
i2c_core               24832  1 i2c_piix4
yenta_socket           27276  4
rsrc_nonstatic         13696  1 yenta_socket
pcmcia_core            40596  5 xirc2ps_cs,serial_cs,pcmcia,yenta_socket,rsrc_no
nstatic
pcspkr                  4224  0
ext3                  136712  2
jbd                    48404  1 ext3
mbcache                 9600  1 ext3
sg                     36880  0
sr_mod                 17956  0
cdrom                  37408  1 sr_mod
sd_mod                 30720  5
pata_acpi               8320  0
ata_piix               19588  3
ata_generic             8324  0
libata                159344  3 pata_acpi,ata_piix,ata_generic
uhci_hcd               27024  0
floppy                 59588  0
scsi_mod              151436  5 usb_storage,sg,sr_mod,sd_mod,libata
usbcore               146028  4 usb_storage,libusual,uhci_hcd
fbcon                  42912  0
tileblit                3456  1 fbcon
font                    9472  1 fbcon
bitblit                 6784  1 fbcon
softcursor              3072  1 bitblit
fuse                   50580  1
user@kanister:/sbin$


und hier die lspci:
Code:

user@kanister:/sbin$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host b   ridge (AGP disabled) [8086:7192] (rev 02)
00:02.0 CardBus bridge [0607]: Texas Instruments PCI1250 [104c:ac16] (rev 02)
00:02.1 CardBus bridge [0607]: Texas Instruments PCI1250 [104c:ac16] (rev 02)
00:03.0 VGA compatible controller [0300]: Neomagic Corporation NM2200 [MagicGrap   h 256AV] [10c8:0005] (rev 20)
00:06.0 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ISA [8086:7110] (re   v 02)
00:06.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:71   11] (rev 01)
00:06.2 USB Controller [0c03]: Intel Corporation 82371AB/EB/MB PIIX4 USB [8086:7   112] (rev 01)
00:06.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (r   ev 02)
user@kanister:/sbin$
 
Benutzer-Profile anzeigen Private Nachricht senden

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 21. Mai 2008 21:01   Titel:

zusätzlich, das Modul ist ja schon geladen,
Code:
 modinfo xirc2ps_cs
lspcmcia     # aus den pcmciautils bzw. aus pcmcia-cs


Hast Du die Pakete pcmciautils bzw. pcmcia-cs?
Oder ist schon ein Netzwerkinterface da?
Code:
ifconfig -a

_________________
mfg komsomolze
 
Benutzer-Profile anzeigen Private Nachricht senden

PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 21. Mai 2008 21:10   Titel:

kann ich nicht genau sagen, ob ich die Pakete "pcmciautils bzw. pcmcia-cs" schon habe, an welcher Stelle kann ich das denn sehen?

Netzwekinterface scheint nicht wirklich vorhanden. Entsprechend "ifconfig -a" zeigt er den Infrarotanschluss und einen internen Loopbackadapter an. In der "Systemübersicht" wird auch keine Karte etc. angezeigt und an der Karte selber geht auch kein Lämpchen an. Kann es am Cardmanager liegen?
 
Benutzer-Profile anzeigen Private Nachricht senden

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 21. Mai 2008 21:35   Titel:

"Pakete pcmciautils bzw. pcmcia-cs? "
Diese Pakete starten eine Initialisierung in /etc/init.d/pcmciautils
Vielleicht braucht es genau das?

Code:
dpkg  -l  |  grep  -i  pcmcia

apt-get  install  pcmciautils

_________________
mfg komsomolze


Zuletzt bearbeitet von komsomolze am 21. Mai 2008 21:42, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 21. Mai 2008 21:55   Titel:

sorry, bin noch nicht so fit in der Syntax unter Linux. Irgendwie scheint das mit den Leerzeichen nicht zu klappen. Ich habe es halt so geschrieben wie Du, sprich mit den ganzen Leerzeichen etc. Kommt dann aber gleich die Meldung: unbekannte Option -1. Ich habs natürlich auch ohne dem Leerzeichen probiert, dann sagt er aber dgkp-1 command not found...
 
Benutzer-Profile anzeigen Private Nachricht senden

PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 21. Mai 2008 22:12   Titel:

hmm, ich habe nun über den Adept-Manager herausgefunden, dass die Pakete "pciutils" und "pcmciautils" installiert sind. Hilft das?
 
Benutzer-Profile anzeigen Private Nachricht senden

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 21. Mai 2008 22:33   Titel:

Habe ich mir auch schon gedacht, da der Treiber geladen ist und ubuntu i.a. "benutzerfreundlich" vorkonfiguriert.


Ist "allow-hotplug eth0" oder ähnlich in /etc/network/interfaces schon eingetragen?
Es gibt ein /usr/share/doc/pcmciautils/mini-howto.txt.gz.

/etc/init.d/pcmciautils kann Einstellungen aus einer (noch nicht vorhandenen?) /etc/default/pcmciautils einlesen.
(erstellt oder verfeinert nach Anleitung aus dem mini-howto?)




-------------------------
Zitat:
unbekannte Option -1
das war ein kleines "L"
_________________
mfg komsomolze


Zuletzt bearbeitet von komsomolze am 22. Mai 2008 16:21, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 22. Mai 2008 7:30   Titel:

also in etc/network/interfaces steht nur "auto lo" und "iface lo inet loopback" drin. Sollte ich die Datei um diesen Eintrag ergänz?

das mini-howto werde ich mir mal jetzt zu Gemüte führen. Im Kofler ist das Thema leider zu spartanisch abgehandelt.

der Peter
 
Benutzer-Profile anzeigen Private Nachricht senden

PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 22. Mai 2008 8:19   Titel:

ich habe gerade das mini-how to durch und glaich mal mit "pccardctl info" nachgefragt, da zeigt er/es fast die korrekte Karte an! Ach brat mir doch einer nen Storch....
 
Benutzer-Profile anzeigen Private Nachricht senden

PeterLustich



Anmeldungsdatum: 14.05.2008
Beiträge: 24

BeitragVerfasst am: 22. Mai 2008 9:14   Titel:

ich habe jetzt gesehen, dass das Paket "pcmcia-cs" nicht drauf ist. Also holla doe Waldfee das Ding runtergeladen, ausgewickelt und entsprechend dem how-to in das usr/src - verzeichnis gekippt. How-to sagt':
Code:
  Here is a synopsis of the installation process:

  +o  Unpack pcmcia-cs-3.2.?.tar.gz in /usr/src.

  +o  Run ``make config'' in the new pcmcia-cs-3.2.? directory.

  +o  Run ``make all'', then ``make install''.

  +o  Customize the startup script and the option files in /etc/pcmcia
     for your site, if needed.


also das Erste lockt ja noch neReaktion hervor. Aber spätestens beim Kommando :"make all" ist dann schluss. Verstehe ich das Script falsch oder was muss ich machen? Der Paketmanager möchte nicht auf die Platte schauen um sich die Pakete selber einzulesen!

Falls noch jemand ne Ize hat, wie's weitergeht...
her damit,

der Peter


Zuletzt bearbeitet von PeterLustich am 22. Mai 2008 9:15, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 22. Mai 2008 10:02   Titel:

Die meisten Howtos gehen immer vom unbequemsten Fall aus, dass man alles selbst kompilieren muss. Das ist sinnvoll, denn nach den Howtos des Softwareentwicklers gehen auch die Paketmaintainer vor, wenn sie Pakete für den Endanwender bauen.

Es ist im allgemeinen unnötig, Software selbst aus den Quellen zu bauen, wie du es gerade vorhast. Es ist fast immer sogar unnötig, selbst danach zu suchen. Den Paketnamen zu wissen reicht schon. Wenn pcmcia-cs nicht da ist, kannst du es bei Kubuntu vermutlich einfach und schmerzlos mit "apt-get install pcmcia-cs" installieren. Oder mit "adept", oder "synaptic" oder einem anderen Paketmanager deiner Wahl. Nichts mit make etc.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy