Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit nVidia Treiber 173.14.05

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Twins



Anmeldungsdatum: 23.05.2008
Beiträge: 19

BeitragVerfasst am: 11. Jun 2008 8:06   Titel: Probleme mit nVidia Treiber 173.14.05

Hallo,

ich habe vor ein paar Tagen eine neuen Festplatte bekommen und wollte dort gerne Debian Etch 32-Bit aufspielen, was im Grunde auch geklappt hat. Allerdings lässt sich der X-Server nicht starten, vermutlich wegen den Treibern.
Auf den alten System hatte ich eine ältere Version der Treiber drauf, mit denen ging alles reibungslos - NUR die neuen machen Pobleme.

Grafikkarte: nVidia GeForce 8800GT mit 512MB

Also, nachdem die minimale Installation von Debian fertig ist, hab ich über den Paketmanager einige Sachen installiert:
Zitat:
apt-get install xserver-xorg-core gdm gnome-core xfonts-base gcc g++ build-essential libncurses5-dev pkg-config linux-headers-ùname -r`


Danach habe ich den GDM beendet und die Treiber geladen von: http://www.nvidia.de/object/linux_display_ia32_173.14.05_de.htmlhttp://de.download.nvidia.com/XFree86/Linux und ausführbar gemacht.

Als root habe ich das Setup mittels ./NVIDIA-Linux-x86-173.14.05-pkg1.run gestartet und wenn man Ende gefragt wird "neue X-Config anlegen, damit nVidia-Treiber geladen werden" habe ich mit ja geantwortet.

Dann war die Installation beendet und System neugestartet - der X startet leider nicht. In den Logs vom X finde ich immer wieder Einträge, dass der den "device /dev/nvidia0" nicht finden kann und "no screens selected".
Dabei habe ich den X gesagt er soll die nVidia Treiber nehmen und auch die Auflösung 1280x960 nutzen.

Jemand eine Ahnung was ich jetzt machen kann? Wie gesagt mit einer älteren Version hat es funktioniert, nur ich weiß die Versionsnummer nicht mehr.
Danke.

Viele Grüße,
Twins
_________________
Meine Community:
http://twinsspieleforum.de/
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Twins



Anmeldungsdatum: 23.05.2008
Beiträge: 19

BeitragVerfasst am: 11. Jun 2008 20:21   Titel:

Ich bins nochmal - hab was rumprobiert. Wink

Das System hab ich in diesen single user Modus gestartet und dann manuell GDM gestartet - das funktioniert.
Im normalen Modus will der GDM aber nicht von alleine starten.

Der letze Auszug der Logs:
Zitat:
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): NVIDIA GPU GeForce 8800 GT (G92) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 62.92.16.00.04
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 8800 GT at PCI:1:0:0:
(--) NVIDIA(0): ACI ASUS MB19SE (CRT-0)
(--) NVIDIA(0): ACI ASUS MB19SE (CRT-0): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1280x1024"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(++) NVIDIA(0): DPI set to (96, 96); computed from -dpi X commandline option
(==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xe8200000 - 0xe8203fff (0x4000) MX[B]
[5] -1 0 0xe8204000 - 0xe82047ff (0x800) MX[B]
[6] -1 0 0xe4000000 - 0xe7ffffff (0x4000000) MX[B]
[7] -1 0 0xe8000000 - 0xe81fffff (0x200000) MX[B]
[8] -1 0 0xf1000000 - 0xf1000fff (0x1000) MX[B]
[9] -1 0 0xf2000000 - 0xf2001fff (0x2000) MX[B]
[10] -1 0 0xf2106000 - 0xf21060ff (0x100) MX[B]
[11] -1 0 0xf2104000 - 0xf21043ff (0x400) MX[B]
[12] -1 0 0xf2100000 - 0xf2103fff (0x4000) MX[B]
[13] -1 0 0xf2105000 - 0xf21053ff (0x400) MX[B]
[14] -1 0 0xec000000 - 0xedffffff (0x2000000) MX[B](B)
[15] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
[16] -1 0 0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
[17] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[18] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[19] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[21] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[22] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[23] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B]
[24] -1 0 0x0000b400 - 0x0000b40f (0x10) IX[B]
[25] -1 0 0x0000b300 - 0x0000b303 (0x4) IX[B]
[26] -1 0 0x0000b200 - 0x0000b207 (0x8) IX[B]
[27] -1 0 0x0000b100 - 0x0000b103 (0x4) IX[B]
[28] -1 0 0x0000b000 - 0x0000b007 (0x8) IX[B]
[29] -1 0 0x0000ec00 - 0x0000ec0f (0x10) IX[B]
[30] -1 0 0x0000eb00 - 0x0000eb0f (0x10) IX[B]
[31] -1 0 0x0000ea00 - 0x0000ea03 (0x4) IX[B]
[32] -1 0 0x0000e900 - 0x0000e907 (0x8) IX[B]
[33] -1 0 0x0000e800 - 0x0000e803 (0x4) IX[B]
[34] -1 0 0x0000e700 - 0x0000e707 (0x8) IX[B]
[35] -1 0 0x00000500 - 0x0000051f (0x20) IX[B]
[36] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[B]
[37] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
[38] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[B]
[39] -1 0 0x0000e300 - 0x0000e31f (0x20) IX[B]
[40] -1 0 0x0000e200 - 0x0000e21f (0x20) IX[B]
[41] -1 0 0x0000e500 - 0x0000e51f (0x20) IX[B]
[42] -1 0 0x0000e100 - 0x0000e11f (0x20) IX[B]
[43] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[44] -1 0 0x0000a000 - 0x0000a07f (0x80) IX[B](B)
[45] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[46] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Unable to connect to the ACPI daemon; the ACPI daemon may not
(II) NVIDIA(0): be running or the "AcpidSocketPath" X configuration option
(II) NVIDIA(0): may not be set correctly. When the ACPI daemon is
(II) NVIDIA(0): available, the NVIDIA X driver can use it to receive ACPI
(II) NVIDIA(0): events. For details, please see the "ConnectToAcpid" and
(II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
(II) NVIDIA(0): Config Options in the README.
(II) NVIDIA(0): Setting mode "1280x1024"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Generic Keyboard: XkbModel: "pc105"
(**) Option "XkbLayout" "de"
(**) Generic Keyboard: XkbLayout: "de"
(**) Option "XkbVariant" "nodeadkeys"
(**) Generic Keyboard: XkbVariant: "nodeadkeys"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
xkb_keycodes { include "xfree86+aliases(qwertz)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc(pc105)+de(nodeadkeys)" };
xkb_geometry { include "pc(pc105)" };
(II) Configured Mouse: ps2EnableDataReporting: succeeded
(II) NVIDIA(0): Setting mode "1280x960"
(II) NVIDIA(0): Setting mode "1280x1024"
(II) NVIDIA(0): Setting mode "1280x960"
(II) NVIDIA(0): Setting mode "1024x768"
(II) NVIDIA(0): Setting mode "1280x960"
(II) NVIDIA(0): Setting mode "1280x1024_75"

_________________
Meine Community:
http://twinsspieleforum.de/
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Twins



Anmeldungsdatum: 23.05.2008
Beiträge: 19

BeitragVerfasst am: 14. Jun 2008 13:42   Titel:

Hi,

auf meinen 64-Bit Debian mit 64-Bit Treibern klappt alles - nur bei 32-Bit nicht.
_________________
Meine Community:
http://twinsspieleforum.de/
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 14. Jun 2008 14:00   Titel:

Guck doch mal in Deine xorg.conf, welcher Treiber verwendet wird. Ist es nv oder nvidia ?
 
Benutzer-Profile anzeigen Private Nachricht senden

Twins



Anmeldungsdatum: 23.05.2008
Beiträge: 19

BeitragVerfasst am: 14. Jun 2008 19:59   Titel:

In der conf steht überall nvidia Wink
_________________
Meine Community:
http://twinsspieleforum.de/
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy