Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
upgrade Probleme bei Debian

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Umstieg auf Linux
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
alko_klinik



Anmeldungsdatum: 12.06.2008
Beiträge: 29

BeitragVerfasst am: 12. Jun 2008 10:21   Titel: upgrade Probleme bei Debian

Hallo Leute!

Ich suche schon seit mehr als eijner Woche nach dem Problem, jetzt hoffe ich im Forum erfolg zu haben.

Habe auf den Debian-Rechner in der Firma ein apt-get upgrade gemacht
und er zeigte mir dann einige nicht aufgelöste (unment dependencies) python-Pakete.

Egal dachte ich mir kommt eh bald das Lenny, kümmere ich mich dann darum.
Wichtiger ist ja jetzt das ich die NVidia-Grafikkarte wieder zum laufen bring.

habe den neuesten Treiber von NVIDIA gezogen und ein sh damit ausgeführt.
Natürlich ist kein Kernel vorhanden, eh klar
auf der nvidia-site at er ihn auch nicht gefunden
muss er Ihn halt selbst kompilieren.

Er bricht dann aber ab, weil die libc vom developer package nicht vorhanden ist.
ich schätze mal er braucht die linux-libc-dev
kann ich aber nicht herunterladen,
weil diese unmet dependencies blockieren.

pu02zpr002:~# apt-get install linux-libc-dev
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
linux-libc-dev: Conflicts: linux-kernel-headers
python-cairo: Depends: python (>= 2.4) but 2.3.5-5 is to be installed
python-central: Depends: python (>= 2.4.3-10) but 2.3.5-5 is to be installed
python-glade2: Depends: python (>= 2.4) but 2.3.5-5 is to be installed
python-gmenu: Depends: python (>= 2.4) but 2.3.5-5 is to be installed
python-gobject: Depends: python (>= 2.4) but 2.3.5-5 is to be installed
python-gtk2: Depends: python (>= 2.4) but 2.3.5-5 is to be installed
python-newt: Depends: python (>= 2.4) but 2.3.5-5 is to be installed
python-numeric: Depends: python (>= 2.4) but 2.3.5-5 is to be installed
python-support: Depends: python (>= 2.4) but 2.3.5-5 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

apt-get -f install hat keine auswirkungen

hat sonst noch irgend wer ne Idee?
bin am Verzweifeln

Cool alko_klinik
 
Benutzer-Profile anzeigen Private Nachricht senden

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 12. Jun 2008 10:47   Titel:

Hi!

Bei einem normalen Etch kommt sowas nicht vor - hast du Lenny/Sid oder Extra-Pakete aus Backports oder so?

Versuche auch mal aptitude statt apt-get. Wird sowieso als das bessere Tool empfohlen.

Grüße,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

alko_klinik



Anmeldungsdatum: 12.06.2008
Beiträge: 29

BeitragVerfasst am: 12. Jun 2008 12:41   Titel:

Ja Hallo!

Gleich so eine Größe die mir antwortet Very Happy

ja, hast recht,
aptitude ist super -> da tut sich ja was
die unment dependencies hab ich jetzt weg.
ein aptitude upgrade durch geführt
linux-libc-dev installiert
nur der NVIDIA Treiber bricht immer noch wegen des feheln der libc ab.
also war's nicht das Paket linux-libc-dev das er wollte

meine sources.list sieht folgender maßen aus:
# security updates
deb ftp://security.debian.org/debian-security/ stable/updates main contrib non-free

deb ftp://ftp.debian.at/debian unstable main contrib non-free

deb ftp://ftp.debian.at/debian testing main contrib non-free

# centericq
#deb http://debian.parsed.net unstable main

#fifi.org (xview)
#deb http://debian.fifi.org/debian-local woody/unofficial/

#dvdrip
#deb http://marillat.free.fr/ testing main
#deb http://marillat.free.fr/ unstable main

# rox filer
#deb http://www.janw.easynet.be/rox/ i386/

# Cheetah
#deb http://debian.icg.tugraz.at unstable main

wo ist da der hinweis welche version ich habe?
bei ubuntu steht doch immer hardy, gutsy, ...

alle vorhandenen http adressen musste ich in ftp umändern
da das LKH Graz einen Paketfilter hat
die letzte Adresse hatte leider keinen ftp-download
also hab ich Ihn weggelassen.

Die Fehlermeldung vom NVIDI-Treiber ist wie folgt:
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
ERROR: You do not appear to have libc header files installed on your system.
Please install your distribution's libc development package.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

hast Du irgend eine Ahnung welches Paket da fehlt?

Cool alko_klinik
 
Benutzer-Profile anzeigen Private Nachricht senden

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 12. Jun 2008 13:19   Titel:

Hi!

Du hast da
unstable = sid
testing = lenny

Da muss man schon einmal damit rechnen, dass ein Update nicht klappt. Oft hilft abwarten Wink

Was den Treiber angeht, vermute ich libc6-dev. Du kannst, um sicherzugehen, auch build-essential installieren.

Grüße,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

alko_klinik



Anmeldungsdatum: 12.06.2008
Beiträge: 29

BeitragVerfasst am: 13. Jun 2008 8:16   Titel:

Hallo Hjb!

Danke hat super funktioniert!
Er hat durch-Kompiliert und ich hab den runlevel in inittab wieder auf 5 gestellt.
Hoffe das war der richtige.
Nach dem reboot kann ich jetzt leider nicht kontrollieren ob die Grafische Oberfläche läuft,
da ich erst wieder am Montag in der Kinerradiologie bin.

Unterdessen stell ich mir aber eine ganz andere Frage.
wenn die libc gar nicht vorhanden war, musste der Treiber ja noch nie Compilieren.
Dann ist das Problem nur beim apt-get gelegen!?

soll ich jetzt das nvidia-glx Package nochmals drüber spielen?
Dann würde er doch beim nächsten Update das selbst managen, isn't it?

Cool alko_klinik
 
Benutzer-Profile anzeigen Private Nachricht senden

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 13. Jun 2008 10:42   Titel:

Hi!

> Dann ist das Problem nur beim apt-get gelegen!?

Es sind halt standardmäßig keine Compilersachen installiert.

Über nvidia-glx weiß ich nichts.

Grüße,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

alko_klinik



Anmeldungsdatum: 12.06.2008
Beiträge: 29

BeitragVerfasst am: 16. Jun 2008 13:30   Titel:

ich hab jetzt zwar die unment dependencies weg,
aber dafür ein anderes Problem!

wenn ich was installieren will schreibt er mir jetzt immer:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

aber bei dem Befehl den er mir vorschlägt bricht er auch immer ab

...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.15-1-686-smp
/usr/sbin/mkinitramfs: line 164: mktemp: command not found
update-initramfs: failed for /boot/initrd.img-2.6.15-1-686-smp
dpkg: subprocess post-installation script returned error exit status 1

kannst Du mir vielleicht auch dabei weiterhelfen?
Ich wollte nämlich Deine Systemwiederherstellung ausprobieren.
aptitude eingetippt
dann 2 x aufs plus und dan groß G, klein g
und er hat schon gerödelt...
Dann war mir das ganze etwas unheimlich, und ich hab abgebrochen
Crying or Very sad und jetzt hab ich eben dieses Problem.

sollte vielleicht doch nicht alles gleich ausprobieren
zumindest beim Firmenrechner Laughing

Cool alko_klinik
 
Benutzer-Profile anzeigen Private Nachricht senden

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 17. Jun 2008 11:12   Titel:

Hi!

Ein ähnliches Problem habe ich schon mal als Fehler gemeldet. Es ist laut Debian aber eher kein Fehler, sondern ein Problem, das durch das Update auf Sid verursacht wird. Du musst das Paket mktemp nachinstallieren. Das gehört zu den essentiellen Paketen und ist daher normalerweise automatisch vorhanden.

Grüße,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Umstieg auf Linux Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy