Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Nov 2018 9:56

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Merlin UMTS Karte und serial_cs
BeitragVerfasst: 05. Jul 2008 18:04 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Hallo !

Ich habe jetzt eine Merlin U630 UMTS-Karte, um unterwegs mal Mails checken zu können. Laut zahlreichen Anleitungen (z. B. diese) soll das ziemlich problemlos funktionieren. Die Karte sollte vom Modul serial_cs unterstützt werden, bei mir funktioniert das aber nicht. Stecke ich die Karte ein, wird kein Modul geladen. Auch wenn ich es per Hand lade, erscheint keine neues Device (/dev/ttySx), auch in den Logs taucht nichts auf (wie es laut Anleitung der Fall sein sollte). Was läuft da schief?

Die Karte wird erkannt:
Code:
pccardctl status
Socket 0:
  5.0V 16-bit PC Card
Socket 1:
  no card
... nur das Modul scheint sich nicht zuständig zu fühlen.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 05. Jul 2008 20:03 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Hat sich erledigt. In den pcmcia-Paketen hat's wohl irgendwo gehakt. Nach de- und reinstallation funktioniert's.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 05. Jul 2008 21:03 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Das war's wohl doch nicht. Nach einem Neustart dasselbe Spiel. Dabei war ich vorher schon Online mit der Karte. Wenn also jemand noch eine Idee hat wäre ich dankbar.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 06. Jul 2008 11:05 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Mal weiter nachgeforscht. Was komisch ist, daß die Karte in meinem System nicht richtig erkannt wird, wohl aber von einer Knoppix Live-CD:

Installiertes System:
Code:
# pccardctl ident
Socket 0:
  no product info available
Socket 1:
  no product info available

Knoppix:
Code:
# pccardctl ident
Socket 0:
  product info: "Novatel Wireless", "Merlin UMTS Modem", "U630", ""
  manfid: 0x00a4, 0x0276
  function: 2 (serial)
Socket 1:
  no product info available


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 06. Jul 2008 22:35 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Ich hab's. Die PCMCIA-Slots müssen bei 16 Bit-Karten wohl erst gestartet werden. Wenn ich folgendes beim Hochfahren ausführe, funktioniert's:
Code:
/lib/udev/pcmcia-socket-startup 0
/lib/udev/pcmcia-socket-startup 1
Aus irgendeinem Grund wird das bei meinem System nicht automatisch ausgeführt.

Das war verdammt fies !


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 22. Nov 2008 16:34 
Offline

Registriert: 22. Nov 2008 15:38
Beiträge: 2
Hallo,

ich habe auch eine solche Karte und komme nicht per UMTS ins Internet. Bisher konnte mir auch keiner weiterhelfen.... :(
Ich habe Suse 11.0 mit KDE 4..
Wo genau kann ich die hier erwähnten Einstellungen vornehmen? Wer kann mir helfen?

LG
Zurbel


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 22. Nov 2008 19:13 
Offline

Registriert: 22. Nov 2008 15:38
Beiträge: 2
Nun, die Karte scheint erkannt zu werden - aber mehr auch nicht...

Ausgabe von hwinfo --pcmcia:
Code:
26: PCMCIA 00.1: 0000 Unclassified device
[Created at pcmcia.84]
UDI: /org/freedesktop/Hal/devices/pcmcia__1__1_0
Unique ID: DH4X.sUdupz7cpz5
Parent ID: Tq_r.3FEKYRLJPHD
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:0f:06.0/0.1
SysFS BusID: 0.1
Hardware Class: unknown
Model: "Novatel Wireless Merlin UMTS Modem"
Hotplug: CardBus
Socket: 0
Vendor: pcmcia 0x00a4 "Novatel Wireless"
Device: pcmcia 0x0276 "Merlin UMTS Modem"
Driver: "serial_cs"
Driver Modules: "serial_cs"
Module Alias: "pcmcia:m00A4c0276f02fn01pfn01pa32607776pbD9E73B13pc0E87332Epd00000000"
Driver Info #0:
Driver Status: serial_cs is active
Driver Activation Cmd: "modprobe serial_cs"
Extra Info: Novatel Wireless, Merlin UMTS Modem, U630
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #4 (CardBus bridge)

27: PCMCIA 00.0: 0000 Unclassified device
[Created at pcmcia.84]
UDI: /org/freedesktop/Hal/devices/pcmcia__1__1
Unique ID: m5qS.sUdupz7cpz5
Parent ID: Tq_r.3FEKYRLJPHD
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:0f:06.0/0.0
SysFS BusID: 0.0
Hardware Class: unknown
Model: "Novatel Wireless Merlin UMTS Modem"
Hotplug: CardBus
Socket: 0
Vendor: pcmcia 0x00a4 "Novatel Wireless"
Device: pcmcia 0x0276 "Merlin UMTS Modem"
Driver: "serial_cs"
Driver Modules: "serial_cs"
Module Alias: "pcmcia:m00A4c0276f02fn00pfn00pa32607776pbD9E73B13pc0E87332Epd00000000"
Driver Info #0:
Driver Status: serial_cs is active
Driver Activation Cmd: "modprobe serial_cs"
Extra Info: Novatel Wireless, Merlin UMTS Modem, U630
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #4 (CardBus bridge)
Ausgabe von lsmod|grep serial_cs:
Code:
 serial_cs 45188 2
pcmcia 61336 1 serial_cs
pcmcia_core 61604 4 serial_cs,pcmcia,yenta_socket,rsrc_nonstatic
pccardctl ident:
Code:
Socket 0: 
  product info: "Novatel Wireless", "Merlin UMTS Modem", "U630", "" 
  manfid: 0x00a4, 0x0276 
  function: 2 (serial) 
Socket 1: 
  no product info available
Einwählen hab ich versucht nach folgendem Muster: http://www.nodemaster.de/31-1-kabellose ... linux.html, allerdings bekomme ich beim starten der Sache die Meldung, das /dev/tts nicht existiert (gibt es auf diesem Rechner tatsächlich nicht)

Vorschläge? Ideen? :(

LG
Zurbel


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 22. Nov 2008 19:52 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
http://pcmcia-cs.sourceforge.net/man/serial_cs.4.html
Die tatsächliche Devicenode steht im Kernellog (dmesg) drin und soll wohl /dev/ttyS... sein.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags: umts karte Merlin u630
BeitragVerfasst: 12. Feb 2009 15:08 
hallo, ich habe eine umts karte Merlin U630, aber ich komme damit nicht zurecht.
ich habe viele foren gelesen aber keines konnte mir weiter helfen. meiner karte wird keine ttyS* schnittstelle zugeteilt...

hilfe und tipps würden mir sehr helfen...


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de