Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
lv export

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
susmi
Gast





BeitragVerfasst am: 07. Jul 2008 17:11   Titel: lv export

Hallo LV-Fans,

mein Experiment schlug mangel log. Volumes-Kenntnissen fehl
(Warum habe ich mich damit eingelassen ??)

Also ich wollte ein reallen Rechner zu einem Vmware-PC kopieren:

Ich legte das Filesystem auf der VM analog dem des rellen PC's an.
(also mit /dev/vg00-lv1 usw...)
plus einem Linuxsystem zur Administration.

Dann wurden die (Quellen-) Dateisysteme mit TAR archiviert und und auf der VM entpackt.
Dar Bootversuch ging dann aber schief mit der Meldung, dass die logischen Volumes nicht gefunden wurden.

Da der PC micht ausgeschaltet werden kann, suche ich eine Onlinelösung ...

Gute Ideen wilkommen.

LG
sumsi
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 09. Jul 2008 10:58   Titel:

Hi!

Es reicht heutzutage leider nicht mehr, die Dateisysteme zu kopieren. Du musst auch noch /dev/.static auf das Zielsystem kopieren. Wenn ich mich recht erinnere:

Code:
cp -a /dev/.static/* /target/dev


Ich glaube, ich habe es schonmal irgendwo beschrieben.

Grüße,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

sumsi
Gast





BeitragVerfasst am: 09. Jul 2008 13:47   Titel: .static

Hallo hjb,

ich glaube mich erinnern zu können, Du hattest das mit der /dev/.staic irgendwie im Zusammenhang mit rsync beschrieben...

Nützt mir aber nix, hier auf der SLES 10.1 gibt es keine /dev/.static.

Höchstewahrscheinlich gibt's Konflikte mit der UID der log. Volumes Sad

LG
sumsi
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 10. Jul 2008 11:09   Titel:

Hi!

bzgl. UUID fällt mir nichts ein. Aber ist der Kernel auf Host und Gast der gleiche? Wenn der Gastkernel neuer ist, dann könnten die LVM-Tools veraltet sein. Als Workaround könnte es reichen, im neuen Kernel die sysfs-Legacy-Optionen einzuschalten.

Grüße,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

susmi
Gast





BeitragVerfasst am: 16. Jul 2008 13:00   Titel: 2. Versuch

Hallo,

da bin ich wieder Wink

Die Systeme sind so ziemlich alle gleich ...

Mein 2. Versuch:
Ein Image von der Platte /dev/sda wurde erstellt (device-image.de).
Diese Daten wurden dann auf eine VM-Platte kopiert und danach in einer
neu erstellten VM eingebunden.
Dann wurde mit einer Boot-CD gestartet und das Image auf der virtuellen /dev/sda zurückgespielt.

Beim booten nun die selbe Fehlermeldung: kann Volumegroup vg00 nicht finden.....

Muss ich das verstehen?

Grüße
sumsi
 

sumsi
Gast





BeitragVerfasst am: 16. Jul 2008 18:19   Titel: edit

-edit -

Bei dem Vergleich der originalen Quelle und der Kopie konnte ich keinen Unterschied feststellen.
Beim booten von CD war diese LVM beinhaltende Partition sda3.
Beim booten vom System werden keine Device angelegt, weder sdaX, noch lvm-mapper ... Sad

bye
sumsi
 

sumsi
Gast





BeitragVerfasst am: 21. Jul 2008 7:31   Titel: Auflösung:

Der Fehler lag woanders:

Das Original hatte eine andern SCSI-Treiberaufruf als die neue Maschine und konnte nach dem Start die Festplatte nicht mehr finden ...

Kaum macht amn es richtig schon funktionierts: Aufruf in die initrd eingeschrieben und es läuft ...
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy