Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 15. Nov 2018 3:49

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 13 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: growisofs und openSuse 11.0
BeitragVerfasst: 13. Jul 2008 20:14 
Ich habe Probleme mit growisofs unter openSuse 11.0. Ich weiß nicht, ob es nun ein Software- oder ein Hardware-Problem ist.

dieter@home:/> growisofs -Z /dev/sr0 -r /dat
WARNING: /dev/sr0 already carries isofs!
About to execute 'genisoimage -r ./ | builtin_dd of=/dev/sr0 obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
0.02% done, estimate finish Sun Jul 13 18:42:44 2008
0.05% done, estimate finish Sun Jul 13 18:42:44 2008
0.07% done, estimate finish Sun Jul 13 19:06:46 2008
/dev/sr0: "Current Write Speed" is 2.0x4390KBps.
0.09% done, estimate finish Mon Jul 14 01:37:49 2008
0.12% done, estimate finish Mon Jul 14 00:43:34 2008
0.14% done, estimate finish Mon Jul 14 00:19:38 2008
0.16% done, estimate finish Mon Jul 14 00:02:23 2008
0.18% done, estimate finish Sun Jul 13 23:40:33 2008
0.21% done, estimate finish Sun Jul 13 23:31:29 2008
0.23% done, estimate finish Sun Jul 13 23:24:19 2008
0.25% done, estimate finish Sun Jul 13 23:18:22 2008

[...]

54.52% done, estimate finish Sun Jul 13 21:56:53 2008
54.54% done, estimate finish Sun Jul 13 21:56:54 2008
54.56% done, estimate finish Sun Jul 13 21:56:54 2008
54.59% done, estimate finish Sun Jul 13 21:56:55 2008
54.61% done, estimate finish Sun Jul 13 21:56:55 2008
54.63% done, estimate finish Sun Jul 13 21:56:54 2008
54.66% done, estimate finish Sun Jul 13 21:56:55 2008
54.68% done, estimate finish Sun Jul 13 21:57:12 2008
:-[ WRITE@LBA=b48440h failed with SK=3h/WRITE ERROR - AUTO-REALLOCATION FAILED]: Input/output error
:-( write failed: Input/output error
/dev/sr0: flushing cache
:-[ SYNCHRONOUS FLUSH CACHE failed with SK=3h/ASC=A0h/ACQ=80h]: Input/output error


Der Fortschritt ist immer unterschiedlich, manchmal bricht es schon bei 20% ab, manchmal erst bei 90%.
Im Syslog steht absolut gar nichts und der Fehler tritt auch auf, wenn ich es als root starte.
Es gibt keinen Prozess, der auf irgendwas unter /dat zugreift. Ich teste im Runlevel 3, also ohne KDE-Automounter (geht aber auch unter KDE nicht). CDs kann ich mit wodim oder K3b brennen.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14. Jul 2008 8:07 
Verflixte Kiste. Es scheint nur bei Dual Layer Rohlingen Probleme zu geben, sobald die zweite Schicht begonnen wird. Ich habe gerade einen Single komplett gefüllt, geht einwandfrei. Komischerweise geht das Löschen eines Rohlings durch, wird aber in der Mitte für eine Weile extrem langsam.


dieter@home:/> growisofs -Z /dev/sr0=/dev/zero
About to execute 'builtin_dd if=/dev/zero of=/dev/sr0 obs=32k seek=0'
/dev/sr0: "Current Write Speed" is 2.0x4390KBps.
1900544/48440016896 ( 0.0%) @0.0x, remaining 2973:25 RBU 100.0% UBU 1.7%
1900544/48440016896 ( 0.0%) @0.0x, remaining 4247:44 RBU 100.0% UBU 100.0%
1900544/48440016896 ( 0.0%) @0.0x, remaining 5946:50 RBU 100.0% UBU 100.0%
1900544/48440016896 ( 0.0%) @0.0x, remaining 7221:09 RBU 100.0% UBU 100.0%
1900544/48440016896 ( 0.0%) @0.0x, remaining 8495:28 RBU 100.0% UBU 100.0%
10092544/48440016896 ( 0.0%) @0.5x, remaining 1919:26 RBU 100.0% UBU 98.3%
22642688/48440016896 ( 0.0%) @0.8x, remaining 962:14 RBU 100.0% UBU 98.3%
35160064/48440016896 ( 0.1%) @0.8x, remaining 688:20 RBU 100.0% UBU 98.3%
48529408/48440016896 ( 0.1%) @0.9x, remaining 565:03 RBU 100.0% UBU 98.3%
59441152/48440016896 ( 0.1%) @0.7x, remaining 501:55 RBU 100.0% UBU 98.3%
70451200/48440016896 ( 0.1%) @0.7x, remaining 457:42 RBU 100.0% UBU 98.3%
81461248/48440016896 ( 0.2%) @0.7x, remaining 435:20 RBU 100.0% UBU 98.3%
92471296/48440016896 ( 0.2%) @0.7x, remaining 409:33 RBU 100.0% UBU 98.3%

[...] ab hier wird es langsam

24220401664/48440016896 (50.0%) @0.8x, remaining 105:15 RBU 100.0% UBU 98.3%
24223219712/48440016896 (50.0%) @0.2x, remaining 105:18 RBU 100.0% UBU 98.3%
24224858112/48440016896 (50.0%) @0.1x, remaining 105:20 RBU 100.0% UBU 70.7%
24227676160/48440016896 (50.0%) @0.2x, remaining 105:21 RBU 100.0% UBU 98.3%
24229183488/48440016896 (50.0%) @0.1x, remaining 105:25 RBU 100.0% UBU 77.6%
24230494208/48440016896 (50.0%) @0.1x, remaining 105:27 RBU 100.0% UBU 100.0%
24231149568/48440016896 (50.0%) @0.0x, remaining 105:30 RBU 100.0% UBU 84.5%
24231804928/48440016896 (50.0%) @0.0x, remaining 105:33 RBU 100.0% UBU 100.0%
24233181184/48440016896 (50.0%) @0.1x, remaining 105:36 RBU 100.0% UBU 70.7%
24233443328/48440016896 (50.0%) @0.0x, remaining 105:38 RBU 100.0% UBU 100.0%

[...] und nach einer Weile wieder schneller

26249134080/48440016896 (54.2%) @0.1x, remaining 161:13 RBU 100.0% UBU 87.9%
26252673024/48440016896 (54.2%) @0.2x, remaining 161:13 RBU 100.0% UBU 67.2%
26259357696/48440016896 (54.2%) @0.4x, remaining 161:11 RBU 100.0% UBU 53.4%
26263814144/48440016896 (54.2%) @0.3x, remaining 161:10 RBU 100.0% UBU 74.1%
26269515776/48440016896 (54.2%) @0.4x, remaining 161:09 RBU 100.0% UBU 63.8%
26275282944/48440016896 (54.2%) @0.4x, remaining 161:07 RBU 100.0% UBU 74.1%
26281574400/48440016896 (54.3%) @0.4x, remaining 161:04 RBU 100.0% UBU 36.2%
26287341568/48440016896 (54.3%) @0.4x, remaining 161:03 RBU 100.0% UBU 22.4%
26293043200/48440016896 (54.3%) @0.4x, remaining 161:01 RBU 100.0% UBU 70.7%
26300973056/48440016896 (54.3%) @0.5x, remaining 160:57 RBU 100.0% UBU 46.6%
26306740224/48440016896 (54.3%) @0.4x, remaining 160:56 RBU 100.0% UBU 60.3%
26314899456/48440016896 (54.3%) @0.5x, remaining 160:52 RBU 100.0% UBU 98.3%
26321289216/48440016896 (54.3%) @0.4x, remaining 160:49 RBU 100.0% UBU 32.8%
26331906048/48440016896 (54.4%) @0.7x, remaining 160:44 RBU 100.0% UBU 81.0%
26340360192/48440016896 (54.4%) @0.6x, remaining 160:40 RBU 100.0% UBU 87.9%
26353336320/48440016896 (54.4%) @0.9x, remaining 160:32 RBU 100.0% UBU 98.3%
26366312448/48440016896 (54.4%) @0.9x, remaining 160:25 RBU 100.0% UBU 98.3%

[...]

48294395904/48440016896 (99.7%) @0.9x, remaining 0:52 RBU 100.0% UBU 98.3%
48307634176/48440016896 (99.7%) @0.9x, remaining 0:47 RBU 100.0% UBU 98.3%
48320217088/48440016896 (99.8%) @0.8x, remaining 0:42 RBU 100.0% UBU 98.3%
48332800000/48440016896 (99.8%) @0.8x, remaining 0:38 RBU 100.0% UBU 98.3%
48345382912/48440016896 (99.8%) @0.8x, remaining 0:33 RBU 100.0% UBU 98.3%
48356392960/48440016896 (99.8%) @0.7x, remaining 0:29 RBU 100.0% UBU 98.3%
48367403008/48440016896 (99.9%) @0.7x, remaining 0:26 RBU 100.0% UBU 98.3%
48378413056/48440016896 (99.9%) @0.7x, remaining 0:22 RBU 100.0% UBU 98.3%
48389390336/48440016896 (99.9%) @0.7x, remaining 0:18 RBU 100.0% UBU 98.3%
48400138240/48440016896 (99.9%) @0.7x, remaining 0:14 RBU 100.0% UBU 98.3%
48410984448/48440016896 (99.9%) @0.7x, remaining 0:10 RBU 100.0% UBU 98.3%
48421797888/48440016896 (100.0%) @0.7x, remaining 0:06 RBU 100.0% UBU 98.3%
48432709632/48440016896 (100.0%) @0.7x, remaining 0:02 RBU 100.0% UBU 98.3%
:-[ WRITE@LBA=168e800h failed with SK=5h/LOGICAL BLOCK ADDRESS OUT OF RANGE]: No space left on device
:-( write failed: No space left on device
/dev/sr0: flushing cache

Der Fehler am Ende scheint beim Löschen normal zu sein.
Hier die Daten des Brenners und des gelöschten Rohlings.

dieter@home:/> wodim -scanbus
scsibus1:
1,0,0 100) 'HL-DT-ST' 'BD-RE GGW-H20L ' 'YL02' Removable CD-ROM
1,1,0 101) *
1,2,0 102) *
1,3,0 103) *
1,4,0 104) *
1,5,0 105) *
1,6,0 106) *
1,7,0 107) *
dieter@home:/> dvd+rw-mediainfo /dev/sr0
INQUIRY: [HL-DT-ST][BD-RE GGW-H20L ][YL02]
GET [CURRENT] CONFIGURATION:
Mounted Media: 43h, BD-RE
Media ID: TDKBLD/Wfa
Current Write Speed: 2.0x4495=8991KB/s
Write Speed #0: 2.0x4495=8991KB/s
GET [CURRENT] PERFORMANCE:
Write Performance: 2.0x4495=8991KB/s@[0 -> 11826175]
2.0x4495=8991KB/s@[11826176 -> 23652351]
Speed Descriptor#0: 02/23652351 R@2.0x4495=8991KB/s W@2.0x4495=8991KB/s
BD SPARE AREA INFORMATION:
Spare Area: 650176/786432=82.7% free
READ DISC INFORMATION:
Disc status: complete
Number of Sessions: 1
State of Last Session: complete
Number of Tracks: 1
READ FORMAT CAPACITIES:
formatted: 23652352*2048=48440016896
00h(6000): 23652352*2048=48440016896
30h(6000): 23652352*2048=48440016896
30h(9000): 23259136*2048=47634710528
30h(1000): 24307712*2048=49782194176
31h(800): 24438784*2048=50050629632
READ TRACK INFORMATION[#1]:
Track State: complete
Track Start Address: 0*2KB
Free Blocks: 0*2KB
Track Size: 23652352*2KB
FABRICATED TOC:
Track#1 : 14@0
Track#AA : 14@23652352
Multi-session Info: #1@0
READ CAPACITY: 23652352*2048=48440016896

Woran könnte es liegen? Der Brenner dürfte ja in Ordnung sein?


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14. Jul 2008 9:09 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Zitat:
Verflixte Kiste. Es scheint nur bei Dual Layer Rohlingen Probleme zu geben, sobald die zweite Schicht begonnen wird. Ich habe gerade einen Single komplett gefüllt, geht einwandfrei. Komischerweise geht das Löschen eines Rohlings durch, wird aber in der Mitte für eine Weile extrem langsam.
Ich habe diese Probleme mit Dual-Layer-DVDs ebenfalls immer wieder. Ab und zu klappt es dann mal, dann wieder nicht. Er bleibt auch fast genau in der Mitte hängen. Evtl. ein Firmware-Problem des Brenners?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14. Jul 2008 9:35 
Ich tippe mal auf billiger Brenner + billiger Spindelrohling. Zumindest die doppelschichtigen sollte man schon einzeln kaufen. Der Brenner ist ein LG, die können von allem etwas, aber nichts richtig.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14. Jul 2008 10:44 
Offline
Pro-Linux
Benutzeravatar

Registriert: 15. Aug 1999 16:59
Beiträge: 3236
Wohnort: Bruchsal
Hi!

Eine Inkompatibilität zwischen Brenner und Rohling ist durchaus möglich; vielleicht mal die Brenngeschwindigkeit reduzieren.

Sinnvoll ist es auch, auf der Homepage der dvd-utils nachzusehen, was die neueste Version ist und ob vielleicht Probleme bekannt sind.

Grüße,
hjb

_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14. Jul 2008 13:54 
dieter@home:/> growisofs -Z /dev/sr0=/dev/zero
About to execute 'builtin_dd if=/dev/zero of=/dev/sr0 obs=32k seek=0'
/dev/sr0: "Current Write Speed" is 2.0x4390KBps.
1900544/48440016896 ( 0.0%) @0.0x, remaining 2973:25 RBU 100.0% UBU 1.7%
1900544/48440016896 ( 0.0%) @0.0x, remaining 4247:44 RBU 100.0% UBU 100.0%
1900544/48440016896 ( 0.0%) @0.0x, remaining 5946:50 RBU 100.0% UBU 100.0%
1900544/48440016896 ( 0.0%) @0.0x, remaining 7221:09 RBU 100.0% UBU 100.0%

Ist mir erst jetzt aufgefallen: Das sieht komisch aus. Kann es sein, das nach einem Upgrade auf die 11.0 noch ein paar Links unter /dev waren, die jetzt falsch zeigen? Wenn ja, hast du die Partition genullt, auf die sr0 zeigt. Oder der Brenner ist wirklich im Eimer.

Ansonsten versuch mal, ohne die ide-scsi Emulation auszukommen. Wahrscheinlich musst Du dafür einen Kernel selbercompilieren. Manchmal gibt es Probleme beim Schichtwechsel, wenn da kurz der Datenstrom abbricht. Ohne die Emulation geht es vielleicht besser.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14. Jul 2008 20:32 
Links sind alle richtig gesetzt, die Platten sind sda und sdb.
Das mit der ide-scsi Emulation muss ich mir mal ansehen, da könnte was dran sein. Ich kann mich erinnern, da früher schonmal Ärger gehabt zu haben. Ich dachte aber bisher, für Sata wird die Emulation nicht verwendet. Da kocht Novell wohl wieder eine eigene Suppe.
Dieser Rohling sollte jedenfalls zum Brenner passen, er war in der Packung mit drin.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 15. Jul 2008 12:54 
Wenn es wirklich ein SATA-Brenner ist, ignorier die Sache mit der SCSI-Emulation.
Schau mal welche Version der dvd+rw-tools Du hast. Mindestens 6.0 ist zu empfehlen, aktuell ist die 7.1.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 16. Jul 2008 6:09 
Manchmal sitzte ich aber wirklich auf meinen Augen. A weia!

> 1,0,0 100) 'HL-DT-ST' 'BD-RE GGW-H20L ' 'YL02' Removable CD-ROM

Laut Google ist das ein Sata-Brenner. Und das hier hätte ich auch nicht übersehen dürfen:

> Mounted Media: 43h, BD-RE
> Media ID: TDKBLD/Wfa
> formatted: 23652352*2048=48440016896
> READ CAPACITY: 23652352*2048=48440016896

Laut Paketliste kommt die Suse 11.0 mit den aktuellen dvd+rw-tools 7.1 aber nur mit Kernel 2.6.25. Die bieten Blueray-Unterstützung, aber vielleicht noch nicht richtig. Der aktuelle 2.6.26 hat da ja noch extra Patches für drin. Leider habe ich so einen Brenner noch nie selbst gesehen oder benutzt und kann da keine Hilfe geben.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 16. Jul 2008 23:27 
Offline

Registriert: 16. Jul 2008 22:59
Beiträge: 5
Ja, es ist ein Blueray-Brenner. Laut der dvd+rw-tools Seite muss man nichts besonders beachten, das Formatieren macht growisofs selbst. Aber ich habe bestimmt wieder etwas vergessen.
Stundenlanges Googeln hat nichts sinnvolles erbracht. Es wäre schon schön zu wissen, ob es mit den 50G überhaupt geht oder ich mir die Mühe sparen kann.


Nach oben
   
 Betreff des Beitrags: Ich habe es raus
BeitragVerfasst: 17. Jul 2008 22:31 
Offline

Registriert: 16. Jul 2008 22:59
Beiträge: 5
Es geht. Nach langem Herumprobieren und Rohlingen verschiedener Hersteller habe ich es hinbekommen.
Die Sache ist eigentlich einfach, aber ich bin einfach nicht draufgekommen. Es gab immer so eine Fehlermeldung:

:-[ WRITE@LBA=b48440h failed with SK=3h/WRITE ERROR - AUTO-REALLOCATION FAILED]: Input/output error
:-( write failed: Input/output error
/dev/sr0: flushing cache
:-[ SYNCHRONOUS FLUSH CACHE failed with SK=3h/ASC=A0h/ACQ=80h]: Input/output error

Der Grund ist, das genisoimage im Hintergrund kann nicht langsam genug arbeiten, wenn der Brenner an den Schichtwechsel kommt.
Man muss also das Image vorher erzeugen und dann mit growisofs -speed=2 -Z /dev/sr0=/var/tmp/image.iso brennen. Die Geschwindigkeitsangabe muss sein, sonst geht es nicht.
Bei der Größe darauf achten, dass man nur 45GB draufkriegt und nicht echte 50.


Nach oben
   
 Betreff des Beitrags: Re: Ich habe es raus
BeitragVerfasst: 18. Jul 2008 20:22 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Zitat:
Der Grund ist, das genisoimage im Hintergrund kann nicht langsam genug arbeiten,
Unwahrscheinlich. Normalerweise schreibt der die Daten nur in eine Pipe und blockiert, wenn da kein Programm was draus liest. Zumindest führt sowas nicht zu einem I/O Error, es sei denn, der Programmierer hat total was verbockt.
Zitat:
Man muss also das Image vorher erzeugen und dann mit growisofs -speed=2 -Z /dev/sr0=/var/tmp/image.iso brennen. Die Geschwindigkeitsangabe muss sein, sonst geht es nicht.
Bei der Größe darauf achten, dass man nur 45GB draufkriegt und nicht echte 50.
Ok. So funzt es zumindest.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 03. Aug 2008 16:23 
Offline

Registriert: 03. Mär 2006 23:16
Beiträge: 429
Anm: Es heißt "Blu-ray"
http://de.wikipedia.org/wiki/Blu-ray_Disc

_________________
mfg komsomolze


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 13 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de