Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 21. Nov 2018 8:34

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 8 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: perl1 needed
BeitragVerfasst: 19. Jul 2008 7:13 
Offline

Registriert: 19. Feb 2007 10:26
Beiträge: 17
Hallo,
ich betreibe unter RedHat8 einen Server. Gerne hätte ich für die bequeme Verwaltung webmin installiert. Dafür besorgte ich mir das Paket webmin-1.160-1.0.rh8.dag.noarch.rpm. Dieses Paket kann ich nicht installieren.
Fehlermeldung: perl1 (Net::SSLeavy) is needed, perl1(Non::Client)
Wer kann mir hier helfen?
DANK


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Jul 2008 8:24 
Auf der Webmin-Seite ist die aktuelle Version 1.42.
http://www.webmin.com/download.html
Deine Version ist von 2004, etwas alt.

Probiere es erst einmal damit und dann schauen wir weiter.


Nach oben
   
 Betreff des Beitrags: Versionenkonflikt?
BeitragVerfasst: 19. Jul 2008 8:37 
Offline

Registriert: 19. Feb 2007 10:26
Beiträge: 17
Die installierte Software (ich arbeite mit dem vorkonfigurierten Server Toshiba SG30) ist ein RedHat8, also auch aus der Zeit um 2004. Mein erster Versuch eine moderne Webmin-Software zu installieren, schlug sofort fehl. Gerne würde ich natürlich auch die Fehlermeldung verstehen und direkt bedienen (Erkenntnisinteresse;>).
Webmin wird in sehr vielen Versionen für unterschiedliche Distributionen angeboten. Mit welchem Paket soll ich den Versuch starten?
Und ich freue mich auf das Weiterschauen. Danke.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Jul 2008 12:16 
Wenn du OpenSSL installiert hast brauchst du auch noch ein Perl Modul namens
http://dag.wieers.com/rpm/packages/perl-Net-SSLeay/
wie die Fehlermeldung besagt.
Installiere dir das und dann installierst du Webmin.

Ja das ist das Dilemma bei so vielen Anbietern.

Das habe ich auf der Webmin Seite gesehen.
Zitat:
The best supported systems at the moment are Solaris, Linux (Redhat in particular) and FreeBSD.
Du scheinst aber wohl schon die richtige Version zu haben.
Ob man aktuelle Versionen installieren kann weiß ich nicht, da ich weder Red Hat noch Webmin benutze. Es scheint wohl Probleme mit den offiziellen .rpms zu geben.

http://dag.wieers.com/rpm/packages/webmin/
Sinnvoll auch
http://dag.wieers.com/rpm/packages/apt/

Ich hoffe das hilft schon mal weiter.


Nach oben
   
 Betreff des Beitrags: Der erste Schritt
BeitragVerfasst: 19. Jul 2008 12:36 
Offline

Registriert: 19. Feb 2007 10:26
Beiträge: 17
Danke. Der erste Schritt scheint erledigt. Noch aber kann ich Webmin nicht installieren.
Nach einer Signaturwarnung (wohl unerheblich) kommt noch der ursprünglich zweite Hinweis: perl1 (Mon::Client) is needed.
Natürlich würde ich mich sehr freuen........


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 20. Jul 2008 13:45 
Das ist der Link zum .rpm
http://dag.wieers.com/rpm/packages/perl-Mon/

Aber ich gab dir ja auch diesen Link. Das sollte dir helfen die Abhängigkeiten aufzulösen.
http://dag.wieers.com/rpm/packages/apt/


Nach oben
   
 Betreff des Beitrags: Convert::BER
BeitragVerfasst: 20. Jul 2008 17:27 
Offline

Registriert: 19. Feb 2007 10:26
Beiträge: 17
Hallo,
Vermutlich wird noch ein Paket verlangt. Die Installation von MON wird mit der Fehlermeldung perl (Convert::BER) ist needed by perl-Mon-0.11-1.rh80.dag.
Schon jetzt, herzlichen Dank.


Nach oben
   
 Betreff des Beitrags: Es hat geklappt
BeitragVerfasst: 28. Jul 2008 16:21 
Offline

Registriert: 19. Feb 2007 10:26
Beiträge: 17
Nachdem perl (Convert::BER) für redhat 8.0 erfolgreich installiert wurde verlangte webmin wieder das Script perl MON::Client). Ich befürchtete bereits eine Regelschleife aber nach abermaliger Installation dieses Scripts konnte ich webmin 1.160 erfolgreich installieren.
Ein Wehmutstropfen: Ich hoffte, mit webmin den ddclient ordentlich zum Laufen zu bekommen. Webmin 1.160 verwaltet jedoch diesen Client nicht.
Kann mir jemand einen Tipp geben?
Eigentlich sollte alles funktionieren. Das dd-Packet habe ich für redhat 8 erfolgreich installiert und die Einträge für dyndns sind mir eigentlich geläufig. Trotzdem funktioniert dieser Dienst nicht.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 8 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de