Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
normalen usern das mounten erlauben

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sicherheit
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Linux24325
Gast





BeitragVerfasst am: 28. Sep 2008 9:23   Titel: normalen usern das mounten erlauben

Hallo,

ich will, das eine Festplatte auch von normalen usern gemountet werden kann.

Dafür habe ich in der /etc/fstab den Eintrag

    /dev/sda4 /mnt/eigenedateien ntfs-3g rw,dev,suid,exec,auto,user,async 0 0

erstellt.

Wenn ich aber nun dieses mounten will bekomme ich immer die Fehlermeldung

Error opening partition device: Permission denied
Failed to mount '/dev/sda4': Permission denied


Wieso funktioniert das nicht??

danke
 

bamboocha
Gast





BeitragVerfasst am: 28. Sep 2008 17:55   Titel:

ist das verzeichnis /mnt/eigenedateien für den user schreibbar?
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 28. Sep 2008 17:55   Titel:

ntfs-3g verwendet fuse. Schaue nach, ob du in der fuse gruppe bist und ob der kernel (fuse unterstützt, bzw. das fuse module geladen ist (lsmod) - zum laden 'modprobe fuse').
 
Benutzer-Profile anzeigen Private Nachricht senden

Linux24325
Gast





BeitragVerfasst am: 28. Sep 2008 19:37   Titel:

das fuse modul ist geladen. Wie schauen ich nach ob ich in der fuse gruppe bin?

das Verzeichnis /mnt/eigenedateien gehört root und die gruppe ist users. Ich hab auch Schreibzugriff darauf.

Sonst noch ne Idee?

danke
 

PDA
Gast





BeitragVerfasst am: 29. Sep 2008 18:46   Titel:

Code:
# groups
 

Linux24325
Gast





BeitragVerfasst am: 03. Okt 2008 9:54   Titel:

ich bin in der gruppe eingetragen und hab auch mit chmod meine berechtigungen nochmals so geändert das ich schreibzugriff habe.

Wenn ich nun versuch die partion zu mounten kommt, das ich in der fstab eintragen muss allow_others jedoch hat dies auch nichts an meinem problem geändert.
 

Linux24325
Gast





BeitragVerfasst am: 04. Okt 2008 12:03   Titel:

nun bekomme ich folgende Fehlermeldung:
fusermount: failed to chdir to mountpoint: Permission denied
FUSE mount point creation failed
Unmounting /dev/sda4 (Eigene Dateien)


Jemand ne idee?
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 04. Okt 2008 13:02   Titel:

Mache das Verzeichnis für alle zugänglich (vor dem mounten als root):

Code:
chmod a+x /mnt/eigenedateien
 
Benutzer-Profile anzeigen Private Nachricht senden

Linux24325
Gast





BeitragVerfasst am: 05. Okt 2008 16:01   Titel:

wenn ich die Berechtigungen so ändere wie du oben geschrieben hat bekomme ich wieder diese Fehlermeldung:

fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf
FUSE mount point creation failed


Ich bin echt ratlos
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 05. Okt 2008 18:38   Titel:

Ähm, du schreibst oben, du hättest "allow_other" in /etc/fstab eingetragen. Die Fehlermeldung legt aber nahe, dies mit "user_allow_other" auch in /etc/fuse.conf zu gestatten.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Linux24325
Gast





BeitragVerfasst am: 06. Okt 2008 12:38   Titel:

Diese Datei existiert bei mir aber nicht.
Soll ich sie nun erstellen?
 

Linux24325
Gast





BeitragVerfasst am: 06. Okt 2008 12:39   Titel:

Diese Datei existiert bei mir aber nicht.
Soll ich sie nun erstellen?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 06. Okt 2008 14:50   Titel:

Schaden wird es vermutlich nicht. Gehören muss sie vermutlich root.root, Rechte sollten vermutlich rw-rw-r-- sein.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Linux24325
Gast





BeitragVerfasst am: 09. Okt 2008 18:43   Titel:

danke für deine Hilfe kann allerdings nicht sagen ob es nun funktioniert, da ich nun nicht mehr auf ntfs Datenträger schreiben kann hab ich mich dazu entschlossen OpenSuse 11 zu installieren. Sollte es da dann auch mithilfe eurer Vorschläge nicht funktionieren melde ich ich wieder.

danke an alle
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sicherheit Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy