Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Partitionierung Festplatte bei Inst. Linux neben wiinxp
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Umstieg auf Linux
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
mattore



Anmeldungsdatum: 29.09.2008
Beiträge: 15

BeitragVerfasst am: 29. Sep 2008 10:29   Titel: Partitionierung Festplatte bei Inst. Linux neben wiinxp

Hallo!
Ich möchte neben winxp opensuse11 auf dem Rechner installieren, komme aber mit dem Partitionieren nicht zurecht. Meine Festplatte (360GB) ist in 4 Bereiche partitioniert. Davon werden 2 von Windows genutzt, die anderen beiden sind partitioniert, aber ungenutzt. Beim Installationsversuch von Linux findet er die freien Bereiche nicht und möchte immer Windows verkleinern. Heißt dieses, daß das Installationsprogramm Linux auf die von Winxp genutzten Partitionen schreiben wird?
Wie kann ich in diesem Fall die beiden freien Partitionen für die Installation nutzen?
Ich habe die Installation an diesem Punkt immer wieder abgebrochen.

Könnte mit jemand weiterhelfen.
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 29. Sep 2008 13:59   Titel:

Hallo mattore

Kommst du bei der Installation bis zu diesem Bild? Ist dies genau der Schritt im Installationsprozess, wo du misstrauisch wirst? Falls ja, was steht denn bei dir da?

Durch Klicken dort auf die Überschrift "Partitionierung" solltest du in einen Zweig von YaST gelangen, wo du die Partitionen zur Installation auswählen kannst.

Grundsätzlich: Die Win-Partitionen zu verkleinern, heißt nicht, dass sie nachher überschrieben werden. Es heißt nur, dass die anderen Partitionen - genau die für Linux bestimmten - größer werden.

Es kann natürlich passieren, dass YaST die zur Installation vorgesehenen Partitionen (und nur die, die anderen bleiben unangetastet) formatieren muss. Aber so weit sind wir noch nicht...

Frohes Schaffen
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

mattore



Anmeldungsdatum: 29.09.2008
Beiträge: 15

BeitragVerfasst am: 29. Sep 2008 14:37   Titel: winxp und linux auf einer Festplatte

Hallo Lothar!
Vielen Dank für die schnelle Antwort!

Die Installation läuft bis zur Systemanalyse:
Anzeige: Die Partitionierung auf Festplatte /dev/sda kann mit dem Partitionierungswerkzeug `parted`nicht gelesen werde, das zum Ändern der Partitionstabelle verwendet wird.

danach drücke ich "ok"

hier erscheint dann der Partitionierungsvorschlag:
- Auslagerungs-Partition /dev/sdb1 (2.0GB) erstellen
- Root-Partition /dev/sdb2 (20.0GB) mit ex/l3 erstellen
- Partition/dev/sdb3 (127.0GB) für home mit ext3 erstellen
- Einlagerungspunkt von /dev/mapper/isw.bjgcbhggfe_ARRAY_part2 auf /windows/C setzen

bei der Möglichkeit zum "Partitionsaufbau erstellen" gibt es 4 Möglichkeiten, sich zu entscheiden:
- 1: BIOS RAID isw_bjgcbhggfe_Array
- 2: 2.IDE 149,0GB/dev/sda, ST3160023AS
- 3: 1.IDE 149.0GB /dev/sdb, ST3160023AS

oder - benutzerdefinierte Partitionierung (für Experten)

Da ich an dieser Stelle nicht weiß, wie es weiter geht, breche ich hier die Installation ab.
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 29. Sep 2008 15:49   Titel:

Hallo mattore

Der Reihe nach:

1. Die Meldung "Die Partitionierung auf Festplatte /dev/sda kann..." ist für mich Neuland. Anscheinend macht aber YaST in deiner Installation trotzdem brav weiter.

2. YaST spricht von /dev/sda und /dev/sdb. Hast du zwei Festplatten? Und auf welcher schlummert dein WinXP? Ist die Installation von LInux auf /dev/sdb für dich ok?

3. "Einlagerungspunkt von /dev/mapper..." sagt mir nichts. Aber ich betreibe auch kein Windows.

4. "benutzerdefinierte Partitionierung (für Experten)" sollte eigentlich für dich das Richtige sein. Ich arbeite immer damit, da ich mehrere openSUSE-Distributionen parallel betreibe und immer wieder eine ältere überschreibe. Die Bemerkung in Klammern betreffend Expertentum ist natürlich bitterer Ernst. Du wirst zwar immer gewarnt, bevor etwas Irreversibles passiert, aber du solltest schon wissen, wo du gerade bist und was du tust.

Frohes Schaffen
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 29. Sep 2008 16:16   Titel:

Das Grundproblem liegt vermutlich darin begründet, dass du ein Software-RAID0 über einen Controller mit BIOS-Erweiterung betreibst. Du hast laut Anzeige nicht eine große Festplatte, sondern 2 kleine, die zusammengeschaltet sind.

Schalte im Installationsprogramm mal mit Strg+Alt+F2 in eine Textkonsole um und gib dort
Code:

# fdisk -l /dev/sda /dev/sdb

ein und poste das Ergebnis. Dann bekommen wir die aktuelle Partitionierung der Festplatten zu sehen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

mattore



Anmeldungsdatum: 29.09.2008
Beiträge: 15

BeitragVerfasst am: 29. Sep 2008 19:57   Titel: Antworten

Guten Abend Günther und Janka !

Nun kurz die Antworten zu Euren Fragen bzw. Vorschlägen:

1) ich habe einen Dell Computer mit vorinstalliertem winxp (Herbst2006)
- Festplatte 320 GB Serial ATA RAID O Stripe (2x160GB 7200 rpm)
- die beiden Platten sind gekoppelt, ich konnte bisher nicht sehen, auf welcher
Festplatte winxp installiert ist oder ob die Programme auf beiden stehen;
- Arbeitsspeicher wären 3GB

2) Ich habe den vorgeschlagenen code von Janka eingegeben.
Das Ergebnis:
fdisk: invalid option--`1
Usage: fdisk [-b ssz] [-u] DISK Change partition table
fdisk -1 [-b ssz] [-u] DISK List partition table(s)
fdisk -s PARTITION Give partition sizes(s) in blocks
fdisk -v Give fdisk version
Here DISK something like/dev/hdb or /dev/sda and PARTITION is something like /dev/hda7
-u: give Start and End sector (istead of cylinder) units
-b: 2048 (for certain MO disks) use 2048-byte sectors

Ich hoffe, daß alles richtig geschrieben ist. Mir sagen die obigen Zeilen nicht viel, aber vielleicht könnt Ihr mir diese übersetzten.

Vielen Dank!

Viele Grüße aus Mecklenburg
Mathis
 
Benutzer-Profile anzeigen Private Nachricht senden

mattore



Anmeldungsdatum: 29.09.2008
Beiträge: 15

BeitragVerfasst am: 29. Sep 2008 20:02   Titel: Antwort

Natürlich meinte ich

Hallo Lothar und Janka !

Nach mehreren Stunden Computer-experimentieren habe ich den Namen verwechselt.

Entschuldigung!!!
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 29. Sep 2008 20:29   Titel:

Hallo mattore

Hast du "l" (Buchstabe) und "1" (Ziffer) verwechselt? Der Buchstabe "l" (kleines L) ist richtig als Übergabeparameter bei 'fdisk'..

Viel Glück
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

mattore



Anmeldungsdatum: 29.09.2008
Beiträge: 15

BeitragVerfasst am: 29. Sep 2008 21:05   Titel: Antwort

Hallo Lothar !

Es stimmt, es ist ein l (kleines L) und keine 1.

Heißt das, daß die vorgeschlagene Einteilung vom Installationsprogramm so durchlaufen könnte?

Viele Grüße Mathis
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 29. Sep 2008 21:12   Titel:

Wie lotharb schon schrieb: Nicht 1, sondern kleines l. Das sieht im Festbreitenfont nunmal so aus. Im normalen Font kann man es mit dem großen I verwechseln. So oder so Mist.

Dann solltest du dir überlegen, ob du das jetzige RAID0-Setup überhaupt beibehalten willst. Es ist von der Datensicherheit nämlich schlechter als eine einzelne Festplatte oder 2 einzelne Platten. Egal welche der beiden Platten mal irgendwann hin ist -- es sind dann grundsätzlich *alle* Daten futsch, weil die Daten ja zwischen den Platten aufgeteilt werden. Der Geschwindigkeitsvorteil, den RAID0 auf einem normalen PC gegenüber einer Einzelplatte bringt ist lächerlich gering, zumal mit einem Software-RAID wie du es hast.

Dell gehört in den Hintern getreten, dass sie so einen Mist ausgeliefert haben.

Zwei Möglichkeiten:
1. Windows sichern, BIOS-RAID abschalten, MS-Windows neu auf eine der Platten installieren, Linux auf die andere. Oder Windows und Linux auf die eine Platte und die andere Platte als reine Datenplatte benutzen.

2. Linux ebenfalls in das BIOS-RAID installieren. Setzt voraus, dass auf dem SuSE-Installationmedium ein passender Treiber vorhanden ist, der die RAID-Konfiguration auslesen kann. Scheint anhand der Meldungen oben gegeben zu sein.

Du solltest aber dennoch bitte mal den fdisk-Befehl ausführen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

mattore



Anmeldungsdatum: 29.09.2008
Beiträge: 15

BeitragVerfasst am: 01. Okt 2008 20:49   Titel: neuer Versuch

Hallo Lothar und Janka !

Beim Installieren hatte ich wahrscheinlich etwas nicht beachtet. Jedenfalls ging garnix mehr.
Deshalb schreibe ich von einem anderen Computer.

Die beiden Festplatten habe ich formatiert und eine Platte für windows und die zweite Platte für Linux eingerichtet. D.h. zuerst win auf Platte a installiert und danach Linux (opensuse 11.0) auf die Platte zwei installiert.
Funktionierte super.
Wenn ich jetzt den Rechner hoch fahre, erscheint im die Abfrage, ob ich linux, windows oder von CD starten möchte.

Mit linux oder auch CD starten funktioniert es auch weiter. Gehe ich aber auf windows erscheint kurz danach die Fehlermeldung:
rootnoverify (hd1;1)
chainloader (hd0,0)+1

und danach hilft nur noch strgaltentf. Ich komme auf die window-Platte nicht mehr rauf.
Vor der Linux-Instalation startete windows von der Festplatte ohne Probleme.

Muß ich noch etwas verändern?

Viele Grüße aus dem verregneten Mecklenburg!
Mathis
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 01. Okt 2008 21:48   Titel:

Irgendwas im GRUB-Bootlader macht Probleme. Starte mal Linux und poste den Inhalt der Datei /boot/grub/menu.lst.

Kannst du von Linux aus auf das MS-Windows-Dateisystem zugreifen? "Arbeitsplatz->Datenträger" oder auch einfach mit "mount" in der Konsole gucken, wo es eingehängt wurde.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

mattore



Anmeldungsdatum: 29.09.2008
Beiträge: 15

BeitragVerfasst am: 01. Okt 2008 22:01   Titel:

Hallo Janka!

Ich versuche es gerade. Mal sehen.

Mathis
 
Benutzer-Profile anzeigen Private Nachricht senden

mattore



Anmeldungsdatum: 29.09.2008
Beiträge: 15

BeitragVerfasst am: 01. Okt 2008 22:26   Titel:

Hallo !

Die Datei lässt sich nicht öffnen.
Der Zugriff auf windows funktioniert auch noch nicht.

Gruß Mathis
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 02. Okt 2008 7:40   Titel:

Hallo Mathis

Gib als root doch nacheinander mal ein:
Code:
cat /boot/grub/menu.lst

Code:
fdisk -l

und zeige uns, was deine Maschine antwortet, dann kriegen wir das schon auf die Reihe.

Grüße aus Franken
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Umstieg auf Linux Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy