gnupg sicherheitsabfrage umgehen

Software besorgen und anwenden
Antworten
Nachricht
Autor
Gnursel

gnupg sicherheitsabfrage umgehen

#1 Beitrag von Gnursel » 01. Nov 2008 12:06

Immer wenn ich eine Datei mit einem importierten Schlüssel verschlüsseln will, bekomme ich die nervige Abfrage:

Code: Alles auswählen

It is NOT certain that the key belongs to the person named
in the user ID.  If you *really* know what you are doing,
you may answer the next question with yes.

Use this key anyway? (y/N)
Ist ja schön und gut, daß es diesen Hinweis gibt, in meinem Fall aber hinderlich. Das Problem ist nun, wenn ich "--batch" angebe, dann erfolgt keine Verschlüsselung, er bricht mit einem Fehler (unusable public key" ab, und "--yes" als Option wird einfach ignoriert, er fragt mich trotzdem. "--batch --yes" geht auch nicht.

Wie bekomme ich diese Meldung bitte weg?

Oder, noch besser, gibt es eine Möglichkeit, eine Datei direkt mit einem Schlüssel zu verschlüsselnm ohne diesen erst importieren zu müssen?
Sodaß ich auch den Dateinamen des Schlüssels statt des im Schlüssel gespeicherten Namen nehmen kann?

Zu gnupg selber gibt es leider keine Alternative, ein weniger umständlichen Programm kommt daher nicht in Frage[/quote]

Gnursel

#2 Beitrag von Gnursel » 01. Nov 2008 13:15

Für kommende Generationen:

--trust-model always

Antworten