Truecrypt unter Opensuse 10.2 installieren

Antworten
Nachricht
Autor
inixlinux

Truecrypt unter Opensuse 10.2 installieren

#1 Beitrag von inixlinux » 13. Dez 2008 17:26

Hallo

ich habe versucht TrueCrypt auf meinem Openuse 10.2 System zu installieren jedoch bekahm ich dann immer die Meldung das libfuse2 nicht vorhanden ist.

Als ich nach folgender Anleitung vorging http://hochglanz.dyndns.org/?p=96 und die sources erstellen wollte erhielt ich diese Ausgabe an der Konsole:
  • Precompiling SystemPrecompiled.h
    SystemPrecompiled.h:18:26: warning: wx/hyperlink.h: Datei oder Verzeichnis nicht gefunden
    SystemPrecompiled.h:21:22: warning: wx/power.h: Datei oder Verzeichnis nicht gefunden
    Compiling Application.cpp
    GraphicUserInterface.h:33: error: ISO C++ forbids declaration of ‘wxHyperlinkCtrl’ with no type
    GraphicUserInterface.h:33: error: expected ‘;’ before ‘*’ token
    Application.cpp: In static member function ‘static TrueCrypt::DirectoryPath TrueCrypt::Application::GetExecutableDirectory()’:
    Application.cpp:64: error: ‘class wxStandardPaths’ has no member named ‘GetExecutablePath’
    Application.cpp: In static member function ‘static TrueCrypt::FilePath TrueCrypt::Application::GetExecutablePath()’:
    Application.cpp:69: error: ‘class wxStandardPaths’ has no member named ‘GetExecutablePath’
    make[1]: *** [Application.o] Fehler 1
    make: *** [all] Fehler 2
was muss ich machen, damit ich endlich truecrypt nutzen kann? Ich bin am verzweifeln

danke

inixlinux

#2 Beitrag von inixlinux » 19. Dez 2008 18:15

hat da niemand eine Lösung??

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#3 Beitrag von Janka » 19. Dez 2008 19:18

Zunächst mal gibt es für openSUSE10.2 seit ungefähr einem Monat keine Sicherheitsupdates mehr. Bevor du dir Gedanken über die Verschlüsselung des Systems machst, solltest du erst einmal auf ein sicheres System updaten. Ab openSuSE10.3 kannst du libfuse2 auch ganz einfach als Paket installieren und hast diese Probleme nicht.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

inixlinux

#4 Beitrag von inixlinux » 19. Dez 2008 23:43

Gibt es dann eine Möglichkeit auf OpenSuse 10.3 updaten so, dass meine installieren Progamme noch drauf sind oder muss ich da wieder ne neue CD brennen und alles runterlöschen?

danke

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#5 Beitrag von Janka » 20. Dez 2008 17:00

Du solltest besser gleich auf openSuSE11.0 updaten. Hab ich letztens bei den Rechnern hier auch gemacht und dabei keine größeren Probleme gehabt. Einfach die aktuelle DVD auf dem Netz holen, brennen, davon booten und dann im Installationsprogramm "Update" anwählen. Vorher sicherheitshalber zumindest ein Backup der persönlichen Daten (/home-Verzeichnis) machen.

Wichtig: immer dieselbe Architektur benutzen. Wenn du bei openSUSE10.2 also i386 (Pentium etc) gewählt hattest, musst du bei einem Update auch bei dieser Version bleiben. Update und gleichzeitiger Wechsel auf x86_64 ist nicht.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

inixlinux

#6 Beitrag von inixlinux » 21. Dez 2008 16:49

hat sich jetzt erledigt. Ich hab gleich OpenSuse 11 neuinstalliert, da ich im internet gelesen habe, dass es öffters mal Probleme gibt

danke

Antworten