Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 20. Nov 2018 9:09

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: USB2/FIREWIRE400 CardBus 32bit
BeitragVerfasst: 28. Jan 2009 13:45 
Hallo

Ich habe mir eine Cardbus Karte für mein Laptop IBM Thinkpad T22 zugelegt.
Nun aber läuft diese aber nicht. Mit dmesg habe ich mal nachgeschaut ob der kernel überhaupt darauf reagiert. Da konnte ich sehen, das ein neuer usb und eine ieee1394 Schnittstelle dazugekommen ist. Daraus entnehme ich das der Kernel zwar erkennt das an dem cardbus slot etwas dran ist aber der daemon ( pcmciautils denke ich mal) macht hier keine Ansltalten zu reagieren. Auch lsusb und lspci ergeben keine Erkenntnisse über model und verbauten chipsatz ( was ich übel finde). Ich habe schon gehört, das Cardbus und Linux unter Umständen ein leidiges Thema sein könnte.
Als Distri habe OpenSuse 10.3 mit dem Kernel 2.6.22.19-0.2.
Natürlich kann es sein, das ich ein Billig Teil aus China erwischt habe aber ich hoffe mal das mir da jemand helfen kann, dieser widerspenstigen cardbus-karte das Leben einzuhauchen.
Es ist übrigens eine USB2 FireWire Combo Cardbus32 Karte.


Nach oben
   
BeitragVerfasst: 28. Jan 2009 14:18 
Habe soeben eine info was das Modell angeht
laut yast Hardware info muss soll es ein Genesys Logic USB2.0 Hub sein
und FireWire ist laut der info ein VIA IEEE 1394 Host Controller.
Ich hoffe das kann etwas helfen.


Nach oben
   
BeitragVerfasst: 28. Jan 2009 14:54 
Und hier habe ich noch die Ausgabe von lspci



lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Ethernet controller: Intel Corporation 82557/8/9 Ethernet Pro 100 (rev 0c)
00:03.1 Serial controller: Agere Systems LT WinModem (rev 01)
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 13)
02:00.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
02:00.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 65)
02:00.3 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 28. Jan 2009 15:53 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Beide Controller auf der Karte werden von lspci (an Bus 02) gelistet. Die Cardbus-Bridge in deinem Rechner geht also.

Vielleicht ist das Hotplug noch nicht korrekt eingerichtet, so dass du usb_uhci und usb_ehci sowie ohci1394 nach dem Einstecken von Hand neu laden musst (rmmod+modprobe)? Was sagt lsusb?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
BeitragVerfasst: 28. Jan 2009 16:10 
hier die Ausgabe von lsusb

lsusb
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 005: ID 046d:09a4 Logitech, Inc.
Bus 001 Device 004: ID 0ea0:2126 Ours Technology, Inc. 7-in-1 Card Reader
Bus 001 Device 003: ID 045e:007d Microsoft Corp. Notebook Optical Mouse
Bus 001 Device 002: ID 05e3:0606 Genesys Logic, Inc.
Bus 001 Device 001: ID 0000:0000


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 28. Jan 2009 17:01 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Das "Device 001" an einem USB-Bus ist normalerweise der "Root Hub". Dass für den Root-Hub die ID 0000:0000 gemeldet wird, ist auch relativ normal. Was sagt lsusb, wenn du ein USB-Gerät an die Cardbus-Karte ansteckst? Was sagt dmesg in diesem Fall?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
BeitragVerfasst: 28. Jan 2009 18:16 
hier ist der dmesg auszug mit angeschlssener karte und einem usb2 stick
lsusb zeigt keine änderung



pccard: CardBus card inserted into slot 0
PCI: Enabling device 0000:02:00.0 (0000 -> 0003)
ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:02:00.0: UHCI Host Controller
uhci_hcd 0000:02:00.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:02:00.0: irq 11, io base 0x00001480
usb usb2: new device found, idVendor=0000, idProduct=0000
usb usb2: new device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: UHCI Host Controller
usb usb2: Manufacturer: Linux 2.6.22.19-0.2-default uhci_hcd
usb usb2: SerialNumber: 0000:02:00.0
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
PCI: Enabling device 0000:02:00.2 (0000 -> 0002)
ACPI: PCI Interrupt 0000:02:00.2[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
ehci_hcd 0000:02:00.2: EHCI Host Controller
ehci_hcd 0000:02:00.2: new USB bus registered, assigned bus number 3
ehci_hcd 0000:02:00.2: irq 11, io mem 0x34000900
ehci_hcd 0000:02:00.2: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb3: new device found, idVendor=0000, idProduct=0000
usb usb3: new device strings: Mfr=3, Product=2, SerialNumber=1
usb usb3: Product: EHCI Host Controller
usb usb3: Manufacturer: Linux 2.6.22.19-0.2-default ehci_hcd
usb usb3: SerialNumber: 0000:02:00.2
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
PCI: Enabling device 0000:02:00.3 (0080 -> 0083)
ACPI: PCI Interrupt 0000:02:00.3[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:02:00.3 to 64
ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[11] MMIO=[34000000-340007ff] Max Packet=[1024] IR/IT contexts=[4/8]
hub 3-0:1.0: over-current change on port 1
hub 3-0:1.0: over-current change on port 2
ieee1394: Host added: ID:BUS[0-00:1023] GUID[0011066600000003]


Nach oben
   
BeitragVerfasst: 28. Jan 2009 19:18 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Zitat:
hub 3-0:1.0: over-current change on port 1
hub 3-0:1.0: over-current change on port 2
Das ist das Problem. Die Ports melden übermäßigen Stromverbrauch. Ich habe das hier auch häufiger mit meinem Cardreader. Anscheinend kommt der nicht mit 500mA aus, oder die Cardbus-Karte meldet, dass sie nicht "powered" wäre, dann sind es nur 100mA. Versuch mal, einen Hub mit externer Stromversorgung anzuschließen. Evtl. musst du die Cardbus-Karte auch nochmal ein-austecken, um den Fehlerzustand zurückzusetzen.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
BeitragVerfasst: 28. Jan 2009 20:11 
Danke nochmal für deine zeit und ich habe an der cardbus karte eine kleine buchse an der seite entdeckt die wie ich annehme für eine externe stromversorgung dienen könnte.
Jetzt weis ich auch wozu das eine usb kabel mit dem kinch stecker am ende gut ist
Habe dieses usb kabel an dem usb 1.1 anschluss von dem laptop an der karte angeschlossen und sie geht jetzt.
Diese konfiguration von cardbus karten war mir bis heute unbekannt.

man lernt doch nie aus


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de