Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit bttv/xawtv

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Bart
Gast





BeitragVerfasst am: 30. Jan 2009 18:06   Titel: Probleme mit bttv/xawtv

Hi,

ich habe hier eine etwas ältere TV-Karte, für die ich die bttv-Parameter bereits gefunden habe. D.h. scantv findet mir diverse Fernsehkanäle (die zwar alle als "unknown", aber ich hoffe, das ist kein Problem - woher sollte es auch wissen, wie die Kanäle heißen).

Wenn ich allerdings xawtv mit dem so erzeugten .xawtv-File benutze, so sehe ich gar nix, xawtv gibt mir statt dessen beim Umschalten immer folgende Meldungen aus:

Code:
ioctl: VIDIOC_REQBUFS(count=2;type=VIDEO_CAPTURE;memory=MMAP): Die Ressource ist zur Zeit nicht verfügbar
ioctl: VIDIOC_DQBUF(index=0;type=VIDEO_CAPTURE;bytesused=0;flags=0x0 [];field=ANY;;timecode.type=0;timecode.flags=0;timecode.frames=0;timecode.seconds=0;timecode.minutes=0;timecode.hours=0;timecode.userbits="";sequence=0;memory=unknown): Eingabe-/Ausgabefehler


Was könnte die Ursache dafür sein? Mit den neueren 2.6er Kerneln sollte xawtv doch trotzdem funktionieren?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 30. Jan 2009 22:49   Titel:

Schon andere Programme wie z.B. tvtime oder mplayer ausprobiert? Was sagen die? Läuft parallel vielleicht noch ein anderer Player?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Bart
Gast





BeitragVerfasst am: 31. Jan 2009 15:15   Titel:

Beit tvtime sieht der Fehler zumindest anders aus, ist aber auch nicht wirklich hilfreich:

Code:
xvoutput: Received X error: BadAccess (attempt to access private resource denied)
xvoutput: Received X error: BadShmSeg (invalid shared segment parameter)         
xvoutput: Received X error: BadShmSeg (invalid shared segment parameter)         
xvoutput: Received X error: BadShmSeg (invalid shared segment parameter)         
Danke, daß Sie tvtime gewählt haben.


Ganz originell: Wenn ich ffmpeg im "video4linux"-Mode zum Grabben verwende, dann klappt zumindest der Zugriff auf /dev/video0, das Ergebnis ist allerdings nur ein komplett grünes Bild. Mit "video4linux2" verweigert ffmpeg die Arbeit komplett und encodiert nur den Audiostrom.
 

Bart
Gast





BeitragVerfasst am: 31. Jan 2009 18:18   Titel:

Hat sich erledigt - es war ein Hardwareproblem mit der Karte.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy