Linux zerschoosen um wieder neu zu installieren, kann nicht mehr booten

Forum für Leute, die von anderen Systemen auf Linux gewechselt haben oder den Umstieg planen
Antworten
Nachricht
Autor
dr_live
Beiträge: 2
Registriert: 03. Feb 2009 22:34

Linux zerschoosen um wieder neu zu installieren, kann nicht mehr booten

#1 Beitrag von dr_live » 03. Feb 2009 22:38

Hallo,

ich habe ein Fehler begangen, daß ich nicht mehr daraus komm.

Habe neben meinem Vista Betreibssystem noch Linux Installiert, dies habe ich jetzt gelöschet, indem ich die Linux Partitionen (root, swap und temp) per Windows gelöscht habe.
Nachdem ich dies gemacht habe kann ich nicht mehr booten, es ist nur GRUB> zu sehen.
Dann habe ich noch auf die gelöschte Linux Partition XP drauf installiert, könnte immernoch nicht mit Vista booten.
Meine Recovery-Partition ist auch nicht zu erreichen, was meine letzte hoffnung war.

Im internet habe ich herausgefunden das ich mit GParted eventuell weiter komme, versucht habe ich so einiges, hat aber nicht gebracht.
Falls einer mir helfen kann.

Bitte um Hilfe.

Will wieder mit Vista booten können.

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 03. Feb 2009 23:00

Die Dateien, die der GRUB zum Booten braucht, befinden sich vermutlich in der Linux-Partition, die du entfernt hast. Der Bootcode von GRUB befindet sich hingegen bei dir im MBR der Festplatte, wo auch die Partitionstabelle drin ist.

Um das MS-Windows wieder booten zu können, musst du den Original-MBR über den aktuellen drübermangeln. Für die Zukunft: Tu das *bevor* du die Linux-Partitionen löscht in MS-Windows mit dem Befehl "fixmbr" in der MS-Windows-Kommandozeile (cmd.exe).

Da du ja MS-Windows im Moment nicht booten kannst, musst du die passende MS-Windows Original-CD (nicht: Recovery-CD!) einlegen, davon Booten, dort die Wiederherstellungskonsole aufrufen und dann "fixmbr" eingeben. Danach runterfahren, CD aus dem Laufwerk und du solltest wieder normal booten können.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

dr_live
Beiträge: 2
Registriert: 03. Feb 2009 22:34

#3 Beitrag von dr_live » 04. Feb 2009 0:41

ich habe jetzt per Puppy-Linux mit der GParted funktion.
Neue Partitione erstellt und Linux wieder installiert, dass läst sich wieder hoch fahren.
Wenn ich versuche mit Vista zu starten bekomme ich so eine fehlermeldung:

Windows konnte nicht gestartet werden , da folgende Datei fehlt oder beschädigt ist:
<windows root>\system\hal.dll.
Installieren sie ein exemplar der oben angegebenen Datei erneut.

lotharb
Beiträge: 411
Registriert: 10. Feb 2002 21:39
Wohnort: Heroldsberg (ERH)

#4 Beitrag von lotharb » 04. Feb 2009 9:02

Hallo dr_live

Herzlich willkommen im PL-Forum!

Damit dein aktuelles Problem klar wird: Du hast Puppy-Linux installiert, und ein Teil dieser Installation war die Installation von GRUB in den MBR, korrekt?

Hat dein Puppy-Linux während der Installation registriert, dass da noch Windows-Partitionen sind, und hat es in das GRUB-Bootmenü eine entsprechende Option eingetragen?

Wenn du jetzt zweimal "ja" gesagt hast, dann liegt doch dein boot-Problem im Zuständigkeitsbereich von Windows. Und dann wird es u.U. schwer, hier Hilfe zu finden...

Frohes Schaffen
Lothar

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#5 Beitrag von Janka » 04. Feb 2009 13:59

Auch dieses Problem lässt sich mit MS-Windows-Bordmitteln lösen:
http://pcsupport.about.com/od/findbyerr ... haldll.htm

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten