Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Nov 2018 16:39

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 2 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Logitech Maus RX 250
BeitragVerfasst: 15. Feb 2009 15:53 
Offline
Benutzeravatar

Registriert: 19. Mai 2000 19:36
Beiträge: 529
Diese Maus RX 250 von Logitech habe ich als bulk für wenige Euros eingekauft. Klassisches Design, USB-Anschluss mit PS/2 Adapter. Sie hat ein "Tilt Wheel", das mittig liegende Mausrad lässt sich nach links und rechts kippen. Die 50 MB Windows Software/Treiber lassen dann dem Kipprad z.B. Seite vorblättern und Seite zurückblättern zuweisen - das gibt manchmal Problem bei der gleichen Maus beim Freund mit XP, WIN2K hat damit oft Probleme.

Ich selbst finde die Logitech Software erheblich zu gross und habe sie in meinem XP gar nicht installiert.

Für Linux habe ich mich aber interessiert, diese Funktion zu bewerkstelligen und bin gescheitert. Out of the box funktioniert es nicht und von vielen Versuchen ist im Moment
Code:
        Driver          "evdev"
        Option "HWHEELRelativeAxisButtons" "7 6"
in der xorg.conf übriggeblieben, nachdem alle vorangegangen Änderung rein gar nichts geändert haben oder die Maus disabled hatten.

xev und cat /proc/interrupts haben ergeben, dass Radkippen nie ein event auslöst. Ich glaube mittlerweile, dass das Radkippen von der Logitechsoftware über Stromschwankungen messen ermittelt wird.

Oder habe ich nur die richtigen Dokumente nicht gefunden? Läuft das bei jemanden hier wunschgemäß?

_________________
Es gibt keine dumme Fragen!

Killerhippy


Nach oben
   
 Betreff des Beitrags: Re: Logitech Maus RX 250
BeitragVerfasst: 15. Feb 2009 20:59 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Zitat:
Ich glaube mittlerweile, dass das Radkippen von der Logitechsoftware über Stromschwankungen messen ermittelt wird.
Sicher nicht. Aber für die Frage, ob ein Event kommt, ist es ohnehin unerheblich, wie dieser auf Hardwareseite genau ausgelöst wird.

Ich vermute, dass die Maus nicht im richtigen Modus ist. Da MS-Windows ohne Treiber nur "normale" Radmäuse abfragen kann, ist die Radmaus nach dem Einschalten garantiert in einem Modus, der die zusätzlichen Knöpfe nicht übermittelt. Erst der Spezialtreiber schaltet sie in den passenden Modus.

Es gibt in X WIMRE nur zwei Treiber für Radmäuse, "IMPS2" und "ExplorerPS2". Evtl. benutzt du den falschen oder es gibt
einfach keinen, der diese Maus in den "Wippenmodus" bringen kann.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 2 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de