Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Kein Netzwerkzugriff bei bestimmten Programmen

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
stimzuk
Gast





BeitragVerfasst am: 23. Feb 2009 20:08   Titel: Kein Netzwerkzugriff bei bestimmten Programmen

Hallo, ich habe einige Applikationen installiert (Thunderbird, Scribus,) bei denen ich nach der Installation auf keine Netzlaufwerke zugreifen kann. Ich kann mich nur auf dem lokalen Rechner bewegenn. Mit OpenOffice kann ich aber auf Netzlaufwerke zugreifen, mit den obigen Programmen nicht - also sollte der Netzwerkzugriff funktionieren. In den entsprechenden Foren gibt es auch keine Hilfe daher wende ich mich an Euch. Muß ich in Linux noch irgendwo was einstellen?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 23. Feb 2009 22:43   Titel:

Einige Programme können von sich aus auf SMB/CIFS-Netzlaufwerke zugreifen, z.B. alle KDE-Programme. Andere können das aber nicht, z.B. Firefox etc. Für solche Programme musst du die Netzwerkressource mounten. Dann wird sie ganz normal in das Dateisystem eingehängt und die Dateien darin können mit allen Linux-Programmen wie lokale Dateien benutzt werden.

CIFS-Netzwerkfreigaben mountest du so:
Code:

# mount -t cifs //servername/freigabename mountpoint

wobei "mountpoint" ein existierendes Verzeichnis beliebigen Namens sein muss, am besten extra für diesen Zweck angelegt und leer. Hat das mounten geklappt, ist unter diesem Verzeichnis das Netzlaufwerk eingehängt.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

stimzuk
Gast





BeitragVerfasst am: 01. März 2009 19:41   Titel:

Hab ich probiert aber ich bekomme ein fehlermeldung:

Kommando: mount -t cifs //sme/dat-x1 /sme/dat-x1
Password:xxxxxx

Nach der Passwordeingabe bekomme ich die Fehlermeldung:
mount error 13 = permission denied
refere to the mount.cifs (Cool manual page (e.g. man mount.cifs)

Dort werde ich aber auch nicht schlauer. Ping auf sme funktioniert, dh der Server ist erreichbar. Das Verzeichnis dat-x1 gibt es dort auch.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 02. März 2009 8:07   Titel:

stimzuk hat folgendes geschrieben::

Kommando: mount -t cifs //sme/dat-x1 /sme/dat-x1
Password:xxxxxx

Nach der Passwordeingabe bekomme ich die Fehlermeldung:
mount error 13 = permission denied

Das bedeutet, dass du nicht als Gast auf //sme/dat-x1 zugreifen darfst. In dem Fall muss du noch die Option -o user=... verwenden.

Code:

# mount -t cifs //sme/dat-x1 /sme/dat-x1 -o user=stimzuk

Hast du das Verzeichnis /sme/dat-x1 auf deinem Rechner angelegt? Das hängt jetzt nicht mit *diesem* Fehler zusammen, wäre dann aber gleich der nächste.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

stimzuk
Gast





BeitragVerfasst am: 02. März 2009 21:02   Titel:

Hallo Janka, vielen Dank hat geklappt. Du hast mir sehr geholfen. Mit Thunderbird habe ich noch mein Problem aber das krieg ich hoffentlich auch noch hin. Aber heute nicht mehr, mein Tag war schon lange.
LG
 

stimzuk
Gast





BeitragVerfasst am: 05. März 2009 18:24   Titel:

Hallo, ist doch nicht ganz OK. Nach dem Neustart ist alles wieder weg. Was muß ich tun damit die Laufwerke auch nach dem Neustart gemeountet bleiben? lg
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 05. März 2009 23:52   Titel:

Am einfachsten: Mach ein kleines Skript, das nur den Mount-Befehl enthält um dies dann über ein Desktopicon mit "Programm ausführen"->"als anderer Benutzer ausführen", "im Terminal ausführen" (damit das Kennwort eingetippt werden kann) aufzurufen.
Code:

#!/bin/sh
mount -t cifs //sme/dat-x1 /sme/dat-x1 -o user=stimzuk

Das Skript dann noch ausführbar machen. Dann einmal in den Autostart deiner Benutzersession hinein, fertig. Man kann das alles auch noch aufhübschen, im Kern muss aber immer der Mount-Befehl gegeben werden.

Automatisch einbinden über die /etc/fstab ist leider nicht so einfach, weil zu dem Zeitpunkt, an dem die Dateisysteme aus /etc/fstab automatisch gemountet werden üblicherweise das Netzwerk noch nicht aktiv ist. Außerdem müsste man das Kennwort im Klartext in die Datei schreiben.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

stimzuk
Gast





BeitragVerfasst am: 07. März 2009 23:02   Titel:

Hallo und danke. Hat prächtig funktioniert. Aber leider funktioniert das mount-Kommando nur unter root. Was muß ich machen um das mount Kommando als normaler user aufzurufen?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 08. März 2009 12:50   Titel:

stimzuk hat folgendes geschrieben::
Hallo und danke. Hat prächtig funktioniert. Aber leider funktioniert das mount-Kommando nur unter root. Was muß ich machen um das mount Kommando als normaler user aufzurufen?

Das Skript per sudo freigeben.

$ man sudoers

Sind eine Menge nützliche Beispiele drin.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

stimzuk
Gast





BeitragVerfasst am: 09. März 2009 8:23   Titel:

Hallo und danke, nur fürchte ich ich bin als Linux-Neuling mit der man-page von Sudo überlastet. Sorry. Ich verwende KDE3.5 und dort gibt es ebenfalls Sudo nur komme ich damit nicht ganz klar. Kannst Du mir da bitte ein wenig assistieren?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. März 2009 10:04   Titel:

Gegeben sei, dass das Skript /usr/local/bin/mycifsmount heißt. Dann muss in /etc/sudoers folgendes drinstehen
Code:

ALL ALL = NOPASSWD: /usr/local/bin/mycifsmount

Jetzt kann ein normaler Benutzer genau dieses Skript über
Code:

sudo /usr/local/bin/mycifsmount

aufrufen, ohne ein Kennwort eingeben zu müssen. Diesen Befehl kann man dann in einer Desktopverknüpfung eintragen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy