ältere Software Installieren

Software besorgen und anwenden
Antworten
Nachricht
Autor
henry0815

ältere Software Installieren

#1 Beitrag von henry0815 » 24. Mär 2009 14:34

Hallo Linuxer,

Ich habe ein Problem. Auf meinem Server läuft OpenSuse 10.3 im Runlevel 3 (Ich weis nicht das Ideale für einen Server aber das kann und beherrsche ich).
Dieser Server soll unter anderem für meinen Netz ein einen MySQL-Server zur Verfügung stellen.
Der Haken dadran ist aber das es ein MySQL 4.0.20 sein muss und im OpenSuse 10.3 wird aber ein 5.1 installiert.
Wo bekomme ich nun ein passenden Server her?

vielen Dank im voraus
henry

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 24. Mär 2009 14:44

Es *muss* tatsächlich genau diese Version sein? Wer behauptet das?

Wenn es tatsächlich diese alte Version sein *muss*, so kannst du dir das Quellpaket dieser Version von der openSuSE-Webseite besorgen und es für openSUSE10.3 neu bauen. Oder du musst es aus den Quelltexten kompilieren.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

henry0815

es muss

#3 Beitrag von henry0815 » 24. Mär 2009 23:33

Hallo Janka,
leider muss es so sein und sagen tut´s mein Chef der von Computern soviel Ahnung hat wie ein Schwein von fliegen. Aber er hat sich mal wieder trotz allen Warnungen ein Windows-Programm aufschwatzen lassen welches nur mit MySQL 4.0.20.xx zusammenarbeitet. Die Windows-Clients prüfen beim start ob die richtige MySQL-Version installiert ist und nur dann starten sie.
Hängt mit der Benutzerverwaltung im MySQL zusammen. Ab Version 4.1.xx ist die Benutzernamesübergabe anders.
Wie ich das Paket von Opensuse holen muss weis ich noch nicht, das habe ich noch nie gemacht.
Ich werde mal ein wenig Googlen mal sehn was ich finde. Ich melde mich dann wieder.

mfg Henry

Benutzeravatar
hjb
Pro-Linux
Beiträge: 3252
Registriert: 15. Aug 1999 16:59
Wohnort: Bruchsal
Kontaktdaten:

#4 Beitrag von hjb » 25. Mär 2009 11:43

Hi!

Ein Binärpaket von mysql.org könnte die einfachste Lösung sein.

Grüße,
hjb
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?

henry0815

dachte ich auch

#5 Beitrag von henry0815 » 25. Mär 2009 13:00

Ja das dachte ich auch nur bei MySQL.com fängt das Archiv erst mit der Version 4.1.xx an.
die alten Binärpakete gibt es da auch nicht mehr.

Antworten