wie war das mit reinstall modul?

Software besorgen und anwenden
Antworten
Nachricht
Autor
brum

wie war das mit reinstall modul?

#1 Beitrag von brum » 10. Apr 2009 9:44

Hallo,

lange war's her als man noch manuell mit den Modulen spielen mußte, nun habe ich's vergessen :( und SuSE aktualisiert ....

Also nach SuSE-Update funktioniert WLAN nicht mehr ohne Eingriff.

Nur nach Entladen und Laden des Treiber-Modul reagiert der knetworkmnager und verbindet.

Code: Alles auswählen

 # rmmod iwl4965 && modprobe iwl4965
Wer hat den Syntax für den re- oder postinstall in der /etc/modeles.conf noch im Kopf?

Danke und Frohe Ostern

LG
brum

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 10. Apr 2009 10:11

/etc/modules.conf gibt es schon lange nicht mehr. Seit Kernel 2.6 ist das /etc/modprobe.conf (mit geänderter, einheitlicherer Syntax).

Wenn du das Kernelmodul einmal entladen und dann neuladen musst, ist es vermutlich so, dass die Firmware für die WLAN-Hardware beim automatischen Laden des Moduls nicht da liegt, wo sie sollte, bzw. dass die Firmware dann nicht korrekt eingespielt wird. Spätere "modprobes" von den Netzwerk-Init-Skripten oder hotplug laden das Modul nicht neu, weil es ja schon geladen ist. Dadurch wird dann das Laden der Firmware nicht neu angestoßen und die Hardware funzt nicht.

Das ist jetzt aber noch stochern im Nebel. Guck mal nach, ob meine Vermutung zutrifft.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

brum

??

#3 Beitrag von brum » 10. Apr 2009 11:13

Hallo Janka,

danke für deine Reaktion.

Vielleicht stell ich mich etwas an, aber ich weiß trotzdem nicht weiter....
Noch mal die Zusammenfassung:

Vor dem Update funktionierte es automatisch.
Danach zeigt knetwerk Feldstärke und Netwerk-ID an, verbindet aber nicht.

Nach Neuladen kann man sich verbinden.
/var/log/messsage und lsmod zeigen vor und nach dem Laden exakt das selbe an.

Das Modul ist " Intel(R) Wireless WiFi Link 4965AGN driver for Linux, " , also ein ohne extra Fimware (firmware_class <- iwl4965,microcode) funktionierendes.

Was soll ich jetzt wo tun?

LG
sumsi

Antworten