LFS6.4 über SuSE11.1 erstellt?

Software besorgen und anwenden
Antworten
Nachricht
Autor
DH
Beiträge: 103
Registriert: 19. Feb 2006 13:31

LFS6.4 über SuSE11.1 erstellt?

#1 Beitrag von DH » 09. Mai 2009 22:26

Hallo Linuxfreunde,

unzufrieden mit SuSE11.1, da nach jedem Onlineupdate etwas anderes nicht mehr funktioniert, will ich jetzt von Grund auf neu beginnen.

11.1 als Hostsystem, LFS6.4 soll es sein!

Mache nun schon seit Tagen rum, war schon kurz vor dem Schluß, dann haut es mir bei glibc-2.8-20080929 die bash um die Ohren.

Meine Frage: Hat jemals jemand geschafft, LFS6.4 unter SuSE11.1 zu bauen?

Viele Grüße - Dieter

Benutzeravatar
hastifranki
Beiträge: 259
Registriert: 06. Mai 2006 19:58

#2 Beitrag von hastifranki » 10. Mai 2009 10:49

Hallo,

ich hatte mal LFS 6.3 unter openSUSE 10.3 gebaut. Dabei hatte ich folgendes Problem:

viewtopic.php?p=1134984&highlight=#1134984

Vielleicht hilft dir das weiter.

Viele Grüße
Frank

DH
Beiträge: 103
Registriert: 19. Feb 2006 13:31

#3 Beitrag von DH » 11. Mai 2009 9:37

Hallo Frank,

so weit wie Du in Deinem früheren Thread war ich auch schon, hatte aber nur den ersten Fehler.

Bei mir war es am Freitag ganz obskur:

Ich hatte nach erfolgreichem 'make' von GLIBC plötzlich einen versteckten Ordner namens '.Trash-0', in dem das Source- und Buildpaket im Subfolder files stand.

Im Sourcesverzeichnis war glibc... verschwunden.

Dieser Trash-Ordner gehört 'root', ausserdem war der Mountpoint /mnt/lfs verschwunden.

Gearbeitet hatte ich natürlich als User 'lfs', nur entpackt hatte ich mit grafischen Werkzeugen als 'root'. Kann's mir nur so vorstellen, daß beim Rechteverbiegen etwas in die Hose gegangen ist.

Nun ja, fange ich wieder von vorne an... :D :D

Hast Du auch etwas mit BLFS gemacht?

Viele Grüße - Dieter

Benutzeravatar
hastifranki
Beiträge: 259
Registriert: 06. Mai 2006 19:58

#4 Beitrag von hastifranki » 11. Mai 2009 19:08

Hallo Dieter,

hast du das Backup vor chroot angelegt?

http://oss.erdfunkstelle.de/lfs-de/6.4/ ... owner.html

Wenn ich mich richtig erinnere, habe ich kurz vor dem Betreten der chroot-Umgebung mit init 3 auf den Textmodus umgeschaltet. Als Browser habe ich Lynx verwendet.

BLFS hatte ich bis KDE 3.5 aufgebaut.

LFS oder BLFS würde ich nicht als Alternative zu anderen Distributionen sehen, da man sich um die Sicherheitsupdates immer selbst kümmern muss. Vielleicht ist Gentoo eine bessere Möglichkeit.

Viele Grüße
Frank

Antworten