rpm bauen schlägt fehl

Software besorgen und anwenden
Antworten
Nachricht
Autor
ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

rpm bauen schlägt fehl

#1 Beitrag von ElBlues » 28. Jun 2009 18:40

Hi,

ich versuche hier gerade mit einem eigentlich funtkionierenden .spec-File ein RPM mit dem Kommando

rpmbuild -vvv -bb --buildroot=/home/wuddin/buildroot/ fullpackage.spec

zu bauen. Das RPM sammelt ausschließlich Binaries ein und hat keinerlei Compile/Pre/Post-Scripts. Lustigerweise gibt es Fehlermeldungen zu Dateien, die dann nicht aufgelistet werden.

Was will mir das denn wohl sagen? Was genau hat rpmbuild da gefunden? Den Effekt habe ich unter Fedora 11...
Zuletzt geändert von ElBlues am 22. Aug 2009 16:37, insgesamt 1-mal geändert.
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 28. Jun 2009 19:27

Evtl. ist das buildroot noch mit Dateien aus einem fehlgeschlagenen alten Lauf vermüllt?

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

#3 Beitrag von ElBlues » 29. Jun 2009 6:17

Der buildroot ist nix weiter als ein Symlink auf "/" da ich die Dateien aus dem aktuellen System ziehen will - ist das vielleicht eine doofe Idee?
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

#4 Beitrag von ElBlues » 29. Jun 2009 17:00

OK, es lag tatsächlich daran: die neueren RPMs kann man nicht mehr aus dem / heraus bauen, wenn da noch andere Files rumliegen, die auch gar nicht mit in das RPM reinsollen, dann kommt diese seltsame Fehlermeldung...
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

Antworten