Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
ide=nodma funktioniert nicht mehr

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
TomoT
Gast





BeitragVerfasst am: 09. Jul 2009 8:54   Titel: ide=nodma funktioniert nicht mehr

Ich habe hier ein etwas exotisches Board mit VIA-CPU, das sein Betriebssystem von einem Compact Flash bootet. Damit das sauber funktioniert, war bisher immer der Kernel-Parameter ide=nodma notwendig (so weit ich mich erinnere, hat das mit Kernelversionen 2.6.26 auch funktioniert).

Jatzt habe ich einen selbst gebackenen 2.7.27.25er Kernel drauf, bei dem das nicht mehr klappt: egal ob mit oder ohne diesen Parameter, der Zugriff auf den Flash ist extram langsam und mit diversen lustigen Fehlermeldungen garniert, die sonst nur auftreten, wenn für den flash DMA aktiv ist.

Hat sich dab bei der 27er Kernelserie was geändert oder habe ich womöglich irgend eine wichtige Option in der Kernelkonfiguration zerschossen?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. Jul 2009 23:07   Titel:

Der Parameter heißt, wenn du die PATA/SATA-Treiber (libata) benutzt, "libata.dma=0". Du kannst auch "libata.dma=3" schreiben, dann wird DMA ausschließlich für CF-Karten abgeschaltet -- klappt aber nicht bei jedem Board, ausprobieren.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy