Desktop startet nur im Failsafemodus

Forum für Leute, die von anderen Systemen auf Linux gewechselt haben oder den Umstieg planen
Antworten
Nachricht
Autor
bursche73
Beiträge: 42
Registriert: 17. Sep 2006 10:42
Wohnort: Leer

Desktop startet nur im Failsafemodus

#1 Beitrag von bursche73 » 01. Aug 2009 17:26

Hallo,
ich habe gestern Abend, für mich problemlos, mit einer DVD Suse 11.1 installiert. Leider startet der Desktop KDE4 nur im Failsafemodus und nicht über die normale Startauswahl. Im Failsafe sind alle Programme und Einstellungen verfügbar und ich kann damit arbeiten.
Startet der PC nicht im Failsafe, dann habe ich keinen Zugriff auf den Desktop und muss alles über Befehlszeilen machen, was ich nicht möchte und auch nicht wirklich beherrsche.
Kann mir jemand einen Tipp geben, wie ich es schaffe, dass der Rechner sauber startet?
Danke im voraus.
Nicht fragen - einfach machen...und dann doch fragen... :-)

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 01. Aug 2009 19:31

Der Failsafemodus unterscheidet sich bei openSUSE durch folgende Bootparameter.

Code: Alles auswählen

ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe
Du kannst beim normalen Booten auf der Bootlader-Kommandozeile einen Parameter nach dem anderen hinzufügen um zu gucken, welche du brauchst, damit auch der "normale" Modus durchläuft. Anhand deiner Fehlerbeschreibung tippe ich allerdings direkt auf "x11failsafe". Falls es direkt mit diesem einen zusätzlichen Parameter funzt, können wir das Problem z.B. gezielt bei X11 suchen.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

bursche73
Beiträge: 42
Registriert: 17. Sep 2006 10:42
Wohnort: Leer

#3 Beitrag von bursche73 » 04. Aug 2009 19:37

Danke für die Info @Janka. Wo bzw. wann gebe ich den Code denn ein? Über die Konsole, wenn der PC im Failsafemodus gestartet ist oder im "Fehlerhaften"?
Ist dazu ein login erforderlich?
Nicht fragen - einfach machen...und dann doch fragen... :-)

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 05. Aug 2009 14:26

Du gibst das auf der Boolader-Kommandozeile ein. Der Bootlader ist das Programm, das startet, sobald das BIOS durch ist. Da drückst du irgendeine Taste, damit stoppt der automatische Bootvorgang. Dann kannst du tippen.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten