Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
störrisches Netzwerkinterface

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Kugelkopf
Gast





BeitragVerfasst am: 04. Nov 2009 9:26   Titel: störrisches Netzwerkinterface

Seit etwa zwei Wochen habe ich auf einem System folgendes Problem: Das Netzwerkinterface eth0 wird in unregelmäßigen und unvorhersehbaren Abständen immer wieder neugestartet. Einen klaren Zusammenhang mit irgendeiner Ursache, sei es System- oder Netzwerklast oder ein Verkabelungsproblem, habe ich nicht feststellen können. Kabel und Switch-Port habe ich vorsichtshalber mit einem anderen Computer gewechselt - ohne Änderung.
System ist eine OpenSUSE 11.1 64bit, Netzwerkkarte ist ein onboard 88E8001 Marvell Gigabit Interface, das mit skge betrieben wird.

Ausgabe von lspci:
Code:
00:0a.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller [11ab:4320] (rev 13)
        Subsystem: ASUSTeK Computer Inc. Marvell 88E8001 Gigabit Ethernet Controller (Asus) [1043:811a]                   
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-             
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-           
        Latency: 64 (5750ns min, 7750ns max), Cache Line Size: 64 bytes                                                   
        Interrupt: pin A routed to IRQ 11                                                                                 
        Region 0: Memory at fac00000 (32-bit, non-prefetchable) [size=16K]                                               
        Region 1: I/O ports at b800 [size=256]                                                                           
        Expansion ROM at fab00000 [disabled] [size=128K]                                                                 
        Capabilities: [48] Power Management version 2                                                                     
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)                               
                Status: D0 PME-Enable- DSel=0 DScale=1 PME-                                                               
        Capabilities: [50] Vital Product Data <?>                                                                         
        Kernel driver in use: skge                                                                                       
        Kernel modules: skge


Ausschnitt aus dem syslog von heute:
Code:

Nov  4 01:24:29 arthur kernel: skge eth0: Link is down.
Nov  4 01:24:32 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 01:45:46 arthur kernel: skge eth0: Link is down.
Nov  4 01:45:49 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 01:56:13 arthur kernel: skge eth0: Link is down.
Nov  4 01:56:16 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 02:19:17 arthur kernel: skge eth0: Link is down.
Nov  4 02:19:20 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 03:00:39 arthur kernel: skge eth0: Link is down.
Nov  4 03:00:42 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 03:41:17 arthur kernel: skge eth0: Link is down.
Nov  4 03:41:20 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 04:16:01 arthur kernel: skge eth0: Link is down.
Nov  4 04:16:04 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 04:21:09 arthur kernel: skge eth0: Link is down.
Nov  4 04:21:12 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 04:23:21 arthur kernel: skge eth0: Link is down.
Nov  4 04:23:24 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 04:45:07 arthur kernel: skge eth0: Link is down.
Nov  4 04:45:10 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 04:45:43 arthur kernel: skge eth0: Link is down.
Nov  4 04:45:46 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 04:48:52 arthur kernel: skge eth0: Link is down.
Nov  4 04:48:55 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:01:12 arthur kernel: skge eth0: Link is down.
Nov  4 05:01:15 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:01:36 arthur kernel: skge eth0: Link is down.
Nov  4 05:01:39 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:03:16 arthur kernel: skge eth0: Link is down.
Nov  4 05:03:19 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:03:40 arthur kernel: skge eth0: Link is down.
Nov  4 05:03:43 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:04:35 arthur kernel: skge eth0: Link is down.
Nov  4 05:04:38 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:16:29 arthur kernel: skge eth0: Link is down.
Nov  4 05:16:32 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:24:15 arthur kernel: skge eth0: Link is down.
Nov  4 05:24:19 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:49:43 arthur kernel: skge eth0: Link is down.
Nov  4 05:49:46 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:55:18 arthur kernel: skge eth0: Link is down.
Nov  4 05:55:21 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 05:56:38 arthur kernel: skge eth0: Link is down.
Nov  4 05:56:41 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 06:26:33 arthur kernel: skge eth0: Link is down.
Nov  4 06:26:36 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 06:27:10 arthur kernel: skge eth0: Link is down.
Nov  4 06:27:13 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 06:27:25 arthur kernel: skge eth0: Link is down.
Nov  4 06:27:28 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 06:28:01 arthur kernel: skge eth0: Link is down.
Nov  4 06:28:04 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both


Folgende im Netz für den skge-Treiber angegebene Tipps habe ich bereits ausprobiert: Begrenzung des Speichers mit mem=3G (4GB sind eingebaut) sowie noapic nolapic und acpi=off. Ergebnis ist, dass in den ersten 3 bis 4 Stunden nach einem Neustart keine Aussetzer mehr auftreten. Ganz bleiben sie nicht weg.
Ein Hardwarefehler scheint es nicht zu sein, probeweise habe ich mit einer 9.04 Kubuntu Livecd gestartet und 24 Stunden lang mit KTorrent Last erzeugt, ohne dass es einen einzigen Aussetzer gab.
Eine in Frage kommende Änderung in der betreffenden Zeit ist nur ein Update von KDE 4.3.1 auf 4.3.2, das anstehende Kernelupdate auf 2.6.27.37-0.1 habe ich erst gestern laufen lassen, jedoch ohne Änderung.

Hat jemand eine Idee, woran es liegen könnte?
 

Solver
Gast





BeitragVerfasst am: 04. Nov 2009 13:18   Titel:

Wie mein Vorposter richtig schreibt: Das ist ein hausgemachtes Problem. Das kommt davon, wenn sich unerfahrene Laien als die großen Administratoren aufspielen und statt der elementarsten Grundlagen bloß Einbildung mitbringen.
 

brum
Gast





BeitragVerfasst am: 04. Nov 2009 17:04   Titel: ubuntu

Und hast Du die Ausschriften von "lspci" , "ethtool eth0" und "lsmod" mal von suse mit ubuntu verglichen?

ipv6 aus?

Vielleicht ist der Treiber buggy, hast schon mal den sky2 oder sk98lin?

bye
brum
 

Kugelkopf
Gast





BeitragVerfasst am: 04. Nov 2009 23:02   Titel:

lspci und ethtool ergeben auf beiden das gleiche, die Ausgabe von lsmod habe ich im Moment nur für Suse zur Hand. Kubuntu verwendet jedenfalls auch den skge.

Code:

Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pg
        Wake-on: g
        Current message level: 0x0000ffff (65535)
        Link detected: yes


Code:

Module                  Size  Used by                         
skge                   43200  0                               
iptable_filter          3400  0                               
ip_tables              19464  1 iptable_filter               
x_tables               23376  1 ip_tables                     
joydev                 11376  0                               
nfsd                  268520  13                             
lockd                  71664  1 nfsd                         
nfs_acl                 3480  1 nfsd                         
auth_rpcgss            43344  1 nfsd                         
sunrpc                214920  15 nfsd,lockd,nfs_acl,auth_rpcgss
exportfs                4856  1 nfsd                           
af_packet              20232  2                               
ipv6                  292488  34                               
snd_pcm_oss            48624  0                               
snd_mixer_oss          16808  1 snd_pcm_oss                   
snd_seq                61504  0                               
binfmt_misc            10100  1                               
fuse                   57872  1                               
ext2                   68712  1                               
loop                   16660  0                               
dm_mod                 74064  0                               
snd_via82xx            28112  0                               
gameport               13112  1 snd_via82xx                   
snd_via82xx_modem      13828  0                               
snd_ac97_codec        122168  2 snd_via82xx,snd_via82xx_modem 
snd_mpu401_uart         8824  1 snd_via82xx                   
ac97_bus                2232  1 snd_ac97_codec                 
snd_rawmidi            25808  1 snd_mpu401_uart               
snd_seq_device          8604  2 snd_seq,snd_rawmidi           
snd_pcm                92064  4 snd_pcm_oss,snd_via82xx,snd_via82xx_modem,snd_ac97_codec
snd_timer              24968  2 snd_seq,snd_pcm                                         
rtc_cmos               13000  0                                                         
snd                    73576  11 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_via82xx,snd_via82xx_modem,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_pcm,snd_timer
shpchp                 32228  0                                                                                                                                             
soundcore               8368  1 snd                                                                                                                                         
i2c_viapro              9440  0                                                                                                                                             
rtc_core               21396  1 rtc_cmos                                                                                                                                   
k8temp                  5160  0                                                                                                                                             
sr_mod                 15860  0
serio_raw               6428  0
rtc_lib                 3560  1 rtc_core
pcspkr                  3064  0
i2c_core               35296  1 i2c_viapro
pci_hotplug            31864  1 shpchp
snd_page_alloc          9800  3 snd_via82xx,snd_via82xx_modem,snd_pcm
cdrom                  36200  1 sr_mod
sg                     35376  0
uhci_hcd               26840  0
ehci_hcd               54676  0
usbcore               195808  3 uhci_hcd,ehci_hcd
sd_mod                 35240  7
crc_t10dif              2152  1 sd_mod
edd                    10272  0
ext3                  140824  2
mbcache                 9484  2 ext2,ext3
jbd                    61752  1 ext3
ide_pci_generic         4652  0
via82cxxx               7100  0
ide_core              115068  2 ide_pci_generic,via82cxxx
ata_generic             6044  0
sata_via               11900  5
pata_via               10092  0
libata                183856  3 ata_generic,sata_via,pata_via
scsi_mod              178952  4 sr_mod,sg,sd_mod,libata
dock                   14212  1 libata
thermal_sys            14336  0
hwmon                   3720  2 k8temp,thermal_sys


Der sky2 unterstützt die Karte nicht, den sk98lin muss ich noch probieren. Hier sind die Meldungen aus dem syslog, wenn der skge geladen wird:

Code:

Nov  4 00:30:53 arthur kernel: skge 0000:00:0a.0: found PCI INT A -> IRQ 11
Nov  4 00:30:53 arthur kernel: skge 0000:00:0a.0: sharing IRQ 11 with 0000:00:0f.0
Nov  4 00:30:53 arthur kernel: skge 0000:00:0a.0: PCI: Disallowing DAC for device
Nov  4 00:30:53 arthur kernel: skge 1.13 addr 0xfac00000 irq 11 chip Yukon-Lite rev 9
Nov  4 00:30:53 arthur kernel: skge eth0: addr 00:15:f2:d0:01:4e
Nov  4 00:31:17 arthur ifup:     eth0      device: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
Nov  4 00:31:17 arthur kernel: skge eth0: enabling interface
Nov  4 00:31:17 arthur ifup:     eth0
Nov  4 00:31:17 arthur ifup: IP address: 10.0.0.1/8
Nov  4 00:31:17 arthur ifup:
Nov  4 00:31:19 arthur kernel: skge eth0: phy interrupt status 0x1c40 0xbc0c
Nov  4 00:31:19 arthur kernel: skge eth0: Link is up at 1000 Mbps, full duplex, flow control both
Nov  4 00:31:19 arthur kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready


ipv6 ist unter Suse eigentlich aus, das Modul ipv6 wird aber trotzdem geladen und lässt sich auch nicht einfach entfernen. Unter 9.04 ist ipv6 definitiv aktiviert. Das gibt mir ifconfig eth0 im Moment aus:

Code:

eth0   Link encap:Ethernet  HWaddr 00:15:F2:D0:01:4E
          inet addr:10.0.0.1  Bcast:10.255.255.255  Mask:255.0.0.0
          inet6 addr: fe80::215:f2ff:fed0:14e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:358019 errors:0 dropped:0 overruns:0 frame:562
          TX packets:444559 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:26475759 (25.2 Mb)  TX bytes:669339157 (638.3 Mb)
          Interrupt:11


Kann es sein, dass der sky2 nicht funktioniert, weil die Karte als rev 13 erkannt wird und nicht rev 12? Und wenn der skge wirklich einen Bug hat, warum dann immer nur schubweise und auch, wenn gar keine Netzwerkverkehr stattfindet und nicht z.B. nur bei Volllast?
 

Kugelkopf
Gast





BeitragVerfasst am: 09. Nov 2009 16:25   Titel:

Ein Unterschied, den ich bisher übersehen habe, ist mir erst jetzt aufgefallen: Kubuntu 9.04 verwendet einen 32bit Kernel, Suse ist hingegen 64bit. Kann es am Ende daran liegen? Ich habe leider keine 32bit Suse zum Testen da, werde mir aber eine besorgen.
 

brum
Gast





BeitragVerfasst am: 09. Nov 2009 17:56   Titel: sles

Warum zum Frell verwendet ihr keine zertifizierte Software für professionelle Anwendungen?

Das würde ich dann mal - 1. um knowhow-kompatibel zu bleiben - SLES vorschlagen.

2. Testversion ist uneingeschränkt (Support außen vor gelassen) und kostet nix
3. man bekommt für die Testversion 30 Tage Support.
4. Man kauft eigentlich nur den Support, möchte man dies, so gilt er dann für ein Jahr für alle Installationen - egal welcher Mix an Softwarestand.

Und der Support ist zeitnah, deutsch und qualifiziert Wink

Ich würde mich Anmelden, SLES aufspielen und das Problem den Support lösen lassen, sollte es noch vorhanden sein Wink
bye
brum
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy