Systemuhrzeit verstellt sich zu schnell

Antworten
Nachricht
Autor
edvl

Systemuhrzeit verstellt sich zu schnell

#1 Beitrag von edvl » 11. Nov 2009 18:42

Hallo,

hab ein Problem mit meiner Systemuhrzeit unter einem Debian-System.
Die Systemuhrzeit geht in einer Stunde um 6 Minuten nach.
Ich hab zwar eine Anleitung gefunden, aber eigentlich fehlt Ihr noch etwas.

1. Stelle die richtige Zeitzone ein.
2. Setze die Systemzeit wie oben beschrieben. ('date -s "YYYY-MM-TT hh:mm:ss"')
3. Lösche die Datei '/etc/adjtime'.
4. Setze die RTC mit: 'hwclock --debug --systohc --utc'.
(Läuft die RTC auf lokaler Zeit, verwende statt '--utc' die Option '--localtime').
5. Wiederhole Punkt 3 und 4.

Ich muss aber eine gewisse Zeit warten, bis sich die Zeitdifferenz aufgebaut hat.
D.h. nach 2-3 Stunden ist die Uhrzeit um ca. 20 Minuten verstellt.
Wenn ich jetzt den Befehl hwclock --debug --systohc --utc ausführe, berechnet er mir die Zeitdifferenz und schreibt es in die /etc/adjtime.

Ist ja schön und gut, aber müsste ich nicht noch eine weiter Uhrzeit von einem NTP-Server in den Befehl einbauen um die genaue Zeitdifferenz zu bekommen?
Sonst berechnet mir der Befehl die falsche Uhrzeit mit der evt. falschen RTC Uhrzeit und bekomme einen falschen Korrekturwert.

Ich hab auch einen NTPD laufen, der Synchronisert die Zeit nur einmal und nach 1 Stunde ist die Uhrzeit wieder falsch. (Wahrscheinlich drifftet diese zu stark ab)

Bitte um Hilfe

lustiger

#2 Beitrag von lustiger » 14. Dez 2009 14:11

Klarer Fall: dein Rechner ist zu schnell. Versuche mal ein Downgrade auf einen Pentium4 :P

Sorry

exc64user

rtc-time

#3 Beitrag von exc64user » 15. Dez 2009 17:56

Hallo

Nun ich glaube nicht das Dein Rechner zu schnell ist :-)
mir fallen dazu 2 Dinge ein:

1. Bios Batterie ist am ende ihres Lebens angelangt.

Dies müsste aber beim Booten des Rechners zu sehen sein. Es kommen dann Meldungen wie z.B Low Battery oder so gefolgt von einegen pip-Tönen des Bioses selber.

2. Der " Zeittakt" der rtc stimmt nicht.

Dies ist für gewöhnlich nichts besonderes denn die rtc ist ja kein präzisions-Chronometer
sondern ein Taktgeber für das System. Kleinere Zeitabweichungen sind durchaus normal.
Sollte aber deine Bios-Batterie noch gut sein und du bekommst keine seltsamen Boot pip-töne oder Meldungen, dann könnte dies aber auch am Bios selber liegen.
Soweit ich weis wird die rtc vom Bios aus gesteuert und wenn dies einen fehler hat dann könnte dies eine erklärung sein. Sind die Abweichungen konstant? sind es immer 6 min pro Stunde? Sind diese Abweichungen schon von Anfang an oder erst seit kurzem? Wenn sie seit dem Anfang sind dann würde ich auf das Bios tippen und ein Bios-update wird fällig. Sind diese Abweichungen aber erst seit einigen Tagen oder Wochen aufgetreten dann könnte es die Bios-Batterie sein- je nach alter deines Rechners und ob es ein Desktop oder Laptop ist. Bei Laptop's verbraucht sich die Bios-Batterie scheller weil es nicht so oft am netz hängt.




mfg

Ralf

Benutzeravatar
Janka
Beiträge: 3580
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 15. Dez 2009 19:14

Im laufenden Betrieb holt sich Linux die Zeit nicht aus der RTC, sondern aus einem hochpräzisen Timer. Die Uhr wird beim Systemstart mit dem Wert aus der RTC gestellt und beim Runterfahren wieder in die RTC geschrieben, eben mit dem "hwclock"-Werkzeug. Eine schlappe Batterie oder ein defekter RTC-Zeitgeber dürften sich nur während der Abschaltphasen äußern.

Ich vermute eher, dass das Löschen/Nullen von /etc/adjtime aus irgendeinem Grund nicht klappt. Evtl. läuft gerade ein NTP-Client?

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Papa Schlumpf

Re: Systemuhrzeit verstellt sich zu schnell

#5 Beitrag von Papa Schlumpf » 03. Jan 2010 9:22

Hatte vor einigen Monaten das selbe Problem. Nachdem absolut nichts geholfen hat, hab ich das Bios des Mainboards upgedated. Ursache war ein Bug im Bios, der die Timer unter bestimmten Prozessorkonstellationen zu schnell eingestellt hat ...
Seitdem läuft die Kiste ohne Probleme durch :-)

Antworten