ImageCD auslesen

Antworten
Nachricht
Autor
Benutzeravatar
catconfuser
Beiträge: 27
Registriert: 08. Jul 2002 8:36
Wohnort: Elz

ImageCD auslesen

#1 Beitrag von catconfuser » 03. Dez 2009 8:08

Hallo,

ich habe ein Problem mit diesen CDs, die man dazu bekommt, wenn man einen Film entwickeln lässt:

Eigentlich kenne ich das so, dass diese CDs ganz normal als Daten-CD erkannt werden, mit mehreren Unterordnern in denen die Bilder in verschiedenen Größen liegen. Unter Windows funktioniert das problemlos und ich meine, das auch schon unter Linux gemacht zu haben (kann mich nicht genau erinnern, die Digtalkamera verdrängt halt zunehmend die gute alte Spiegel-Reflex).

Als ich das gestern versuchte, wurde das Dateisystem auf der CD allerdings nicht erkannt, mit dem Ergebnis, dass KDE mir zwar ein neu hinzugefügtes "Volume" anzeigte, dass aber nicht im Dolphin auftauchte. K3b meint, es handele sich um eine leere CD.

Ich vermute mal, dass mir irgendein kleines Modul/Programm/Plugin fehlt, bisher habe ich keine Lösung ergoogeln können. Weiß hier jemand Rat?

Arch-Linux, KDE 4.3.3; die CD ist mit ImageCD beschriftet - es handelt sich nicht um eine Kodak Picture Disk

Benutzeravatar
Lateralus
prolinux-forum-admin
Beiträge: 1238
Registriert: 05. Mai 2004 7:35

#2 Beitrag von Lateralus » 04. Dez 2009 9:27

Vielleicht kann dir ein

Code: Alles auswählen

file /dev/cdrom
erstmal ein paar Informationen geben. Möglicherweise handelt es sich um udf statt iso9660 und es ist kein udf-Support im Kernel bzw. das udf-Modul nicht geladen?

Benutzeravatar
catconfuser
Beiträge: 27
Registriert: 08. Jul 2002 8:36
Wohnort: Elz

#3 Beitrag von catconfuser » 05. Dez 2009 17:29

Also ein dmesg ergibt:

Code: Alles auswählen

cdrom: This disc doesn't have any tracks I recognize!
sr 0:0:1:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 0:0:1:0: [sr0] Sense Key : 0x5 [current]
sr 0:0:1:0: [sr0] ASC=0x21 ASCQ=0x0
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
und so weiter.

Code: Alles auswählen

file /dev/sr0
ergibt

Code: Alles auswählen

/dev/sr0: block special

Benutzeravatar
Janka
Beiträge: 3580
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 06. Dez 2009 13:46

catconfuser hat geschrieben:Also ein dmesg ergibt:

Code: Alles auswählen

cdrom: This disc doesn't have any tracks I recognize!
sr 0:0:1:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 0:0:1:0: [sr0] Sense Key : 0x5 [current]
sr 0:0:1:0: [sr0] ASC=0x21 ASCQ=0x0
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
Das stinkt danach, dass entweder das Laufwerk hin ist oder die CDROM. Prüfe das mal mit

Code: Alles auswählen

$ cdrdao read-toc --device /dev/sr0 toc
Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Benutzeravatar
catconfuser
Beiträge: 27
Registriert: 08. Jul 2002 8:36
Wohnort: Elz

#5 Beitrag von catconfuser » 08. Dez 2009 8:00

Hallo Janka,

erstmal danke - leider geht das momentan etwas schleppend voran, da ich nur gelegentlich an den Rechner komme.

Ich kann allerdings ausschließen, dass das Laufwerk defekt ist (direkt nach meinen Fehlversuchen mit der ImageCD habe ich eine selbst gebrannte CD nochmal kopiert).

Die ImageCD funktioniert unter Windows XP einwandfrei. Als Dateisystem wird mir unter Eigenschaften "CDFS" angezeigt. Laut Google ist das Microsofts Bezeichnung für iso9660. Da ich mit -t iso9660 aber auch nicht mounten konnte, handelt es sich eventuell um eine nicht ganz standard-konforme Umsetzung. Sobald ich wieder die Gelegenheit habe, werde ich mal ein bisschen mit 'dd' rumspielen und ich will mir mal http://users.elis.ugent.be/~mronsse/cdfs/ anschauen

Benutzeravatar
Janka
Beiträge: 3580
Registriert: 11. Feb 2006 19:10

#6 Beitrag von Janka » 08. Dez 2009 12:06

Nimm bitte cdrdao zur Analyse. Dieses Programm gibt nämlich die tatsächliche Track-Struktur aus. Alles andere ist bei diesem Problem stochern im Nebel.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Benutzeravatar
catconfuser
Beiträge: 27
Registriert: 08. Jul 2002 8:36
Wohnort: Elz

#7 Beitrag von catconfuser » 08. Dez 2009 19:06

Code: Alles auswählen

$ cdrdao read-toc --device /dev/sr0 toc
Cdrdao version 1.2.3rc2 - &#40;C&#41; Andreas Mueller <andreas@daneb.de>
/dev/sr0&#58; MATSHITA UJ-840D      Rev&#58; 1.00
Using driver&#58; Generic SCSI-3/MMC - Version 2.0 &#40;options 0x0000&#41;

ERROR&#58; Inserted disk is empty.
Das behauptet k3b auch.

???

Benutzeravatar
Janka
Beiträge: 3580
Registriert: 11. Feb 2006 19:10

#8 Beitrag von Janka » 08. Dez 2009 22:33

Das sollte dir zu denken geben. Ich hatte z.B. mal ein Laufwerk von LG am Wickel, das keine CD-Rs lesen konnte. Brennen konnte es sie und sie haben in einem anderen Laufwerk auch hervorragend funktioniert. Nur halt in dem Brenner nicht (Multisession-Brennen ging logischerweise auch nicht). CD-ROM und CD-RWs konnte derselbe Brenner hingegen hervorragend lesen und auch brennen.

Kurz: Es gibt keinen schwachsinnigen Fehler, der nicht irgendwo implementiert ist.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

komsomolze
Beiträge: 430
Registriert: 03. Mär 2006 23:16

#9 Beitrag von komsomolze » 09. Dez 2009 6:21

Code: Alles auswählen

file /dev/sr0
ergibt

Code: Alles auswählen

/dev/sr0&#58; block special
Bei sowas:

Code: Alles auswählen

file -s /dev/sr0


Bei gezippten wie den xen-Kerneln:

Code: Alles auswählen

$ file /boot/vmlinuz-2.6.26-2-xen-686 
/boot/vmlinuz-2.6.26-2-xen-686&#58; gzip compressed data, from Unix, last modified&#58; Thu Nov  5 00&#58;23&#58;36 2009, max compression

$ file -z /boot/vmlinuz-2.6.26-2-xen-686 
/boot/vmlinuz-2.6.26-2-xen-686&#58; ELF 32-bit LSB executable, Intel 80386, version 1 &#40;SYSV&#41; &#40;gzip compressed data, from Unix, last modified&#58; Thu Nov  5 00&#58;23&#58;36 2009, max compression&#41;
mfg komsomolze

Benutzeravatar
catconfuser
Beiträge: 27
Registriert: 08. Jul 2002 8:36
Wohnort: Elz

#10 Beitrag von catconfuser » 10. Dez 2009 22:23

Tja, leider

Code: Alles auswählen

$ file -s /dev/sr0
/dev/sr0&#58; empty
cdfs hat auch nichts gebracht, dd kopiert 0 Byte, od gibt nur 000000 aus - ich geb es auf :(

Antworten