PHP / Servervariablen und Apache-Konfiguration

Software besorgen und anwenden
Antworten
Nachricht
Autor
ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

PHP / Servervariablen und Apache-Konfiguration

#1 Beitrag von ElBlues » 04. Apr 2010 10:40

Hi,

die neuere PHP-Version bringt mal wieder eine inkompatible Änderung mit, die mich hier gerade die Haare ausraufen lässt.

Die globale Variable $_SERVER['PHP_AUTH_USER'] enthält bei mir plötzlich nichts mehr. Laut Doku darf das aber nur passieren, wenn PHP als CGI verwendet wird und nich als Apache-Modul eingebunden wird. Bei mir (Fedora 12) gibt es in der Apache-Konfiguration aber ein mod_php.

So, was nun? Die PHP-Skripte kann ich leider nicht in die Tonne treten, so gerne ich es täte...
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

Benutzeravatar
Janka
Beiträge: 3580
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 04. Apr 2010 14:10

Kannst du stattdessen auch REMOTE_USER verwenden? Das sollte immer gesetzt sein.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

#3 Beitrag von ElBlues » 04. Apr 2010 16:42

Du meinst $_SERVER['REMOTE_USER']? Die existiert genau so wenig...
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

#4 Beitrag von ElBlues » 13. Apr 2010 7:44

OK, das Problem hat sich - vermutlich mit einem der letzten Updates - von selbst gelöst.
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

Antworten