RawTherapee unter OS 11.3

Software besorgen und anwenden
Antworten
Nachricht
Autor
exc64user

RawTherapee unter OS 11.3

#1 Beitrag von exc64user » 04. Sep 2010 15:39

Hallo Leute

Wollte gerade mal RawTherapee unter Suse 11.3 installieren da kam in der Shell eine frecht seltsame Fehlermeldung.

(rt:8135): Gtk-WARNING **: Fehler beim Laden des Symbols: Bild »/usr/share/icons/oxygen/16x16/actions/edit-find.png« konnte nicht geladen werden: Schwerer Fehler in PNG-Bilddatei: Incompatible libpng version in application and library

(rt:8135): Gtk-WARNING **: Fehler beim Laden des Symbols: Bild »/usr/share/icons/oxygen/16x16/actions/edit-find.png« konnte nicht geladen werden: Schwerer Fehler in PNG-Bilddatei: Incompatible libpng version in application and library
terminate called after throwing an instance of 'Gdk::PixbufError'
./rtstart: Zeile 4: 8135 Abgebrochen `dirname "$0"`/rt "$*"



So wie ich die Sache sehe, habe ich eine völlig inkompatible png Version aber kann das sein?

ich bitte um eueren Rat


mfg


Ralf

Benutzeravatar
Janka
Beiträge: 3578
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 04. Sep 2010 19:21

Nein, die libpng ist inkompatibel zur Applikation. Offensichtlich wird die als Plugin geladen, so dass erst eine Fehlermeldung kommt, während RawTherapee schon läuft.

Bring mal libpng auf den neuesten Stand.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

exc64user

RawTherapee unter OS 11.3

#3 Beitrag von exc64user » 04. Sep 2010 20:59

hallo janka

vielen dank für deine antwort
die libpng zu aktuallisieren würde ich ja gerne tun aber unter opensuse 11.3 wird keine neuere unter yast angeboten zumindest habe ich keine neueren gefunden.
seltsam ist nur das rawtherapee unter suse 11.2 problemlos läuft und da ist die libpng noch etwas älter.
bei rawtherapee handelt es sich um die version 2.4.1 diese lief auch mal unter suse 11.0.
irgendwie werde ich da nicht so ganz schlau daraus.
könnte es helfen eine andere libpng als die von suse zu installieren?

Benutzeravatar
Janka
Beiträge: 3578
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 04. Sep 2010 23:42

In diesem Fall solltest du eher eine aktuellere Version von RawTherapee benutzen. Die libpng nicht downgraden, dadurch gehen nur etliche andere Programme, die diese benutzen, nicht mehr.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

exc64user

RawTherapee unter OS 11.3

#5 Beitrag von exc64user » 05. Sep 2010 11:42

Hallo Janka

da haste recht aber die neueste version ist rawtherapee 3.0 alpha1 und noch nicht optimal für einen produktiven Einsatz gedacht. Habe es aber installiert mal sehen wie es läuft.
Allternativ habe ich noch ein anderes Programm gefunden - Rawstudio-1.2.rpm.
Nicht ganz so umfangreich wie Rawtherapee aber für den Anfang wird´s reichen.


mfg


Ralf

Antworten